Compartir a través de


Errores durante una migración de carpetas públicas

Síntomas

Durante una migración de carpetas públicas, experimenta uno de los siguientes problemas:

  • No se puede quitar un buzón de carpeta pública principal

    Al intentar revertir una migración de carpetas públicas, se bloquea en el paso para quitar el buzón de carpeta pública principal. Además, recibe uno de los siguientes mensajes de error:

    No se pudo realizar la operación porque "Mailbox1" coincide con varias entradas.

    El buzón "Mailbox1" es el buzón de carpeta pública principal para los usuarios. Para quitar este buzón, quite primero todos los demás buzones de carpetas públicas.

  • No se puede crear un punto de conexión de migración de carpetas públicas

    Al intentar crear un punto de conexión de migración de carpetas públicas, recibe uno de los siguientes mensajes de error:

    Ya se agregó un elemento con la misma clave.

    Varios usuarios de buzones coinciden con la identidad "Mailbox1". Especifique un valor único.

  • Error en la migración de carpetas públicas

    Al analizar el informe de migración de las solicitudes de migración de buzón de carpeta pública con errores, verá la siguiente entrada de error:

    Varios usuarios de buzones coinciden con la identidad "Mailbox1". Especifique un valor único.

Causa

Este problema se produce si se cumplen una de las condiciones siguientes o ambas:

  • Los buzones de carpetas públicas que se eliminan temporalmente tienen los mismos nombres que los buzones activos.
  • El buzón de carpeta pública principal o el buzón de carpeta pública secundario tiene un objeto CNF (conflicto) huérfano.

Solución

Para resolver este problema, siga estos pasos:

Paso 1: Quitar buzones de carpetas públicas eliminados temporalmente que tengan los mismos nombres que los buzones activos

Para buscar y quitar buzones de carpetas públicas eliminados temporalmente que tengan los mismos nombres que los buzones activos, siga estos pasos:

  1. Conéctese al PowerShell de Exchange Online.

  2. Para obtener los buzones (incluidos los buzones de carpeta pública eliminados temporalmente), ejecute el siguiente cmdlet:

    Get-Recipient  -IncludeSoftDeletedRecipients -RecipientTypeDetails publicfoldermailbox |fl Name, OrganizationalUnit, DistinguishedName, ExchangeGuid
    

    Busque "Objetos eliminados temporalmente" en la salida y compruebe si el nombre del buzón eliminado temporalmente correspondiente es el mismo que el de cualquier buzón activo.

    Este es un ejemplo de la salida:

    Nombre: Mailbox1
    OrganizationalUnit: <Domain_name.prod.outlook.com/Microsoft> objetos hosted Organizations/contoso.onmicrosoft.com/Soft Deleted de Exchange
    DistinguishedName: CN=Mailbox1,OU=Soft Deleted Objects,OU=contoso.onmicrosoft.com,OU=Microsoft Exchange Hosted Organizations,DC=<Domain_name,DC>=PROD,DC=OUTLOOK,DC=COM
    ExchangeGuid: <Guid_number>

    Nombre: Mailbox1
    OrganizationalUnit: <Domain_name.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com
    DistinguishedName: CN=Mailbox1,OU= contoso.onmicrosoft.com,OU=Microsoft Exchange Hosted Organizations,DC=<Domain_name,DC>=PROD,DC=OUTLOOK,DC=COM
    ExchangeGuid: <Guid_number>

    Nota: Si no se encuentra ningún buzón de carpeta pública eliminado temporalmente en la salida, vaya a "Paso 2: Quitar todos los buzones de carpetas públicas huérfanas existentes".

  3. Para quitar el buzón de carpeta pública eliminado temporalmente, ejecute el siguiente cmdlet:

    Remove-Mailbox -PublicFolder "<ExchangeGuid>" -PermanentlyDelete
    

    Notas:

    • En este cmdlet, reemplace <ExchangeGuid por> el GUID que obtuvo de la salida del cmdlet en el paso anterior.
    • Repita este cmdlet hasta que todos los buzones de carpetas públicas eliminados temporalmente se eliminen de forma rígida.

Paso 2: Quitar todos los buzones de carpetas públicas huérfanas existentes

Para buscar y quitar todos los buzones de carpetas públicas huérfanas existentes, siga estos pasos:

  1. Conéctese al PowerShell de Exchange Online.

  2. Busque buzones de carpetas públicas de CNF huérfanos mediante la ejecución de los siguientes cmdlets:

    Get-Mailbox –PublicFolder | fl Name,Identity,ExchangeGuid,Guid
    Get-Mailbox -PublicFolder -SoftDeletedMailbox | fl Name,Identity,ExchangeGuid,Guid
    

    Si los cmdlets no notifican ningún buzón de carpeta pública huérfano de CNF, ejecute el siguiente cmdlet:

    Get-Recipient -RecipientTypeDetails PublicFolderMailbox -IncludeSoftDeletedRecipients | fl Name,Identity,ExchangeGuid,Guid
    

    Este es un ejemplo de la salida de este cmdlet en el que el objeto tiene el valor CNF en el nombre y la identidad.

    Captura de pantalla de la salida del comando en la que está resaltado ExchangeGuid.

  3. Para quitar un buzón de carpeta pública huérfano individual, ejecute el siguiente cmdlet:

    Remove-Mailbox -PublicFolder -RemoveCNFPublicFolderMailboxPermanently <ExchangeGuid> 
    

    Nota: En este cmdlet, reemplace <ExchangeGuid> por el valor que obtuvo de la salida del cmdlet en el paso 2 para los objetos de buzón que tienen el valor "CNF" en Nombre e identidad.

    Si el cmdlet del paso 2 notifica varios buzones de carpetas públicas huérfanos, puede encontrarlos y quitarlos en un lote mediante la ejecución del siguiente cmdlet:

    $soft= Get-Recipient -RecipientTypeDetails PublicFolderMailbox –IncludeSoftDeletedRecipients ; foreach ($mbx in $soft){if ($mbx.Name -like "*CNF:*" -or $mbx.identity -like "*CNF:*") {Remove-Mailbox -PublicFolder $mbx.ExchangeGUID.GUID -RemoveCNFPublicFolderMailboxPermanently}}