Corregir problemas de autenticación en aplicaciones de Office cuando intenta conectarse a un servicio de Microsoft 365
Síntomas
Se produce un error de autenticación automáticamente en algunas aplicaciones de Microsoft Office y Outlook pueden entrar en el estado "Se necesita contraseña" sin ninguna interacción. Además, cuando realiza una llamada API al administrador de cuentas web a FindAllAccountsAsync, es posible que vea el código de error "-2147024809" en los registros de Microsoft Entra o en los registros del cliente de Office.
Importante
Este problema solo ocurre en equipos que ejecutan Windows 10, versión 1703 o posterior y Microsoft 365, versión 1807 o posterior.
Causa
El problema de autenticación se produce debido a la falta de información del paquete sobre la Biblioteca de autenticación de Active Directory (ADAL) o Live ID.
Solución
Sugerencia
Para diagnosticar y corregir automáticamente varios problemas comunes al iniciar sesión en Office, puede descargar y ejecutar el Asistente de soporte y recuperación de Microsoft.
Para solucionar este problema, use PowerShell para reinstalar los paquetes para el complemento WAM de Microsoft Entra (para cuentas organizativas o profesionales) y Live ID (para cuentas personales como @outlook.com, @hotmail.com, etc.). Para ello, siga estos pasos:
Haga clic con el botón derecho en el icono de Windows de la barra de tareas y, a continuación, seleccione Windows PowerShell (Administrar).
Si aparece una ventana de Control de cuentas de usuario (UAC), seleccione Sí para iniciar PowerShell.
Si su problema es sobre una cuenta profesional, tiene que solucionar el problema del paquete del complemento WAM de Microsoft Entra. Ejecute el siguiente comando en la Consola de comandos:
if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
Si tu problema es sobre una cuenta personal, tiene que solucionar el problema con el paquete de Live ID. Ejecute el siguiente comando en la Consola de comandos:
if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
Después de ejecutar los comandos y de que se hayan completado sin errores, es posible que vea un indicador de progreso rápido o un resultado de estado que contenga información sobre la instalación del paquete.