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No se puede iniciar sesión en aplicaciones de escritorio de Microsoft 365

Síntomas

En un dispositivo Windows que tenga instalado software de seguridad, es posible que experimente cualquiera de los siguientes problemas al intentar iniciar sesión en aplicaciones de escritorio de Microsoft 365:

  • Las indicaciones de inicio de sesión son intermitentes.

  • La ventana de inicio de sesión muestra una pantalla de autenticación en blanco.

    Captura de pantalla de una pantalla de autenticación en blanco.

  • La ventana de inicio de sesión está bloqueada en la autenticación.

    Captura de pantalla de una ventana de inicio de sesión que se bloquea en la autenticación.

  • El cliente de escritorio de Outlook muestra el mensaje "Intentando conectarse...".

  • El cliente de escritorio de Teams muestra el mensaje "No hemos podido conectarse. Inicie sesión y volveremos a intentarlo".

  • Abra el Visor de eventos y seleccione Registros de Windows>Aplicación. Al examinar los detalles de las entradas AppModel-State en la columna Origen de la tabla, verá uno de los siguientes mensajes de evento que terminan en un código -2147xxxxxxde error o advertencia:

    • Error al cargar la configuración de la aplicación para el paquete

    • Reparación de ubicaciones de estado del sistema para la función SettingsInitialize en el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy con error

    • Reparación de la operación LocalSettings contra el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy con error

    • Se desencadenó la reparación porque la operación LocalSettings contra el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy encontró un error.

    • La reparación de ubicaciones de estado fue desencadenada porque la operación SettingsInitialize en el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy provocó un error.

      Captura de pantalla del Visor de eventos que muestra los resultados filtrados para la entrada de origen Appmodel-State y un mensaje de evento que tiene el código de error que comienza en 2147.

Causa

El problema puede deberse a controladores existentes o obsoletos de Windows Filtering Platform (WFP) en el software de seguridad. En esta situación, el software de seguridad impide que la comunicación de red se establezca o mantenga el estado de comunicación anterior. Además, el software de seguridad podría bloquear los complementos del Administrador de cuentas web (WAM) o quitar los complementos como efecto secundario de su actividad en el dispositivo.

Si el Visor de eventos muestra cualquiera de los mensajes de evento que aparecen en la sección "Síntomas", los mensajes indican que los complementos wam están rotos o se han alterado.

Nota:

  • Las aplicaciones de Microsoft 365 usan los complementos WAM para establecer y renovar sesiones de inicio de sesión. Los complementos se instalan en el contexto del perfil de usuario. Esto significa que, aunque un usuario podría experimentar problemas, es posible que otro usuario del mismo dispositivo no lo haga. Por lo tanto, cualquier mitigación y diagnóstico debe realizarse en el contexto del usuario afectado, no en el nivel de dispositivo o en el nivel de administrador.
  • Si los complementos estaban dañados, alterados o eliminados del perfil de usuario durante el examen de software de seguridad, intentar instalar los complementos repetidamente con un script de PowerShell en segundo plano o un script de inicio de sesión de directiva de grupo. Esta acción podría mitigar temporalmente el problema hasta el siguiente examen antivirus.

Resolución

Importante

Si el problema se debe a un complemento WAM roto o alterado, vaya al paso 3 del procedimiento siguiente para volver a instalar los complementos WAM. Si el problema se repite, trabaje con el software de seguridad y el proveedor de controladores de WFP para configurar las exclusiones adecuadas que se enumeran en el paso 5.

Para corregir los problemas, siga estos pasos en el dispositivo:

  1. Inicie sesión con una cuenta de administrador y, a continuación, desinstale temporalmente el software de seguridad y los controladores DE PMA independientes o obsoletos del dispositivo.

  2. Inicie sesión con las credenciales del usuario afectado y compruebe si los complementos WAM están instalados y se pueden ejecutar correctamente en el perfil del usuario.

    1. Ejecute los siguientes cmdlets de PowerShell:

      Get-AppxPackage Microsoft.AAD.BrokerPlugin
      Get-AppxPackage Microsoft.Windows.CloudExperienceHost 
      
    2. Si alguno de los cmdlets no devuelve nada, vaya al paso 3. De lo contrario, ejecute los siguientes comandos en una línea de comandos:

      explorer.exe shell:appsFolder\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy!App
      explorer.exe shell:appsFolder\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy!App
      

      Si la ventana Cuenta profesional o educativa o Cuenta Microsoft no se abre, dirígete al paso 3. De lo contrario, vaya al paso 4.

  3. Si el paso 2 no se realiza correctamente, vuelva a instalar los complementos WAM mediante los siguientes cmdlets de PowerShell:

    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    
  4. Supervise durante 48 horas. Si el problema se repite, póngase en contacto con el soporte técnico de Microsoft. De lo contrario, vaya al paso 5.

    Nota:

    Para solucionar problemas, se recomienda recopilar los datos del Monitor de procesos al reproducir el problema. Esta información puede ayudar a determinar si:

    • Los módulos de terceros se cargan junto con los complementos WAM.
    • Los módulos de terceros mantienen el archivo o el bloqueo del registro e impiden el proceso de inicio de sesión.
    • Los controladores obsoletos del software de seguridad o de WFP están instalados en el sistema.
  5. Inicie sesión con una cuenta de administrador y vuelva a instalar el software de seguridad y los controladores DE PMA independientes que se desinstalaron en el paso 1. Después, trabaje con el software de seguridad y el proveedor de controladores WFP para configurar las siguientes exclusiones de paquetes, carpetas y procesos en el software de seguridad y los controladores WFP.

    Nombres de familia de paquetes que se van a excluir

    • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy

    Ubicaciones de carpetas que se van a excluir

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %windir%\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Microsoft\TokenBroker
    • %localappdata%\Microsoft\OneAuth
    • %localappdata%\Microsoft\IdentityCache

    Procesos a excluir

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Microsoft.AAD.BrokerPlugin.exe
    • %windir%\System32\backgroundTaskHost.exe para los siguientes nombres de paquete:
      • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
      • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %windir%\System32\svchost.exe cargando el servicio TokenBroker NT como TokenBroker.dll