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No se puede iniciar sesión en aplicaciones de escritorio de Microsoft 365

Síntomas

En un dispositivo que tenga instalado software de seguridad, puede experimentar cualquiera de los siguientes problemas al intentar iniciar sesión en aplicaciones de escritorio de Microsoft 365:

  • Las solicitudes de inicio de sesión son intermitentes.

  • La ventana de inicio de sesión muestra una pantalla de autenticación en blanco.

    Captura de pantalla de una pantalla de autenticación en blanco.

  • La ventana de inicio de sesión está bloqueada durante la autenticación.

    Captura de pantalla de una ventana de inicio de sesión que se bloquea al autenticarse.

  • El cliente de escritorio de Outlook muestra el mensaje "Intentando conectarse...".

  • El cliente de escritorio de Teams muestra el mensaje "No pudimos conectarnos. Inicie sesión y lo intentaremos de nuevo".

  • Si abre Visor de eventos, vaya aAplicaciónde registros> de Windows y, a continuación, compruebe los detalles que se muestran para las entradas "AppModel-State" en la columna "Origen" de la tabla en la parte superior del panel central, verá uno de los siguientes mensajes de evento que terminan con un código -2147xxxxxxde advertencia o error:

    • Error al cargar la configuración de la aplicación para el paquete

    • Reparación de ubicaciones de estado para la operación ConfiguraciónInitialize en el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy con error

    • Reparación de la operación LocalSettings en Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy de paquete con error

    • Reparación desencadenada porque la operación LocalSettings en el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy error de acierto

    • Reparación desencadenada de ubicaciones de estado porque la operación ConfiguraciónInitialize en el paquete Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy error de acierto

      Captura de pantalla del Visor de eventos que muestra los resultados filtrados por el estado de appmodel-state de entrada de origen y un mensaje de evento que tiene el código de error que comienza con 2147.

Causa

El software de seguridad del dispositivo impide que se establezca la comunicación de red o mantenga el estado de comunicación anterior. Este problema puede producirse debido a controladores de la Plataforma de filtrado de Windows (WFP) existentes o obsoletos en el software de seguridad. Además, el software de seguridad podría estar impidiendo que se ejecuten los complementos del Administrador de cuentas web (WAM), o podría quitar los complementos como un efecto secundario de su actividad en el dispositivo.

Si Visor de eventos muestra cualquiera de los mensajes de evento que aparecen en la sección "Síntomas", los mensajes indican que los complementos WAM están rotos o alterados.

Nota:

  • Las aplicaciones de Microsoft 365 usan los complementos WAM para establecer y renovar sesiones de inicio de sesión. Los complementos se instalan en el contexto del perfil de usuario. Esto significa que, aunque un usuario puede experimentar problemas, es posible que otro usuario del mismo dispositivo no. Por lo tanto, cualquier mitigación y diagnóstico debe realizarse en el contexto del usuario afectado, no en el nivel de dispositivo o de administrador.
  • Si los complementos están dañados, alterados o eliminados del perfil de usuario debido a la actividad de análisis de software de seguridad, puede intentar instalar repetidamente los complementos mediante un script de PowerShell en segundo plano o directiva de grupo script de inicio de sesión. Esta acción podría mitigar temporalmente el problema hasta el siguiente examen antivirus.

Solución

Importante

Si el problema se debe a un complemento WAM roto o alterado, vaya al paso 3 del procedimiento siguiente para volver a instalar los complementos de WAM. Si el problema se repite, trabaje con el software de seguridad y el proveedor de controladores de WFP para configurar las exclusiones adecuadas que se enumeran en el paso 5.

Para solucionar los otros problemas, siga estos pasos en el dispositivo:

  1. Inicie sesión con una cuenta de administrador y desinstale temporalmente el software de seguridad y los controladores WFP independientes o obsoletos del dispositivo.

  2. Inicie sesión con las credenciales del usuario afectado y compruebe si los complementos WAM están instalados y se pueden ejecutar correctamente en el perfil del usuario.

    1. Ejecute los siguientes cmdlets de PowerShell:

      Get-AppxPackage Microsoft.AAD.BrokerPlugin
      Get-AppxPackage Microsoft.Windows.CloudExperienceHost 
      
    2. Si alguno de los cmdlets no devuelve nada, vaya al paso 3. De lo contrario, ejecute los siguientes comandos en un símbolo del sistema:

      explorer.exe shell:appsFolder\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy!App
      explorer.exe shell:appsFolder\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy!App
      

      Si no se abre la ventana Cuenta profesional o educativa o Cuenta microsoft , vaya al paso 3. De lo contrario, vaya al paso 4.

  3. Si el paso 2 no se realiza correctamente, vuelva a instalar los complementos de WAM. Para ello, ejecute los siguientes cmdlets de PowerShell:

    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    
  4. Supervise durante 48 horas. Si el problema se repite, póngase en contacto con Soporte técnico de Microsoft. De lo contrario, vaya al paso 5.

    Nota:

    Para solucionar problemas, se recomienda recopilar los datos del Monitor de procesos al reproducir el problema. Esto puede ayudar a determinar si:

    • Los módulos de terceros se cargan junto con los complementos de WAM.
    • Los módulos de terceros mantienen el bloqueo de archivo o registro e impiden el proceso de inicio de sesión.
    • Los controladores de software de seguridad o WFP obsoletos están instalados en el sistema.
  5. Inicie sesión con una cuenta de administrador y vuelva a instalar el software de seguridad y los controladores WFP independientes que se desinstalaron en el paso 1. A continuación, trabaje con el software de seguridad y el proveedor de controladores WFP para configurar las siguientes exclusiones de paquetes, carpetas y procesos en los controladores de software de seguridad y WFP.

    Nombres de familia de paquetes que se van a excluir

    • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy

    Ubicaciones de carpeta que se van a excluir

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %windir%\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Microsoft\TokenBroker
    • %localappdata%\Microsoft\OneAuth
    • %localappdata%\Microsoft\IdentityCache

    Procesos que se van a excluir

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Microsoft.AAD.BrokerPlugin.exe
    • %windir%\System32\backgroundTaskHost.exe para los siguientes nombres de paquete:
      • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
      • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %windir%\System32\svchost.exe carga del servicio TokenBroker NT como TokenBroker.dll