Compartir a través de


Solución de problemas de errores de instalación de Office

Este artículo fue escrito por Eric Ashton, ingeniero sénior de escalación de soporte técnico.

En este artículo se describen técnicas sobre cómo determinar y corregir errores de instalación de Microsoft Office. Las técnicas se pueden aplicar a todas las instalaciones de Office que usan Windows Installer (MSI).

Habilitación del registro detallado

Al solucionar problemas de errores de instalación de Office, asegúrese de que el registro detallado de MSI está habilitado. En Office, hay un archivo de registro de setup.exe que se crea de forma predeterminada. Sin embargo, no proporciona los detalles que normalmente se necesitan para diagnosticar un error de instalación. Con el registro msi detallado habilitado, obtendrá un archivo de registro detallado para cada componente que instala Office. Tendrá un registro detallado para la instalación del componente de Word, Excel, etc.

Para habilitar el registro detallado, establezca las siguientes claves del Registro:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer

"Debug"=dword:00000007

"Logging"="voicewarmup"

Para obtener más información sobre el registro de Windows Installer, vea Cómo habilitar el registro de Windows Installer.

Realizar el intento de instalación

Si ejecuta la instalación manualmente en el equipo como usuario que ha iniciado sesión haciendo doble clic en setup.exe, los archivos de registro se generarán en el directorio %temp% del usuario que realiza la instalación.

Ahora que ha habilitado el registro detallado y sabe dónde debe buscar los registros, vuelva a intentar la instalación. Se produjo un error anteriormente, espere que vuelva a producir un error. Sin embargo, esta vez, está listo para capturar archivos de registro que se detallarán lo suficiente como para ayudarle a diagnosticar el punto de error.

Análisis de registros

Después del intento de instalación, verá que tiene entre 1 y 20 registros de la instalación en el directorio temporal.

Esta es una captura de pantalla de los registros detallados de un intento de instalación.

Captura de pantalla que muestra un ejemplo de los registros detallados de un intento de instalación.

Cuando examine los registros MSI, normalmente se querrá buscar una entrada de valor 3 en los registros. Windows Installer devuelve códigos durante la instalación que indican si una función determinada se realiza correctamente o no.

  • Valor 1 = Correcto
  • Valor 2 = Cancelar
  • Valor 3 = Error

En una buena instalación, normalmente no verá ninguna entrada de valor 3 en los registros.

Por lo tanto, hay muchos registros que se deben comprobar. Se recomienda empezar con el registro de setup.exe. Este registro normalmente tiene una entrada de valor 3 cuando se produce un error. Sin embargo, este registro no es lo suficientemente claro como para diagnosticar el problema. Si no tiene una entrada de valor 3 , busque la primera instancia del paquete de reversión. La reversión del paquete indica que la instalación de Office ha producido un error y Office está intentando "revertir" la instalación. Debería poder identificar el error inmediatamente en ese momento. En cuanto encuentre el valor 3 o el paquete de reversión en el registro de setup.exe, debe poder identificar qué componente produce un error y, a continuación, buscar el registro MSI concreto que corresponde a ese componente.

Con frecuencia, hay más de un valor 3 o la reversión de la entrada del paquete. Debe centrarse en la primera entrada que encuentre.

Estos son algunos ejemplos de errores de instalación de Office y cómo podemos identificar el punto de error.

Ejemplo de análisis del registro 1: instalación de Office ProPlus 2010

En este ejemplo, no encuentra una entrada de valor 3 en el registro de setup.exe y, a continuación, busca en el registro de setup.exe el paquete de reversión.

Es posible que encuentre el siguiente error:

Error: No se pudo instalar el producto: C:\MSOCache\All Users\GUID-C\ProPlusWW.msi ErrorCode: 1603(0x643).

El nivel de registro ha cambiado de: Estándar a: Detallado

Reversión de la cadena

Paquete de reversión de fecha y hora: ProPlusWW

El error no indica por qué se produjo un error en la instalación. Pero indica que el error se produjo durante la instalación del archivo ProPlusWW.msi. A continuación, debe encontrar el registro MSI detallado que se correlaciona con ProPlusWW.msi.

Nota:

  • Si sabe que el error está en ProPlusWW.msi, pero no desea perder tiempo en la búsqueda de qué registro MSI es para ProPlus, suele ser el archivo de registro más grande.
  • Si no sabe qué registro es el registro correcto para el componente de ProPlusWW.msi, abra cada registro de uno en uno y desplácese hasta la parte inferior. Indica qué componente acaba de intentar instalar o revertir.

Por ejemplo, en la parte inferior de la MSIb0bc7.LOG, verá la información similar a la siguiente:

MSI (s) (50:CC) [Hora]: Nota: 1: 1724

MSI (s) (50:CC) [Hora]: Producto: Microsoft Office Outlook MUI (inglés) 2010 : la eliminación se completó correctamente.

Por lo tanto, este es el registro MSI detallado para el componente de MUI de Office Outlook y el componente procede de la reversión (el error de instalación se produjo antes de esta reversión).

Cuando encuentre el registro de ProPlus (es el más grande), verá la siguiente información que indica que es el registro de ProPlus:

Producto: C:\MSOCache\All Users\GUID-C\ProPlusWW.msi

Al buscar en el registro una entrada de valor 3 , es posible que no encuentre una, pero es posible que vea el siguiente error en la parte inferior del registro:

MSI (s) (B0:14) [Hora]: Excepción interna durante la operación de instalación: 0xc0000017 en 0x7C812AFB.MSI (s) (B0:14) [Hora]: informe WER deshabilitado para la instalación silenciosa.MSI (s) (B0:14) [Hora]: error de MSI interno. El instalador finalizó prematuramente.Memoria insuficiente. Cierre otras aplicaciones antes de reintentar.MSI (s) (B0:14) [Hora]: MainEngineThread devuelve 1603.

Se trata de un problema conocido sobre Windows Installer. Para corregir este problema, instale la revisión. Después de instalar la revisión y reiniciar, la instalación se realiza correctamente.

Ejemplo 2 de análisis del registro: instalación independiente de Access 2010

En este ejemplo, no encuentra una entrada de valor 3 en el registro de setup.exe y, a continuación, busca en el registro de setup.exe el paquete de reversión. Es posible que encuentre el siguiente error:

Error: No se pudo instalar el producto: C:\MSOCache\All Users\GUID-C\AccessRWW.msi ErrorCode: 1601(0x641).

El nivel de registro ha cambiado de: Estándar a: Detallado

Reversión de la cadena

Paquete de reversión de fecha y hora: AccessRWW

El error no indica por qué se produjo un error en la instalación, pero sí indica que el error se produjo durante la instalación del archivo AccessRWW.msi. Si examina los archivos de registro, puede encontrar un registro para AccessRWW.msi:

Producto: C:\MSOCache\All Users\GUID-C\AccessRWW.msi

Al buscar una entrada de valor 3 , se encuentra el siguiente error:

CAInitSPPTokenStore.x86: OMSICA : Initializing CustomAction CAInitSPPTokenStore.x86CAInitSPPTokenStore.x86: Error: No se pudo inicializar el almacén de tokens de SPP. HResult: 0x80070057.CAInitSPPTokenStore.x86:MSI (s) (2C:D0) [Time]: El valor de la directiva de usuario "DisableRollback" es 0MSI (s) (2C:D0) [Time]: El valor de la directiva de máquina "DisableRollback" es 0Tiempo de fin de acción: InstallExecute. Valor devuelto 3.

Para corregir este problema, asegúrese de que el servicio de red se está ejecutando y, a continuación, asegúrese de que están presentes las siguientes claves del Registro.

  • HKEY_USERS\S-1-5-20
  • HKEY_USERS\S-1-5-19

Ejemplo 3 de análisis de registros: Office ProPlus 2010

En este ejemplo siguiente, encontrará una entrada de valor 3 en el registro de setup.exe similar al siguiente error:

MSI(ERROR): 'Error 1304. Error al escribir en el archivo: C:\WINDOWS\winsxs\Policies\x86_policy.8.0.Microsoft.VC80.ATL_1fc8b3b9a1e18e3b_x-ww_5f0bbcff\8.0.50727.4053.policy. Compruebe que tiene acceso a ese directorio."

El nivel de registro ha cambiado de: Estándar a: Detallado

No se muestra el mensaje porque se ha establecido suprimir modal. Título: 'Setup', Mensaje: 'Error 1304. Error al escribir en el archivo: C:\WINDOWS\winsxs\Policies\x86_policy.8.0.Microsoft.VC80.ATL_1fc8b3b9a1e18e3b_x-ww_5f0bbcff\8.0.50727.4053.policy. Compruebe que tiene acceso a ese directorio."

Mensaje devuelto: 2

MSI(USER): '¿Está seguro de que desea cancelar?'

MSI(INFO): "La acción finalizó a las 14:03:01: InstallExecute. Valor devuelto 3.'

Cuando vea una entrada de valor 3 en el registro de setup.exe, a veces le proporcionará suficiente información para corregir el problema sin tener que ver el registro msi detallado. En este caso, el registro msi detallado acaba de repetir lo que hemos encontrado en el registro de setup.exe.

En este caso, debe considerar la posibilidad de actualizar .net Framework y comprobar los permisos en c:\windows\winsxs.

Errores conocidos de registros detallados y posibles resoluciones

Algunas de estas sugerencias tratan el trabajo con claves del Registro.

Advertencia

Siga atentamente los pasos de esta sección. Pueden producirse problemas graves si modifica incorrectamente el registro. Antes de cambiarlo, realice una copia de seguridad del registro para su restauración en caso de que se produzcan problemas.

Error 1935

Error 1935. Error durante la instalación del componente de ensamblado. HRESULT: 0x80070003. interfaz de ensamblado: IAssemblyCache, función: CreateAssemblyCacheItem, nombre del ensamblado: Microsoft.VC90.ATL,version="9.0.30729.4148",type="win32",processorArchitecture="amd64",publicKeyToken="PublicKeyToken"

MSI (s) (1C:9C) [Hora]: El valor de la directiva de usuario "DisableRollback" es 0

MSI (s) (1C:9C) [Hora]: El valor de la directiva de máquina "DisableRollback" es 0

Hora de fin de la acción: InstallExecute. Valor devuelto 3.

Solución

Esto ocurre con más frecuencia debido a problemas al actualizar Office. Lo primero que hay que intentar es quitar la versión anterior de Office antes de instalar una nueva versión. Puede quitar la versión anterior de Office automáticamente mediante la herramienta adecuada desde aquí. Después de quitar la versión anterior de Office, intente instalar la versión más reciente de Office.

1913

Error 1913: El programa de instalación no puede actualizar el archivo C:/windows/win.ini.Compruebe que el archivo existe en el sistema y que tiene permisos suficientes para actualizarlo.

Causa

Hay un problema conocido con Trend Micro que podría estar causando este problema e impidiendo la instalación de Office.

Solución

Si usa Antivirus u otro software de seguridad, considere la posibilidad de desinstalarlo, reiniciar e intentar la instalación de nuevo.

Error 1714

Error 1714. El programa de instalación no puede quitar la versión anterior de Microsoft Office Product_Name 2007. Póngase en contacto con los Servicios de soporte técnico de Microsoft (PSS) para obtener ayuda. Para obtener información sobre cómo ponerse en contacto con PSS, consulte C:\DOCUME~1\username\LOCALS~1\Temp\Setup00000d64\PSS10R.CHM.

Solución

  • Método 1: quite primero las versiones anteriores de Office si intenta realizar una actualización. Para obtener más información sobre cómo quitar Office, vea Desinstalar Office desde un PC.
  • Método 2: realice una instalación en paralelo en lugar de actualizar. (Se trata de un botón Personalizar).

Error 1719

Error 1719. No se pudo acceder al servicio Windows Installer. Esto puede ocurrir si Windows Installer no está instalado correctamente. Póngase en contacto con el personal de soporte técnico para obtener ayuda.

Causa

Este problema se produce si las claves del Registro están dañadas o son incorrectas en HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver.

Solución

Método 1:

  1. Exporte la clave del Registro msiserver desde un buen equipo conocido que use la misma versión del sistema operativo y Windows Installer.

  2. Realice una copia de seguridad y elimine la clave msiserver existente en el equipo incorrecto en:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver

  3. Importe el archivo del Registro desde el equipo correcto conocido al equipo incorrecto.

  4. Reinicie y vuelva a intentar la instalación.

Método 2:

Consulte el mensaje de error "No se pudo acceder al servicio Windows Installer" al intentar instalar Office.

Error 1406

Error 1406.El programa de instalación no puede escribir el valor en la clave del Registro \CLSID\GUID. Compruebe que tiene permisos suficientes para acceder al registro o póngase en contacto con los Servicios de soporte técnico de Microsoft (PSS) para obtener ayuda. Para obtener información sobre cómo ponerse en contacto con PSS, consulte C:\Users\ADMINI~1\AppData\Local\Temp\Setup00000e64\PSS10R.CHM".

El nivel de registro ha cambiado de: Estándar a: Detallado

MSI(INFO): 'Tiempo de fin de la acción: InstallExecute. Valor devuelto 3.

Causa

Este error indica permisos incorrectos del Registro. En este ejemplo, encontraría permisos incorrectos del Registro en HKEY_CLASSES_ROOT\CLSID\GUID.

Solución

La cuenta de usuario que se usa para instalar Office tiene que tener acceso a la clave del Registro en cuestión. También puede comparar los permisos del Registro en un dispositivo donde la instalación se realiza correctamente.

Error 1920

Error 1920. No se pudo iniciar el servicio "Plataforma de protección de software de Office" (osppsvc). Compruebe que tiene privilegios suficientes para iniciar los servicios del sistema.

El nivel de registro ha cambiado de: Estándar a: Detallado.

MSI(INFO): 'Tiempo de fin de la acción: InstallExecute. Valor devuelto 3.

Causa

Este error indica posibles permisos incorrectos en la carpeta OfficeSoftwareProtectionPlatform o permisos incorrectos en HKEY_CLASSES_ROOT\APPID.

Solución

Método 1:

Conceda permiso completo a la cuenta de servicio de red en la carpeta OfficeSoftwareProtectionPlatform.

Método 2:

  1. Compare los permisos en HKEY_CLASSES_ROOT\APPID desde un buen equipo, con el equipo con problemas.
  2. Intente conceder "Restringido" a los siguientes permisos: Valor de consulta, Enumerar subclaves, Notificar y Leer control.

Error: IHxRegisterSession::CreateTransaction() devolvió 8004036e

IHxRegisterSession::CreateTransaction() devolvió 8004036eBeginTransaction() ERROR: Error de intento porque se estaba ejecutando otra transacción.

Al intentar revertir la transacción actual ({GUID})IHxRegisterSession::ContinueTransaction() devuelto 80004005.

BeginTransaction() ERROR: No se pudo reiniciar la transacción actual.

BeginTransaction() ERROR: No se pudo revertir la transacción actual. El registro de HelpFile se anulará.

No se creó la sesión de registro {GUID}.

Tiempo de fin de la acción: InstallFinalize. Valor devuelto 3.

Solución

Consulte KB 927153 El conjunto de aplicaciones de Office 2007 o el programa de instalación del conjunto de aplicaciones de Office 2010 no se reiniciarán después de que se interrumpa una instalación inicial.

Error: No se pudo registrar el complemento. HResult: 0x80070005

MSI (s) (08:6C) [Hora]: Invocación de una acción personalizada remota. DLL: C:\WINDOWS\Installer\MSI4D4.tmp, Entrypoint: CAInstallSppPlugin

CAInstallPlugin.x86: OMSICA : Initializing CustomAction CAInstallPlugin.x86

CAInstallPlugin.x86: Registrar PlugIn 'C:\Archivos de programa\Archivos comunes\Microsoft Shared\OfficeSoftwareProtectionPlatform\OSPPOBJS.DLL' 'C:\Archivos de programa\Archivos comunes\Microsoft Shared\OfficeSoftwareProtectionPlatform\osppobjs-spp-plugin-manifest-signed.xrm-ms'

CAInstallPlugin.x86: Error: No se pudo registrar el complemento. HResult: 0x80070005.

CAInstallPlugin.x86:MSI (s) (08:58) [Time]: El valor de la directiva de usuario 'DisableRollback' es 0MSI (s) (08:58) [Time]: El valor de la directiva de equipo 'DisableRollback' es 0

La acción finalizó a las 12:32:42: InstallExecute. Valor devuelto 3.

Causa

Las directivas del equipo con problemas (local o a través de un objeto de directiva de grupo (GPO)) están mal configuradas.

Solución

  1. Escriba Gpedit.MSC en el cuadro de búsqueda para abrir la directiva de grupo Editor local.
  2. Busque Configuración del equipo>Configuración de Windows Configuración>de seguridad Directivas>>localesAsignación de derechos de usuario.
  3. Asegúrese de que todos tienen derechos en la directiva Omitir comprobación de recorrido . De forma predeterminada, Todos aparecen en Configuración de seguridad.

Para obtener más información, consulte Los problemas de cliente, servicio y programa pueden producirse si cambia la configuración de seguridad y las asignaciones de derechos de usuario.

Error 0x80070005: Error de CAQuietExec

CAQuietExec: "wevtutil.exe" im "C:\Archivos de programa\Microsoft Office\Office14\BCSEvents.man"CAQuietExec: Los editores y canales se instalan correctamente. Sin embargo, no se pueden habilitar uno o varios publicadores y canales. Se deniega el acceso.

CAQuietExec: error 0x80070005: la línea de comandos devolvió un error.CAQuietExec: Error 0x80070005: Error de CAQuietExec

CustomAction RegisterEventManifest devolvió el código de error real 1603 (tenga en cuenta que es posible que no sea 100 % preciso si la traducción se produjo dentro del espacio aislado)

MSI (s) (88:04) [Hora]: El valor de directiva de usuario "DisableRollback" es 0MSI (s) (88:04) [Hora]: El valor de la directiva de máquina "DisableRollback" es 0

Hora de fin de la acción: InstallExecute. Valor devuelto 3.

Causa

Este problema puede producirse porque los permisos se establecen incorrectamente en la carpeta "C:\Windows\System32\winevt\Logs".

Solución

Conceda derechos completos a todos los usuarios a esa carpeta y vuelva a intentar la instalación. Si esto se realiza correctamente, puede quitar el grupo Todos después.

Error 0x800706b5: Error de CAQuietExec

CAQuietExec: "wevtutil.exe" im "C:\Archivos de programa\Microsoft Office\Office14\BCSEvents.man"CAQuietExec: Los editores y canales se instalan correctamente. Sin embargo, no se pueden habilitar uno o varios publicadores y canales. La interfaz es desconocida.

CAQuietExec: error 0x800706b5: la línea de comandos devolvió un error.CAQuietExec: error 0x800706b5: Error de CAQuietExec

CustomAction RegisterEventManifest devolvió el código de error real 1603 (tenga en cuenta que esto puede no ser 100 % preciso si la traducción se produjo dentro del espacio aislado)MSI (s) (6C:84) [Time]: El valor de la directiva de usuario "DisableRollback" es 0MSI (s) (6C:84) [Time]: El valor de la directiva de máquina "DisableRollback" es 0

Hora de fin de la acción: InstallExecute. Valor devuelto 3.

Causa

Este problema puede producirse si el servicio de registro de eventos de Windows no se está ejecutando.

Solución

  1. Haga clic en iniciar o buscar, escriba services.msc y, a continuación, presione Entrar.
  2. Desplácese hacia abajo hasta el servicio Registro de eventos de Windows y asegúrese de que está establecido en automático. Si no se está ejecutando, haga clic con el botón derecho en él y, a continuación, seleccione Iniciar.

Puede recibir un error similar al siguiente:

Error 4201: El nombre de instancia pasado no fue reconocido como válido por un proveedor de datos WMI.

En este caso, realice las siguientes acciones:

  1. Compruebe los permisos en la carpeta "c:\windows\system32\logfiles\wmi\RTbackup".
  2. Si la cuenta del sistema no tiene permiso control total , conceda a la cuenta del sistema el permiso Control total y reinicie el sistema.
  3. Compruebe y vea si el servicio de registro de eventos de Windows se inicia en services.msc. Si ahora se ha iniciado correctamente, vuelva a intentar la instalación de Office.