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Se le redirigirá a una página de inicio de sesión o a una página de error, o se le pedirá información de autenticación al hacer clic en un hipervínculo a un sitio web de SSO en un documento de Office.

Síntomas

Al hacer clic en un hipervínculo en un documento de Microsoft Office, puede experimentar el siguiente comportamiento antes de abrir la página que solicitó:

  • Se le redirige a una página de inicio de sesión o a una página de error.
  • Se le pedirá información de autenticación.

Normalmente, este comportamiento se produce cuando se cumplen las condiciones siguientes:

  • Abra el documento de Office en modo de edición fuera del explorador web.
  • El sitio web del hipervínculo usa un sistema de autenticación de inicio de sesión único (SSO) que se basa en cookies de sesión HTTP para la identificación del cliente. Incluso si ya ha proporcionado credenciales de usuario, se le pedirá que vuelva a proporcionar las credenciales de usuario.

Causa

Office le permite editar y crear documentos en un sitio web si el servidor admite la creación web y la colaboración. En primer lugar, Office intenta comunicarse con el servidor web. A continuación, Office intenta enlazar directamente al recurso mediante la Biblioteca de hipervínculos de Microsoft (Hlink.dll) y la API URLMON.

Cuando Office envía la solicitud de página web, es posible que se le redirija a la página de inicio de sesión del sitio web para el sistema SSO. Este comportamiento se produce porque la sesión de Office es independiente de la sesión del explorador web en la que es posible que ya haya proporcionado credenciales de usuario.

Dado que las sesiones son independientes, las cookies de sesión no se comparten. Si el sistema SSO se basa exclusivamente en la información de cookies de sesión, es posible que el sistema de SSO no funcione porque el mismo usuario se mueve desde más de una sesión. Este comportamiento es una limitación de diseño fundamental de un sistema SSO cuando el sistema SSO no está diseñado para admitir la autenticación de SSO en más de un explorador o aplicación compatible con web en el escritorio cliente. Dado que Office es una aplicación totalmente compatible con web, el problema puede aparecer único para aplicación de Office licaciones si son los únicos clientes compatibles con web instalados por el cliente. Sin embargo, la causa principal de este problema no se limita a Microsoft Office y este problema puede producirse cuando se usa software de terceros.

Solución alternativa

El problema es una limitación del sistema SSO que usa el servidor web. Sin embargo, puede reducir los efectos actuales del sitio web protegido por SSO mediante uno de los métodos siguientes.

Si este problema se produce cuando los hipervínculos de una página web abren un archivo de Office y la página web se hospeda en Internet Explorer, puede evitar este problema marcando explícitamente el contenido como una descarga de solo lectura en lugar de como una navegación insertada.

Para ello, agregue un encabezado HTTP personalizado a la respuesta GET para el contenido del archivo de Office. Agregue el encabezado "Content-Disposition: Attachment". Cuando una respuesta GET contiene este encabezado, Internet Explorer solicita al usuario que abra o guarde la descarga. Si el usuario decide abrir la descarga, el archivo se abre desde la memoria caché de archivos temporales de Internet Explorer de solo lectura. El usuario puede optar por modificar y guardar el archivo localmente. Sin embargo, el usuario no podrá guardar el archivo en el servidor ni colaborar con servicios web para el sitio web. Por lo tanto, esta solución solo funciona si piensa hacer que el archivo sea de solo lectura.

Puede establecer el encabezado "Content-Disposition" mediante código en Páginas de Microsoft Active Server (ASP), en Microsoft ASP.NET o en ISAPI cuando se trabaja con contenido generado dinámicamente. Si el contenido es estático, puede configurar el encabezado para un archivo o carpeta determinado mediante el Administrador de IIS y la metabase de IIS. Para obtener más información sobre el encabezado HTTP Content-Disposition, vea Cómo generar un cuadro de diálogo Descarga de archivos para un tipo MIME conocido.

Si este problema se produce al hacer clic en hipervínculos en documentos de Office que abren directamente contenido web HTML o se redirigen al contenido HTML, los usuarios cliente pueden evitar el problema habilitando una clave del Registro para enviar la navegación de hipervínculo al explorador en lugar de enlazar directamente al hipervínculo desde Office. Para obtener más información, vea Mensaje de error al hacer clic en hipervínculo en Office: "No se puede encontrar el servidor proxy o el servidor proxy de Internet".

Nota:

Independientemente de la versión de Office que haya instalado, agregue la clave del Registro en la ubicación exacta especificada en Mensaje de error al hacer clic en hipervínculo en Office: "No se puede encontrar el servidor de Internet o el servidor proxy".

Al usar esta configuración del Registro, el componente HLINK que usa Office abre el hipervínculo en el explorador web predeterminado. Esta configuración del Registro afecta a todos los clientes HLINK, no solo a Office. Por lo tanto, use cuidadosamente esta clave del Registro.

Más información

Para resolver completamente este problema, animamos a los proveedores de SSO a desarrollar un sistema que pueda permitir la creación web y un cliente que use varias sesiones. Esta configuración agrega complejidad al sistema SSO. Sin embargo, esta configuración también ofrece a los clientes las opciones de facilidad de uso más frecuentes. Microsoft está trabajando actualmente con proveedores de SSO clave para una solución a largo plazo.

Además, Microsoft está investigando cómo los usuarios finales usan Office para predecir y administrar mejor los escenarios siguientes:

  • El usuario pretende abrir un hipervínculo en modo de solo lectura. En este escenario, el hipervínculo se abre en modo de exploración.
  • El usuario quiere modificar el contenido. En este escenario, se requiere una nueva sesión para la creación y colaboración.

Estos cambios de configuración pueden reducir el efecto del problema que se describe en la sección "Síntomas". Estos cambios también pueden agregar flexibilidad al usuario cuando el usuario visita un sitio de SSO que no admite configuraciones que incluyen clientes de varias sesiones.

Si es un desarrollador o diseñador de SSO, puede agregar compatibilidad con clientes de varias sesiones. Por ejemplo, puede usar los métodos siguientes:

  • Use información de cookies persistente e información de cookies de sesión para identificar cuándo un solo cliente ha cruzado sesiones entre aplicaciones en el escritorio. A continuación, proporcione respuestas web para volver a transferir el cliente a una sola sesión o para autenticar la nueva sesión.

  • Use un componente del lado cliente para crear un sistema de autenticación integrado. Use este sistema de autenticación integrado para autenticar todos los procesos que se inician en el mismo token de autenticación de usuario.

  • Use certificados u otro método de identificación mejorado pero persistente para autenticar al cliente.

  • Para una solicitud HTTP que puede ser una solicitud de cliente de varias sesiones, emita una respuesta de redirección del lado cliente en lugar de una respuesta de redirección del lado servidor. Por ejemplo, envíe un script HTTP o una etiqueta META REFRESH en lugar de una respuesta HTTP 302. Este cambio obliga al cliente a volver al explorador web predeterminado del usuario. Por lo tanto, la sesión predeterminada del explorador puede controlar la llamada y puede mantener la llamada en una sola sesión de solo lectura.

    Este método no permite la creación. Sin embargo, este método deja claro que el sistema SSO no controla varios clientes de sesión y quiere que el cliente permanezca solo en la sesión del explorador predeterminada.

El enfoque exacto para este cambio de configuración depende de los objetivos de diseño y del nivel de integración que desea tener con el escritorio del cliente.