Problemas de rendimiento de Outlook en un archivo .ost o .pst en modo de intercambio almacenado en caché

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Síntomas

En Microsoft Outlook, experimenta síntomas como los siguientes:

  • Cuando se usa el modo de intercambio almacenado en caché o un archivo de datos de Outlook (.pst), se observa una disminución del rendimiento al realizar ciertas acciones.
  • Si las carpetas Bandeja de entrada, Calendario, Tareas, Elementos enviados o Elementos eliminados de Outlook contienen una gran cantidad de elementos, se reduce el rendimiento.
  • El rendimiento del calendario es incoherente. Por ejemplo, es posible que las actualizaciones de reuniones no se reflejen en el calendario principal, compartido o delegado.
  • Las carpetas tardan mucho tiempo en aparecer o no aparecen correctamente.
  • Si el perfil de Outlook contiene buzones compartidos y tiene habilitado el almacenamiento en caché (se selecciona Descargar carpetas compartidas ), se producen problemas de sincronización de carpetas, menor rendimiento u otros problemas si el número de carpetas compartidas por buzón supera los 500. Para obtener más información, vea Problemas de rendimiento y sincronización al trabajar con carpetas en un buzón secundario en Outlook. Además, los errores se registran en la carpeta Problemas de sincronización y los eventos "9646" se registran en el registro de aplicaciones.
  • En casos extremos en los que hay más de 10 000 carpetas, Outlook es muy lento de abrir. Este comportamiento se produce debido al tiempo necesario para enumerar el gran número de carpetas.

Causa

Estos problemas pueden producirse si un buzón contiene muchas carpetas o hay muchos elementos en una carpeta. No hay ningún límite estricto para cuántas carpetas puede contener un buzón de correo o cuántos elementos puede contener una carpeta. Sin embargo, puede experimentar un rendimiento reducido a medida que el número de elementos se aproxima a 10 000 elementos de calendario, 10 000 carpetas o 100 000 elementos de correo por carpeta. Un gran número de reuniones periódicas o reuniones periódicas de larga duración también puede tener un efecto exagerado en el rendimiento.

Solución

Para corregir problemas de rendimiento que afectan al calendario, el correo o las carpetas compartidas, use las siguientes resoluciones, según corresponda.

Soluciones para problemas de calendario

Para corregir problemas de rendimiento que afectan al calendario, pruebe los métodos siguientes.

Método 1: Administrar el crecimiento de excepciones para reuniones periódicas

No todos los elementos de calendario tienen un efecto igual en el rendimiento. Las reuniones únicas tienen un efecto relativamente pequeño y las reuniones periódicas de larga duración tienen un efecto mayor. Un cambio que se realiza en una instancia de una reunión periódica crea excepciones que se almacenan en la serie de reuniones periódicas. Cada cambio en los atributos de reunión, como el asunto, el cuerpo, la ubicación o la hora, crea una excepción correspondiente. Con el tiempo, estas excepciones inflan el tamaño de la reunión periódica e imponen un mayor costo de rendimiento. Puede mitigar este mayor costo mediante la configuración de periodicidad de citas para establecer una hora de finalización o un recuento máximo de periodicidad. A continuación, puede crear una nueva reunión periódica en lugar de ampliar la periodicidad existente.

Método 2: Habilitar mejoras de calendario compartido

Use la opción Activar mejoras de calendario compartido para los usuarios que tienen permisos de edición en un calendario compartido para mejorar el rendimiento. Al habilitar esta opción, las acciones de calendario se envían directamente al servidor en lugar de tener que sincronizarse desde el almacenamiento local. Esto hace que la resolución de conflictos sea más eficaz.

Para obtener más información sobre cómo activar y administrar las mejoras del calendario compartido, vea Cómo habilitar y deshabilitar las actualizaciones de uso compartido del calendario de Outlook.

Método 3: Limitar la ventana De sincronización

Puede limitar la ventana de sincronización que se usa para las carpetas de calendario para reducir el número de elementos almacenados localmente en las carpetas de calendario. Esto puede mejorar el rendimiento.

Importante

Siga atentamente los pasos de esta sección. La modificación incorrecta del Registro puede producir graves problemas. Antes de modificarlo, realice una copia de seguridad del Registro para efectuar una restauración en caso de que surjan problemas.

En Configuración de la ventana de sincronización, ajuste el número de meses de datos que se sincronizan para los calendarios compartidos principales. Para ello, añada las siguientes claves de registro.

Nota: Este método se aplica a la versión 1810 o a una versión posterior de Aplicaciones Microsoft 365 para empresas (hacer clic y ejecutar).

Descripción Configurar para habilitar la ventana Sincronizar calendario
Ruta del Registro HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Modo de almacenamiento en caché
Nombre CalendarSyncWindowSetting
Tipo REG_DWORD
Valor Valor = 0 inactivo
Valor = 1 carpeta del calendario principal
Valor = 2 todas las carpetas de calendario
El valor predeterminado es 0 si no se establece.
Descripción Configuración para controlar el número de meses en la ventana Sincronización de calendario
Ruta del Registro HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Modo de almacenamiento en caché
Nombre CalendarSyncWindowSettingMonths
Tipo REG_DWORD
Valor Valor = Seleccione un valor decimal para establecer el número de meses en la ventana Sincronización del calendario. Por ejemplo, seleccione 1, 3, 6 o 12.
El valor predeterminado es 6 si no se establece.
Descripción Configuración para controlar si se deben mantener todos los elementos periódicos en lugar de filtrarlos
Ruta del Registro HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Modo de almacenamiento en caché
Nombre CalendarSyncWindowAllRecurring
Tipo REG_DWORD
Valor Valor = 0: solo se sincronizarán las series de reuniones periódicas que tengan una fecha de finalización que esté en el futuro o que se encuentre dentro de la configuración actual de la ventana de sincronización del calendario.
Valor = 1: se sincronizarán todas las series de reuniones periódicas, independientemente de la fecha de finalización.
El valor predeterminado es 0 si no se establece.
Explicación De forma predeterminada (si el valor no está establecido o está en 0), se sincronizarán las series de reuniones periódicas que tengan una fecha de finalización en el futuro o dentro de la configuración actual de la ventana de sincronización del calendario. Por ejemplo, si la fecha de hoy es 3 de mayo de 2022 y la ventana de sincronización del calendario se establece en 1 mes, se sincronizarán todas las series de reuniones periódicas que tengan como fecha de finalización el 3 de abril de 2022 o posterior. Si la fecha de finalización está fuera de la configuración de la ventana de sincronización, la serie de reuniones periódicas se quitará del archivo .ost.
Para sincronizar todas las series de reuniones periódicas independientemente de la fecha de finalización, establezca el valor CalendarSyncWindowAllRecurring en 1.

Estas claves del Registro actualizan la restricción de sincronización para que el cliente que usa el modo de intercambio almacenado en caché descargue menos elementos de calendario, incluso para un calendario que tenga varios años de historial en el servidor. Estas claves no limpian contenido del calendario anterior que ya se descargó. Sin embargo, este método puede ser eficaz si acepta borrar los elementos sin conexión y volver a sincronizar el calendario (en lugar de eliminar de forma masiva elementos antiguos). Si ya tiene el calendario en el perfil, debe borrar los elementos sin conexión después de establecer las claves del Registro y reiniciar Outlook.

Para borrar los elementos de calendario sin conexión, siga estos pasos:

  1. Abra el panel Calendario en Outlook y haga clic con el botón derecho en la carpeta Calendario .
  2. Seleccione Propiedades.
  3. En la pestaña General, seleccione Clear Offline Items (Borrar elementos sin conexión).
  4. Seleccione Aceptar.

Soluciones para problemas de Correo

Si tiene carpetas cuyo contenido se aproxima al límite de 10 000 elementos de calendario, 10 000 carpetas o 100 000 elementos de correo, y estos elementos se almacenan en un archivo de datos de Outlook (.pst) o un archivo de datos de Outlook sin conexión () ,.ost mueva elementos de las carpetas más grandes para separar carpetas o más pequeñas en el mismo buzón o archivo de datos. Opcionalmente, si tiene un archivo en línea de Microsoft Exchange, puede mover elementos a ese archivo o crear directivas de retención para eliminar automáticamente elementos antiguos.

Archivar elementos de correo

Si ha habilitado el buzón de archivo en línea, archive los elementos en el buzón de archivo en línea.

Aplicación de una directiva de retención

Para eliminar elementos anteriores de la carpeta Correo o Calendario, aplique una directiva de retención. Por ejemplo, cualquier elemento que no se modifique dentro de un año se mueve a la carpeta Elementos eliminados.

Resolución de problemas de carpetas compartidas

Para corregir problemas de rendimiento que afectan a las carpetas compartidas, pruebe el método siguiente.

Limitar la ventana De sincronización

Para reducir el número de elementos almacenados localmente, limite la ventana de sincronización que se usa para las carpetas compartidas. Esto puede mejorar el rendimiento.

Importante

Siga atentamente los pasos de esta sección. La modificación incorrecta del Registro puede producir graves problemas. Antes de modificarlo, realice una copia de seguridad del Registro para efectuar una restauración en caso de que surjan problemas.

Para ajustar el número de días de datos que se sincronizan para carpetas compartidas, agregue los siguientes valores del Registro.

Descripción Configuración para habilitar la ventana Carpetas compartidas
Ruta del Registro HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Nombre SharedFolderSyncWindowSettingDays
Tipo REG_DWORD
Valor Valor = Seleccione un valor decimal para establecer el número de días (1-365) para la ventana de sincronización de carpetas compartidas.

Ejecutar el Asistente de soporte y recuperación de Microsoft

Nota:

los escenarios de Soporte técnico de Microsoft y Recovery Assistant no están disponibles para los nuevos escenarios de Outlook para Windows.

Puede usar Soporte técnico de Microsoft y Recovery Assistant para diagnosticar problemas de calendario y correo que afectan a Outlook. Para descargar e instalar el Asistente, consulte Acerca de Soporte técnico de Microsoft y Recovery Assistant.

Para determinar la causa de los problemas de rendimiento, inicie el Asistente y ejecute el diagnóstico de Outlook en la sección Diagnósticos avanzados .

Más información

Para ver el recuento de elementos en un Calendario de Outlook al usar el modo de intercambio almacenado en caché, use el cuadro de diálogo Propiedades del calendario:

  1. En Outlook, abra el panel Calendario y haga clic con el botón derecho en la carpeta Calendario .
  2. Seleccione Propiedades.
  3. En la pestaña General, seleccione Mostrar número total de elementos.
  4. Seleccione la pestaña Sincronización.
  5. Vea el recuento en Ver estadísticas de esta carpeta.

Outlook usa un archivo .ost solo si la cuenta de correo electrónico de Exchange está configurada para usar el modo de intercambio en caché. Si Outlook está configurado para conectarse al buzón de Exchange en modo en línea, no se usa un .ost archivo.

Si el cliente de Outlook está conectado a Exchange en modo online y no tiene carpetas de recuento de elementos altos en un archivo .pst, es posible que se produzcan problemas de rendimiento en el servidor. Para obtener más información, consulte Puede experimentar pausas de aplicación si tiene un archivo de datos de Outlook grande.