Compartir a través de


Mensaje de error "Hubo un problema y no se pudo completar la búsqueda" al buscar desde un buzón adicional en Outlook

Síntomas

Imagine la siguiente situación:

  • Se le conceden permisos de acceso completo a un buzón secundario.
  • Añade el buzón como una cuenta de Exchange adicional al perfil de Microsoft Outlook para Microsoft 365.
  • Ejecute una búsqueda desde ese buzón.

En esta situación, recibe un mensaje de error similar al siguiente:

Hubo un problema y no se pudo completar la búsqueda.

Hay un problema con la conexión de red.

Cuando se produce este error, al seleccionar la opción En su lugar, echemos un vistazo en el equipo puede mostrar los resultados de búsqueda esperados.

Causa

Esta es una limitación conocida del servicio de búsqueda de Exchange Online. El problema se produce si un cliente de Outlook usa las credenciales del usuario del buzón principal para realizar una búsqueda desde un buzón secundario.

Solución alternativa

Importante

Siga atentamente los pasos de esta sección. La modificación incorrecta del Registro puede producir graves problemas. Antes de modificarlo, realice una copia de seguridad del Registro para efectuar una restauración en caso de que surjan problemas.

Para solucionar este problema, utilice uno de los siguientes métodos:

  • Aumente el tiempo que Outlook espera a que Exchange proporcione resultados de búsqueda antes de volver a usar la búsqueda local.

    Para aumentar el tiempo, cree el valor de Registro ServerAssistedSearchTimeout. Para obtener más información, consulte este artículo de Outlook Global Customer Service & Support Team Blog.

    Tipo Valor
    Ruta de acceso de registro de la directiva de grupo HKEY_CURRENT_USER\software\policies\microsoft\office\16.0\outlook\search
    Nombre del valor: ServerAssistedSearchTimeout
    Tipo de valor REG_DWORD
    Datos de valor En milisegundos. Por ejemplo, 5000 representa 5 segundos.

    Nota:

    La ruta del Registro de OCT es HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\search.

    Puede realizar la prueba estableciendo el valor en 5 segundos. Es posible que un tiempo más corto también funcione, como 3 o 4 segundos.

  • Seleccione En su lugar, echemos un vistazo en el equipo para iniciar una búsqueda de escritorio de Windows local después de cada error.

  • Cambie la configuración de Outlook para dejar de utilizar la función de búsqueda en el servicio. Para ello, cree una clave de registro DisableServerAssistedSearch. Para obtener más información, consulte este artículo de Outlook Global Customer Service & Support Team Blog.

    Tipo Valor
    Ruta de acceso de registro de la directiva de grupo HKEY_CURRENT_USER\software\policies\Microsoft\office\16.0\outlook\search
    Nombre del valor: DisableServerAssistedSearch
    Tipo de valor REG_DWORD
    Datos de valor 1

    Nota:

    La ruta del Registro de OCT es HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\search.

  • Establezca el buzón adicional para dejar de usar el modo caché de Exchange; para más información, consulte este artículo de soporte técnico de Microsoft.

  • Cree un buzón compartido como un buzón adicional. Para más información, consulte Crear un buzón compartido.