Inserción de informes en un sitio web o portal seguro

Mediante la opción Insertar para Power BI informes, puede insertar informes de forma sencilla y segura en portales web internos. Estos portales pueden estar basados en la nube u hospedados en un entorno local, como una instancia de SharePoint 2019. Los informes insertados respetan todos los permisos de elementos y la seguridad de los datos a través de la seguridad de nivel de fila (RLS) y la seguridad de nivel de objeto (OLS) del modelo tabular de Analysis Services. La inserción segura garantiza que solo los usuarios autenticados y autorizados puedan acceder a los informes. Permiten realizar inserciones sin código en cualquier portal que acepte una dirección URL o un iFrame.

La opción Insertar admite filtros de direcciones URL y la configuración de direcciones URL. Le permite integrarse en portales con un enfoque de código reducido que requiere solo conocimientos básicos de HTML y JavaScript.

Importante

Debido a las actualizaciones de seguridad de Chromium en curso, la opción Insertar ya no funciona exactamente como solía y es posible que los usuarios necesiten autenticarse más de una vez. Para solucionar este cambio, considere la posibilidad de crear su propia solución insertada Power BI.

Cómo insertar informes de Power BI en portales

  1. Abra un informe en el servicio Power BI.

  2. En el menú Archivo, seleccione Insertar informe>Sitio web o portal.

  3. En el cuadro de diálogo Código de inserción seguro que aparece, seleccione el valor debajo de Este es un vínculo que puede usar para insertar este contenido. O bien, si quiere usar un iFrame en un blog o sitio web, seleccione el valor en Código HTML que puede pegar en un sitio web. Cambiar el ancho o alto de lo que se especifica en el código de iframe podría dar lugar a que ciertas características no funcionen según lo previsto.

    Captura de pantalla del cuadro de diálogo de la opción Insertar.

  4. Si un usuario abre directamente la URL de un informe, o bien una URL insertada en un portal web, tendrá que autenticarse para acceder al informe. Se mostrará la pantalla siguiente si un usuario no ha iniciado sesión en Power BI en la sesión del explorador. Al seleccionar Iniciar sesión, se abrirá una nueva pestaña o ventana del explorador. Deben comprobar si tienen activado un bloqueador de ventanas emergentes si no se les solicita que inicien sesión.

    Captura de pantalla de la página de inicio de sesión de Power BI que muestra el diálogo de inicio de sesión para ver este informe.

  5. Después de que el usuario inicie sesión, el informe se abre, mostrando los datos y permitiendo la navegación de páginas y la configuración de filtro. Solo los usuarios que tengan permiso para ver podrán ver el informe en Power BI. También se aplican todas las reglas de seguridad de nivel de fila (RLS ). Cada usuario necesita una licencia de Power BI Pro o Premium por Usuario (PPU), a menos que tanto el informe como su modelo semántico estén almacenados en Fabric F64 o superior o en capacidad Premium de Power BI. El usuario tendrá que iniciar sesión cada vez que abra una nueva ventana del explorador. Sin embargo, después de iniciar sesión, otros informes se cargan automáticamente.

    Captura de pantalla del informe de ejemplo de ventas y marketing.

  6. Al usar un iFrame, es posible que tenga que editar los valores del alto y el ancho para que se adapten a la página web del portal.

<iframe width="1080" height="760" src="https://app.powerbi.com/reportEmbed?reportId=aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb&autoAuth=true" frameborder="0" allowFullScreen="true"></iframe>

En este ejemplo, aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb representa el identificador único (GUID) del informe. Sustituya este valor por el identificador real del informe, que encontrará en el cuadro de diálogo del código para insertar al seleccionar Insertar informe>.

Concesión de acceso a informes

La opción Insertar no permite a los usuarios ver el informe automáticamente. Establezca los permisos de visualización en el servicio Power BI.

En el servicio Power BI, puede compartir informes insertados con usuarios que requieren acceso. Si usa un Grupo de Microsoft 365, puede listar al usuario como miembro del área de trabajo.

Licencias

Para ver el informe incrustado, cada usuario necesita una licencia de Power BI Pro o Premium por usuario (PPU), a menos que tanto el informe como su modelo semántico estén almacenados en capacidad Premium de Power BI o capacidad Fabric F64 o superior.

Los usuarios gratuitos reciben una petición para actualizar su licencia cuando el informe o su modelo semántico no se almacenan en la capacidad apta. Asigne al usuario una licencia Pro o PPU, o mueva ambos elementos a una capacidad que cumpla los requisitos.

Personalización de la experiencia de inserción con la configuración de direcciones URL

Puede personalizar la experiencia del usuario mediante la configuración de entrada de la URL incrustada. En el iframe proporcionado, puedes actualizar la configuración de src de la URL.

Propiedad Descripción
nombreDeLaPagina Use el parámetro de cadena de consulta pageName para establecer la página del informe que se va a abrir. Busque este valor al final de la dirección URL del informe cuando vea un informe en el servicio Power BI, como se muestra más adelante en este artículo.
Filtros de direcciones URL Use filtros de URL en la URL de inserción que recibe en la interfaz de usuario de Power BI para filtrar el contenido insertado. Con este método, puede crear integraciones de poco código con solo experiencia básica de HTML y JavaScript.

Configuración de la página en que se abrirá un informe insertado

Busque el valor pageName al final de la dirección URL del informe cuando vea un informe en el servicio Power BI.

  1. Abra el informe del servicio Power BI en el explorador web y copie la dirección URL de la barra de direcciones.

    https://app.powerbi.com/groups/me/reports/aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb/ReportSection2
    

    En este ejemplo:

    • me indica que el informe está en el área de trabajo personal (o reemplazar por un identificador de área de trabajo para un área de trabajo compartida).
    • aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb representa el identificador de informe (reemplace por el identificador de informe real).
    • ReportSection2 es el nombre de la página.
  2. Anexe la propiedad pageName y su valor al final de la dirección URL.

    https://app.powerbi.com/reportEmbed?reportId=aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb&autoAuth=true&pageName=ReportSection2
    

Filtrado del contenido de informes con filtros de direcciones URL

Puede usar filtros de direcciones URL para proporcionar distintas vistas de informes. Por ejemplo, la dirección URL siguiente filtra el informe para mostrar los datos del sector energético.

El uso de pageName con filtros de direcciones URL puede ser eficaz. Puede crear experiencias mediante HTML básico y JavaScript.

Por ejemplo, puede agregar el botón siguiente a una página HTML:

<button class="textLarge" onclick='show("ReportSection", "Energy");' style="display: inline-block;">Show Energy</button>

Al seleccionar el botón, se llama a una función para actualizar el iframe con una URL actualizada, que incluye el filtro de la industria de la energía.

function show(pageName, filterValue)

{

var newUrl = baseUrl + "&pageName=" + pageName;

if(null != filterValue && "" != filterValue)

{

newUrl += "&$filter=Industries/Industry eq '" + filterValue + "'";

}

//Assumes there's an iFrame on the page with id="iFrame"

var report = document.getElementById("iFrame")

report.src = newUrl;

}
https://app.powerbi.com/reportEmbed?reportId=aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb&autoAuth=true&pageName=ReportSection&$filter=Industries/Industry eq 'Energy'

En este ejemplo:

  • reportId=aaaaaaaa-0000-1111-2222-bbbbbbbbbbbb - El identificador único de su informe (reemplace con su identificador de informe real)
  • autoAuth=true - Habilita la autenticación automática
  • pageName=ReportSection - Abre una página específica
  • $filter=Industries/Industry eq 'Energy' - Filtros para mostrar solo datos del sector energético

Importante

Los filtros de dirección URL no son una característica de seguridad y no deben usarse para restringir el acceso a datos confidenciales. Los usuarios pueden modificar o quitar parámetros de dirección URL para ver datos o datos sin filtrar con distintos filtros. Los filtros de dirección URL solo son para mayor comodidad y personalización de vista inicial. Para proteger correctamente los datos y restringir lo que los usuarios pueden ver en función de su identidad o permisos, use la seguridad de nivel de fila (RLS) o la seguridad de nivel de objeto (OLS) en el modelo de datos.

Puede agregar tantos botones como quiera crear una experiencia personalizada de poco código.

Habilitar Copilot en informes seguros embebidos

Puede activar Copilot para informes web o de portal seguros activando la casilla Habilitar Copilot en el cuadro de diálogo informes incrustados. Esta función requiere un cambio de inquilino de Copilot activo y Power BI Premium o capacidad de Fabric de pago en su área de trabajo. Al habilitarlo, los usuarios pueden interactuar directamente con Copilot dentro del informe insertado.

  1. En el menú Archivo , seleccione Insertar informe y, a continuación, seleccione Sitio web o portal.

    Captura de pantalla de la selección del menú Insertar informe y la selección de la opción de menú Sitio web o portal.

  2. Seleccione la casilla Habilitar Copilot.

    Captura de pantalla del cuadro de diálogo Insertar con la opción Habilitar Copilot activada.   

Consideraciones y limitaciones

  • Los escenarios de inserción seguros admiten informes paginados y también admiten informes paginados con parámetros de dirección URL. Para obtener más información, consulte Pasar un parámetro de informe en una URL para un informe paginado en Power BI.
  • La opción de inserción segura funciona para los informes que se publican en el servicio Power BI.
  • Para hospedar contenido insertado de forma segura, debe usar HTTPS para la página de nivel superior. El servicio Power BI no admite el uso de una página host no segura para acceder al contenido insertado de forma segura.
  • Debe iniciar sesión para ver el informe cada vez que abra una nueva ventana o pestaña del explorador.
  • Para la autenticación, debe habilitar ventanas emergentes.
  • Si ha accedido correctamente a los informes en el pasado, pero ahora encuentra problemas, borre la memoria caché del explorador.
  • Algunos exploradores requieren que se actualice la página después de iniciar sesión, especialmente cuando se usan los modos InPrivate o Incognito.
  • Es posible que encuentre problemas si usa versiones del explorador no admitidas. Para obtener una lista de los exploradores compatibles con Power BI, consulte Exploradores compatibles con Power BI.
  • Si su sitio web establece el encabezado Cross-Origin-Opener-Policy (COOP) en same-origin, no podrá iniciar sesión para ver su contenido incrustado porque MSAL no admite este encabezado. En su lugar, elija restrict-properties (para exploradores basados en Chromium) o same-origin-allow-popups. Como alternativa, si no puede cambiar la Cross-Origin-Opener-Policy, enlace directamente con la URL incrustada en lugar de incrustarla en un iframe.
  • El servicio Power BI no admite el SharePoint Server clásico, ya que requiere Internet Explorer versiones anteriores a 11 o habilitar el modo de vista de compatibilidad.
  • Para lograr una experiencia de inicio de sesión único, use la opción Insertar en SharePoint Online, o bien cree una integración personalizada con el método de inserción el usuario es el propietario de los datos.
  • Las funcionalidades de autenticación automática que se incluyen con la opción Insertar no funcionan con la API de JavaScript para Power BI. Se bloquean en el SDK de cliente embebido de PBI a partir de la versión 2.10.4. Con la API de JavaScript para Power BI, use el método de inserción usuario-propietario-de-datos.
  • Las funcionalidades de autenticación automática no funcionan cuando se insertan en aplicaciones, incluidas las aplicaciones móviles y de escritorio.
  • La configuración de Microsoft Entra controla la duración del token de autenticación. Cuando expire el token de autenticación, el usuario debe iniciar sesión de nuevo para obtener un token de autenticación actualizado. La vigencia predeterminada es de una hora, pero puede que en su organización sea más larga o corta. No se puede actualizar automáticamente el token en este escenario.
  • El servicio Power BI no admite las cuentas de usuario invitado B2B de Azure, y la opción Insertar informe>Sitio web o portal no está visible.
  • Al hacer clic con el botón derecho en un objeto visual en un informe incrustado seguro, el menú visual difiere del menú de clic con el botón derecho estándar en un informe incrustado no seguro y ofrece menos opciones.