Información general sobre consultas en Power BI Desktop

Power BI Desktop le permite conectarse con el mundo de los datos, crear informes básicos y atractivos y compartir sus esfuerzos con otros usuarios, quienes a su vez podrán basarse en el trabajo que comparte con ellos y expandir sus propios esfuerzos de inteligencia empresarial.

Vistas de Power BI Desktop

Power BI Desktop tiene tres vistas:

  • Vista Informe: puede usar las consultas que crea para generar visualizaciones atractivas, que se ordenan como quiere que aparezcan, y con varias páginas, que puede compartir con los demás.
  • Vista Tabla: vea los datos de su informe en formato de modelo de datos, donde puede agregar medidas, crear nuevas columnas y administrar relaciones.
  • Vista Modelo: obtenga una representación gráfica de las relaciones que se han establecido en el modelo de datos y adminístrelas o modifíquelas según corresponda.

Acceda a estas vistas seleccionando uno de los tres iconos situados en el lado izquierdo de Power BI Desktop. En la siguiente imagen, la vista Informe está seleccionada y se indica mediante la banda de color amarillo situada junto al icono.

Captura de pantalla de Power BI Desktop que muestra la vista Informe seleccionada.

Power BI Desktop incluye también el Editor de Power Query. Use el Editor de Power Query para conectarse a uno o varios orígenes de datos, dar forma a los datos y transformarlos para que se ajusten a sus necesidades. Luego, puede cargar ese modelo en Power BI Desktop.

En este artículo se ofrece información general sobre el funcionamiento de los datos en el Editor de Power Query, pero queda mucho por aprender. Al final de este artículo encontrará vínculos a instrucciones detalladas sobre los tipos de datos admitidos. También encontrará instrucciones sobre cómo conectarse a datos, darles forma, crear relaciones y empezar a trabajar.

Pero primero, vamos a familiarizarnos con el Editor de Power Query.

Editor de Power Query

Power BI Desktop ofrece dos experiencias de Editor de Power Query:

  • Nueva experiencia de Power Query (versión preliminar): un editor rediseñado con navegación simplificada, accesibilidad mejorada y una experiencia de Power Query coherente en Power BI Escritorio, modelado web y otros productos Fabric.
  • Experiencia heredada: la ventana de Editor de Power Query original.

En ambas experiencias, se usa Editor de Power Query para conectarse a uno o varios orígenes de datos, dar forma y transformar los datos para satisfacer sus necesidades y, a continuación, cargar el resultado en Power BI Desktop. Seleccione la pestaña que coincida con la experiencia que usa.

Para conocer las limitaciones conocidas, las soluciones alternativas y un lugar para compartir comentarios, consulte Nuevas limitaciones y soluciones alternativas conocidas de la experiencia de Power Query.

Note

La nueva experiencia de Power Query está en versión preliminar.

Prerequisites

Power BI Escritorio con la nueva experiencia de Power Query característica en versión preliminar habilitada.

Para habilitar la nueva experiencia de Power Query:

  1. Inicie Power BI Desktop.
  2. Vaya a Archivo>Opciones y configuración>Opciones.
  3. Seleccione Características de vista previa y, a continuación, active la casilla Nueva experiencia de Power Query.
  4. Selecciona Aceptar.

La misma función en versión preliminar permite tanto la nueva experiencia Obtener datos como el nuevo Editor de Power Query. Para volver al editor heredado, desactive la casilla . No es necesario reiniciar Power BI Escritorio. Para obtener más información sobre la nueva experiencia de Obtener datos, consulte Obtener datos en Power BI Desktop.

Abrir el Editor de Power Query

Para abrir Editor de Power Query, seleccione Transformar datos en la pestaña Inicio de Power BI Escritorio.

Si no existe ninguna conexión de datos, el Editor de Power Query aparece como un panel en blanco listo para mostrar datos. Una vez cargada una consulta, el editor presenta cinco componentes distintos. Los números de la tabla siguiente corresponden a las llamadas numeradas en la captura de pantalla.

Captura de pantalla del nuevo Editor de Power Query en Power BI Escritorio con cada componente descrito y numerado.

# Componente Descripción
1 Cinta de opciones La experiencia de navegación mediante la cinta de opciones, que proporciona varias pestañas para añadir transformaciones, seleccionar opciones de la consulta y acceder a diferentes botones de la cinta de opciones para completar varias tareas.
2 Panel de consultas Vista de todas tus consultas disponibles.
3 Vista actual La vista de trabajo principal, que de forma predeterminada muestra una vista previa de los datos de la consulta. También puede habilitar la vista de diagrama junto con la vista previa de datos. Puede cambiar entre la vista de esquema y la vista previa de datos mientras mantiene la vista de diagrama.
4 Configuración de consultas Vista de la consulta seleccionada actualmente con información relevante, como el nombre de la consulta, los pasos de consulta y varios indicadores.
5 Barra de estado Barra que muestra información importante sobre la consulta, como el tiempo de ejecución, las columnas totales y las filas, y el estado de procesamiento. Esta barra también contiene botones para cambiar la vista actual.

Cada uno de estos componentes se describe en las secciones siguientes. Para ver un tutorial completo de la interfaz de usuario de Power Query, consulte Uso de Power Query para transformar datos.

La cinta

La cinta de opciones es el componente en el que encontrará la mayoría de las transformaciones y acciones que puede realizar en Editor de Power Query. Los comandos se agrupan en las pestañas Inicio, Transformación, Agregar columna, Vista, Herramientas y Ayuda . Cada pestaña proporciona botones y opciones específicos que proporcionan fácil acceso a las transformaciones y acciones que puede necesitar.

La pestaña Inicio contiene las tareas de consulta comunes, incluidos los comandos Obtener datos que se usan para conectarse a los datos y comenzar el proceso de creación de consultas. Para obtener más información sobre los orígenes de datos disponibles, consulte Orígenes de datos en Power BI Desktop. Para más información sobre el uso de conectores, consulte Introducción a los datos.

La pestaña Transformar proporciona acceso a tareas comunes de transformación de datos, como agregar o quitar columnas, cambiar tipos de datos y dividir columnas. La pestaña Agregar columna proporciona más tareas asociadas con la adición de una columna, el formato de los datos de columna y la adición de columnas personalizadas. La pestaña Ver controla qué paneles y vistas se muestran y abre el Editor avanzado.

La interfaz Power Query responde y se ajusta a la resolución de pantalla. Si desea una versión compacta de la cinta de opciones, seleccione el botón contraer situado en la esquina inferior derecha de la cinta. Para volver a la cinta de opciones estándar, seleccione el icono de expansión en la misma esquina.

Muchas de las tareas disponibles en la cinta también están disponibles al hacer clic con el botón derecho en una columna o en otros datos de la vista actual. A menudo, se puede acceder a las transformaciones desde más de un lugar, por lo que puede utilizar la experiencia que prefiera.

Para obtener más información sobre la transformación de datos, incluidos ejemplos, consulte Tutorial: Combinar datos y darles forma en Power BI Desktop.

El panel de consultas

El panel Consultas muestra todas las consultas disponibles. Al seleccionar una consulta, sus datos se muestran en la vista actual, donde puede dar forma y transformar los datos para satisfacer sus necesidades.

Seleccione el icono de la esquina superior derecha del panel Consultas para contraer el panel y selecciónelo de nuevo para expandir el panel. Los iconos similares a lo largo de la interfaz le permiten contraer o expandir otras vistas y secciones, por lo que puede centrarse en la vista que más le importa.

Para obtener más información, consulte panel Consultas.

La vista actual

La vista actual es la vista principal de trabajo. De forma predeterminada, muestra la vista previa de datos de la consulta seleccionada. Realiza gran parte del trabajo relacionado con las consultas en esta área. Seleccione un encabezado de columna o haga clic con el botón derecho en él para ver las transformaciones disponibles para esa columna. Muchos de estos elementos son los mismos que los botones de las pestañas de la cinta de opciones.

Al seleccionar una transformación, la consulta aplica el paso a los datos. También guarda el paso como parte de la propia consulta. El panel Configuración de consulta registra los pasos en orden secuencial, como se describe más adelante en este artículo.

También puede habilitar las herramientas de generación de perfiles de datos para comprender mejor los datos, incluida la distribución de valores y la calidad de las columnas. Habilite y deshabilite estas herramientas en la pestaña Ver para su comodidad. Para obtener más información, consulte Uso de las herramientas de generación de perfiles de datos.

Cambiar entre vistas

Además de contraer paneles y secciones, también puede cambiar las vistas que se muestran. Vaya a la pestaña Ver de la cinta de opciones, donde encontrará los grupos Vista previa y Diseño que controlan el aspecto de la interfaz.

Captura de pantalla de la pestaña Ver del nuevo Editor de Power Query, en la que se muestran los grupos Vista previa y Diseño.

El lado derecho de la barra de estado también contiene iconos para las vistas de diagrama, datos y esquema. Use estos iconos para cambiar entre vistas o para habilitar y deshabilitar la vista que prefiera.

Pruebe estas opciones para encontrar la vista y el diseño con los que está más cómodo trabajar.

Vista de esquema

La vista esquema ofrece una manera rápida y sencilla de interactuar solo con los componentes del esquema de la tabla, como los nombres de columna y los tipos de datos. Use la vista de esquema cuando desee realizar acciones relacionadas con el esquema, como quitar columnas, cambiar el nombre de columnas, cambiar los tipos de datos de columna, reordenar columnas o duplicar columnas.

Captura de pantalla de la vista de esquema en la nueva Editor de Power Query, en la que se muestran las columnas Nombre, Tipo y Clave de la consulta seleccionada.

Cuando la vista de esquema está activa, la pestaña Herramientas de esquema aparece en la cinta de opciones con las acciones que se aplican a las columnas.

Para obtener más información, consulte Usar la vista Esquema.

Vista del diagrama

La vista diagrama le ayuda a visualizar cómo se estructura la consulta y cómo puede interactuar con otras consultas del proyecto. Cada paso de la consulta tiene un icono distinto para ayudarle a reconocer la transformación que se usó y las líneas conectan los pasos para ilustrar las dependencias.

Cuando la vista previa de datos y la vista de diagrama están habilitadas, la vista de diagrama aparece encima de la vista previa de datos. Con la vista de diagrama habilitada, seleccione el signo más para buscar una nueva transformación para agregarla a la consulta.

Captura de pantalla de la vista de diagrama que se muestra encima de la vista previa de datos en la nueva Editor de Power Query.

Para obtener más información, vea Vista diagrama.

El panel de configuración de consulta

El panel Configuración de consulta muestra información sobre la consulta seleccionada actualmente, como el nombre de la consulta, sus pasos y varios indicadores. Cada transformación aplicada a la consulta se guarda como paso en la sección Pasos aplicados .

Si necesita comprobar cómo se transforma la consulta de paso a paso, seleccione un paso para obtener una vista previa de cómo se resuelve la consulta en ese punto específico.

Es importante saber que los datos subyacentes no cambian. En su lugar, el Editor de Power Query ajusta y da forma a su vista de los datos.

Puede cambiar el nombre de los pasos, eliminar pasos o reordenar los pasos según se ajuste. Para ello, haga clic con el botón derecho en el paso de la sección Pasos aplicados y elija en el menú que aparece. Seleccione Propiedades para cambiar el nombre de un paso o agregarle una descripción. Todos los pasos de consulta se llevan a cabo en el orden en que aparecen.

Para obtener más información, consulte Uso de la lista de Pasos aplicados.

La barra de estado

La barra de estado aparece en la parte inferior del editor y muestra información importante sobre la consulta, como el tiempo de ejecución, las columnas totales y las filas, y el estado de procesamiento. El lado derecho de la barra de estado también contiene iconos que puede usar para cambiar la vista actual.

Captura de pantalla de la barra de estado de la nueva Editor de Power Query, que muestra el estado de procesamiento, los recuentos de columnas y filas y los iconos de vista.

Barra de fórmulas

La barra de fórmulas muestra la expresión de lenguaje de fórmulas Power Query M para el paso seleccionado. Puede editar la expresión directamente en la barra de fórmulas para ajustar un solo paso o usar el Editor avanzado para trabajar con el script de consulta completo.

Obtención de ayuda

La pestaña Ayuda de Editor de Power Query proporciona enlaces a información sobre Power BI. Puede acceder a las mismas opciones de ayuda seleccionando Archivo>Ayuda.

Editor avanzado

El Editor avanzado le permite ver el código que el Editor de Power Query crea con cada paso. También le permite crear su propio código en el lenguaje de fórmulas Power Query M. Para iniciar el editor avanzado, seleccione Vista desde la cinta de opciones y después seleccione Editor avanzado. Aparece una ventana que muestra el código generado para la consulta seleccionada.
Captura de pantalla de Power BI Desktop que muestra el cuadro de diálogo Editor avanzado.

Puede modificar directamente el código en la ventana Editor avanzado . Para cerrar la ventana, seleccione el botón Listo o el botón Cancelar .

El Editor avanzado está disponible tanto en la experiencia nueva como en la heredada. En la captura de pantalla anterior se muestra la experiencia heredada. Algunos controles Editor avanzado y opciones de visualización difieren en la nueva experiencia. Para obtener más información, consulte Nuevas limitaciones y soluciones alternativas conocidas de la experiencia de Power Query.

Guardar tu trabajo

Cuando la consulta esté donde usted quiera, seleccione Cerrar y aplicar en el menú Archivo del Editor de Power Query. Esta acción aplica los cambios y cierra el editor.
Captura de pantalla de Power BI Desktop que muestra la opción Cerrar y aplicar en la pestaña Archivo.

Como la operación avanza, Power BI Desktop proporciona un cuadro de diálogo para mostrar su estado.
Captura de pantalla de Power BI Desktop que muestra el cuadro de diálogo de confirmación de los cambios aplicados de la consulta.

Cuando esté a punto, Power BI Desktop puede guardar su trabajo en forma de archivo .pbix.

Para guardar el trabajo, seleccione Archivo>Guardar (o Archivo>Guardar como), tal y como se muestra en la siguiente imagen. Captura de pantalla de Power BI Desktop que muestra la pestaña Archivo del Editor de Power Query. Están resaltadas las opciones Guardar y Guardar como.

Se puede hacer todo tipo de cosas con Power BI Desktop. Para obtener más información sobre sus capacidades, consulte los siguientes recursos: