Nota
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Advertencia
La aplicación de escritorio de Internet Explorer 11, retirada del soporte, ha sido deshabilitada permanentemente a través de una actualización de Microsoft Edge en ciertas versiones de Windows 10. Para obtener más información, consulte Preguntas frecuentes sobre la retirada de la aplicación de escritorio de Internet Explorer 11.
A menudo, debido a la instalación de otras aplicaciones que vuelven a registrar o actualizar los registros de interfaz existentes, Internet Explorer no puede realizar correctamente las funciones de Abrir en nueva ventana y Abrir en nueva pestaña. Este artículo le ayudará a volver a registrar los archivos binarios auxiliares para intentar restaurar la funcionalidad que falta.
Versión original del producto: Internet Explorer 8 y versiones posteriores
Número de KB original: 2574731
Síntomas
Al intentar usar las opciones del menú contextual del botón derecho para abrir en nueva pestaña o Abrir en una nueva ventana de un hipervínculo, es posible que la pestaña o ventana adecuada no aparezcan o naveguen según lo previsto.
Si aparece la pestaña o ventana, puede observar que la pestaña está ocupada, pero la navegación no se completa. Si se detiene el intento de navegación, se puede navegar por la nueva pestaña o ventana proporcionando la dirección en la barra de direcciones adecuada.
Tenga en cuenta que es posible que los métodos abreviados de teclado para crear nuevas pestañas (Ctrl+T) y nuevas ventanas (Ctrl+N) no se vean afectadas.
Causa
La información del Registro que se usa para iniciar estas funcionalidades no es válida o está asignada a otro archivo binario.
Solución
En muchos casos, es posible restaurar esta funcionalidad al volver a registrar los archivos de Internet Explorer específicos de la función.
Como medida de precaución estándar para cualquier modificación del Registro, se recomienda crear un punto de restauración del sistema o una copia de seguridad del estado del sistema siempre que sea posible antes de continuar.
Utilizando un símbolo del sistema de Windows que utiliza un privilegio de cuenta de administrador, escriba los siguientes comandos que se aplican a la arquitectura específica de su procesador.
Sugerencia
En Windows Vista y los sistemas operativos más recientes, esto se puede lograr haciendo clic con el botón derecho en el acceso directo del símbolo del sistema y seleccionando la función Ejecutar como administrador y proporcionando las credenciales de una cuenta de usuario que tiene privilegios de administrador local, si se le solicita.
Para las instalaciones de Internet Explorer en versiones de 64 bits de Windows:
En la línea de comandos, escriba los siguientes comandos (no copiar ni pegar), presionando la tecla Intro después de cada uno:
%SystemRoot%\System32\regsvr32 '%programfiles%\Internet Explorer\ieproxy.dll'
%SystemRoot%\Syswow64\regsvr32 '%programfiles(x86)%\Internet Explorer\ieproxy.dll'
%SystemRoot%\System32\regsvr32 /i /n ieframe.dll
%SystemRoot%\Syswow64\regsvr32 /i /n ieframe.dll
Para las instalaciones de Internet Explorer en versiones de 32 bits de Windows:
En la línea de comandos, escriba los siguientes comandos (no copiar ni pegar), presionando la tecla Intro después de cada uno:
regsvr32 '%programfiles%\Internet Explorer\ieproxy.dll'
regsvr32 /i /n 'ieframe.dll'
Recordatorio: No es necesario anteponer regsvr32
con %SystemRoot%\System32
en sistemas de 32 bits.
Nota:
En la ejecución de cada regsvr32
comando, debería recibir un cuadro de mensaje que indica que el registro se realizó correctamente. Si recibe un mensaje que indica un estado distinto de correcto, se recomienda ponerse en contacto con el soporte técnico de Microsoft para obtener más ayuda. Para obtener más información sobre el regsvr32
uso, consulte el siguiente artículo:
Explicación del uso y el mensaje de error regsvr32
Más información
El nuevo registro manual de estos archivos de Internet Explorer puede ser necesario en las condiciones siguientes:
- Los registros de archivos de instalación de Internet Explorer se bloquearon o retrasaron antes de que se produjera el reinicio.
- Una instalación del paquete de actualización de Internet Explorer no pudo completar los registros de archivos antes de que se produjera el reinicio.
- Una o varias aplicaciones sobrescriben la información de registro de Internet Explorer con datos alternativos.