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En este artículo se proporciona una resolución para el problema que puede que las reglas de negocios (lógica de negocios portable) no funcionen según lo esperado o se produzcan errores cuando un usuario ejecuta flujos de proceso de negocio sin privilegios suficientes en la entidad Proceso.
Se aplica a: Microsoft Dynamics CRM
Número de KB original: 4025533
Síntomas
Las reglas de negocio no se ejecutan o los flujos de proceso de negocio muestran un mensaje de error que comienza con el complemento del servicio web falló en SdkMessageProcessingStepId: (...).
Causa
Si el rol de seguridad de un usuario no tiene privilegios suficientes en la entidad Process , lo que hace referencia a la tabla de flujo de trabajo interna, las reglas de negocio y los flujos de proceso de negocio no generarán, cargarán y ejecutarán correctamente en la primera carga, lo que provocará un comportamiento inesperado o errores intermitentes. Cuando esto ocurre, el estado se almacena en caché y un usuario posterior, cuyo rol de seguridad tiene suficientes privilegios intenta cargar y ejecutar las mismas reglas de negocio y flujos de proceso de negocio, experimentará un error.
Para comprobar los niveles de acceso, vaya a Configuración>Roles de seguridad> y seleccione un rol de seguridad pestaña Personalización> entidad >. La columna Leer debe ser verde completa (acceso de nivel de organización).
Solución
Siga estos pasos para solucionar este problema:
- Asegúrese de que todos los roles de seguridad tienen privilegios de lectura completos de nivel de organización para la entidad Proceso.
- Publique las personalizaciones yendo a Configuración>Personalización>Personalización del sistema.