Compartir a través de


Los scripts del lado cliente ya no funcionan en Microsoft Dynamics CRM Online después de la actualización del servicio de diciembre de 2012

Este artículo le ayuda a corregir errores de script después de actualizar la organización de Microsoft Dynamics CRM Online a la actualización de servicio de diciembre de 2012.

Se aplica a: Microsoft Dynamics CRM Online
Número de KB original: 2804561

Síntomas

Si los formularios usan la API de cliente V4.0 (crmForm), es posible que encuentre errores de script después de actualizar la organización de Microsoft Dynamics CRM Online a la actualización del servicio de diciembre de 2012. Es posible que aparezca un cuadro de diálogo que diga "Undefined" o que vea un error en la esquina inferior izquierda del formulario que indica "Error en la página". Pueden aparecer otros errores de script diferentes.

Causa

La actualización del servicio de diciembre de 2012 para Microsoft Dynamics CRM introdujo una nueva configuración del sistema que controla si los componentes HTML (HTC) se incluyen en formularios de Microsoft Dynamics CRM. Esta configuración está deshabilitada de forma predeterminada en Microsoft Dynamics CRM Online.

Las siguientes propiedades crmForm requieren HTC:

Propiedades de CrmForm
. Save(
. SaveAndClose(
. FormType
. ObjectTypeCode
.ObjectId
.ObjectTypeName
.RequiredLevel
. SetFocus(
. FireOnChange
Min.
.Máximo
.DataValue
.isDirty
Deshabilitado.
.SelectedOption
.SelectedText
.SortingEnum
. Ordenar
.SelectedIndex
. InnerText
. OptionsXml
Precisión.
. DataXml
Texto.
Valor
.DisplayValue
.WillSubmit
.DataChangeHandler
.BypassValidation
.AllowFormFocus
._bSaving
._htcInitCompleted
.SubmitFormId
.SIN_DATOS
. RefreshOnSave
Visible.
. ForceSubmit
Formulario.
. TimeControl
.isInitialized
.allowblankdate
. IsMoney
. IsBaseCurrency
.CurrencySymbol
. CurrencyPrecision
. IgnoreCurrencySymbol
.IgnoreRange
.PrecisionChangeHandler
.TrimValue
. MaxLength
Enumerador

Solución

  1. Inicie sesión en la aplicación web de Microsoft Dynamics CRM como administrador del sistema.
  2. Haga clic en Configuración, haga clic en Administración, y luego haga clic en Configuración del sistema.
  3. Haga clic en la pestaña Personalización.
  4. Haga clic en la casilla situada junto a la opción Incluir compatibilidad con HTC en formularios de Microsoft Dynamics CRM.
  5. Haga clic en Aceptar.

Más información

La API crmForm estaba en desuso con la versión de Microsoft Dynamics CRM 2011. Para obtener más información sobre este tema y otras posibles causas de errores de script después de la actualización del servicio de diciembre de 2012, consulte las siguientes entradas de blog: