Compartir a través de


La ejecución del informe {ID} ha expirado o no se encuentra. El error rsExecutionNotFound se produce en Microsoft Dynamics CRM 2011

En este artículo se proporciona una solución a un error que se produce en Microsoft Dynamics CRM 2011.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2550340

Síntomas

Cualquier informe que se ejecute a través del origen de datos de Microsoft Dynamics CRM 2011 que usa las extensiones de datos de Microsoft Dynamics CRM 2011 muestra RSExectutionNotFound en la interfaz de usuario de CRM. El registro de SSRS y el seguimiento de la plataforma mostrarán el mensaje de error siguiente.

La ejecución del informe [id] ha expirado o no se encuentra. (rsExecutionNotFound)

Los usuarios también pueden ver el error siguiente.

ERROR: Lanzando Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerStorageException: se produjo un error en la base de datos del servidor de informes. Esto puede deberse a un error de conexión, un tiempo de espera o una condición de disco baja en la base de datos.

Causa

Puede deberse a dos problemas de tiempo.

Causa 1

La configuración de zona horaria en todos los componentes del servidor no coincide.

Causa 2

La hora del sistema del servidor tiene una discrepancia de 5 minutos o más.

Solución

Ambas resoluciones deben completarse y comprobarse en todos los servidores de una implementación de Microsoft Dynamics CRM. Incluiría Microsoft SQL Server, el servidor SSRS y todos los servidores de Microsoft Dynamics CRM.

Resolución 1

Corrija la configuración de zona horaria en los servidores para que todos los servidores usen la misma zona horaria.

Resolución 2

Corrija la hora del sistema entre los servidores para que todo el sistema esté dentro de 5 minutos de todos los servidores.