Compartir a través de


El servidor HTTP devolvió la excepción 404 NotFound al usar la sincronización del lado servidor en Microsoft Dynamics 365

En este artículo se proporciona una resolución para resolver los mensajes de error que pueden producirse al intentar probar y habilitar un buzón en Microsoft Dynamics 365.

Se aplica a: Microsoft Dynamics C5 2016
Número de KB original: 3214661

Síntomas

Al probar y habilitar un buzón en Microsoft Dynamics 365 (anteriormente conocido como Microsoft Dynamics CRM Online), se produce uno de los siguientes errores en el área Alertas:

  • El buzón de correo <Nombre del buzón> no se sincronizó porque se produjo un error al conectarse al servidor de correo electrónico. Se ha notificado al propietario del perfil del servidor de correo electrónico asociado <Email Server Profile Name>.
  • El buzón de correo <Nombre del Buzón> no sincronizó las citas, los contactos y las tareas porque se produjo un error al conectarse al servidor de Microsoft Exchange. Se ha notificado al propietario del perfil del servidor de correo electrónico asociado <Email Server Profile Name>.
  • No se puede enviar el mensaje de correo electrónico Test Message porque se produjo un error al intentar conectarse al servidor de correo electrónico. No se sincronizó el buzón <nombreDeBuzón>. Se ha notificado al propietario del perfil del servidor de correo electrónico asociado <Email Server Profile Name>.

Cada uno de los errores anteriores también incluye el siguiente código de error:

Código de error del servidor de correo electrónico: el servidor HTTP devolvió la excepción 404 NotFound.

Causa

Este problema puede ocurrir debido a uno de los siguientes motivos:

  1. No se encontró el buzón del usuario porque la dirección de correo electrónico no es correcta o el buzón no está disponible actualmente.
  2. La configuración del perfil de servidor de correo electrónico asociado no está configurada correctamente para poder localizar el buzón.

Solución

Para corregir este problema, siga estos pasos:

  1. Compruebe que la dirección de correo electrónico del registro de buzón de Microsoft Dynamics 365 coincide con la dirección de correo electrónico en Exchange. El error incluye un vínculo al registro de buzón en Microsoft Dynamics 365. Puede usar este vínculo para comprobar rápidamente el campo Dirección de correo electrónico. Si la dirección de correo electrónico es correcta, compruebe que el buzón está disponible abriendo con la aplicación de correo electrónico, como Microsoft Outlook o Outlook Web Access.
  2. Compruebe la configuración del perfil de servidor de correo electrónico asociado. Si usa Microsoft Dynamics 365 (en línea) con Exchange local, asegúrese de que usa un perfil de servidor de correo electrónico de Exchange Server (híbrido). Use solo un perfil de Exchange Online para los usuarios que tengan buzones en Exchange Online.

Más información

Al seleccionar Ver detalles, verá detalles de error como los siguientes:

IdDeActividad: <GUID>
Error: System.Net.WebException: La solicitud falló con el estado HTTP 404: No encontrado.
En System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
en System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
en Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()

IdDeActividad: <GUID>
Error: System.Net.WebException: La solicitud falló con el estado HTTP 404: No encontrado.
En System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
en System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
en Microsoft.Crm.Sync.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

T:593
IdDeActividad: <GUID>
Excepción: Excepción no controlada: Microsoft.Exchange.WebServices.Data.ServiceRequestException: error en la solicitud. El servidor remoto devolvió un error: (404) No encontrado.
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.EndGetEwsHttpWebResponse(IEwsHttpWebRequest request, IAsyncResult asyncResult)
en Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.EndInternalExecute(IAsyncResult asyncResult)
en Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.EndExecute(IAsyncResult asyncResult)
en Microsoft.Exchange.WebServices.Data.ExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
en Microsoft.Crm.Asynchronous.EmailConnector.MonitoredExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep`2.AfterCall()
en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep`2.E...