Compartir a través de


La actividad de campaña solo se puede distribuir una vez se haya eliminado los valores del campo de código de estado de la actividad de campaña y se haya solucionado cualquier error relacionado.

En este artículo se proporciona una solución para el problema que puede aparecer como error La actividad de campaña solo se puede distribuir una vez tras eliminar los valores del campo StatusCode de la actividad de campaña.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2501788

Síntomas

Después de personalizar el campo StatusCode de actividad de campaña, se produce un error en la distribución de las actividades de campaña.

Aparece el siguiente mensaje al seleccionar el botón Distribuir actividad de campaña :

La actividad de campaña solo se puede distribuir una vez.

Este problema ocurre cuando se eliminan algunos de los valores del campo StatusCode de Actividad de Campaña.

Causa

La operación de distribución de actividad de campaña necesita ciertos valores de StatusCode para ejecutarse. Aunque es posible quitar valores de la personalización, no los quite.

Solución

Una vez quitado el valor, no podrá volver a agregarlos manualmente en Microsoft Dynamics CRM. No elimine los valores del campo StatusCode.

Si ha quitado algunos de los valores, siga estos pasos para recuperarlos:

  1. Exporte la solución predeterminada:

    1. Haga clic en Configuración.
    2. Seleccione Personalizaciones y seleccione Personalizar el sistema.
    3. Seleccione Exportar solución.

    Nota:

    También puede agregar la actividad de campaña a una nueva solución y simplemente exportar esa solución. Extraiga el contenido del archivo ZIP de la solución.

  2. Abra el customizations.xml en un editor xml, como el Bloc de notas o Visual Studio, y busque el nodo siguiente:

    <Name LocalizedName="Campaign Activity" OriginalName="Campaign Activity">CampaignActivity</Name>
    <ObjectTypeCode>4402</ObjectTypeCode>
    <EntityInfo>
    
  3. Busque la siguiente sección dentro de este nodo. Probablemente tendrá una variación de lo siguiente donde faltan algunas etiquetas de estado.

    <?xml version="1.0" encoding="UTF-8"?>
    <statuses>
       <status value="1" state="0">
          <labels>
             <label description="Proposed" languagecode="1033" />
          </labels>
       </status>
       <status value="6" state="0">
          <labels>
             <label description="Completed" languagecode="1033" />
          </labels>
       </status>
       <status value="2" state="1">
          <labels>
             <label description="Closed" languagecode="1033" />
          </labels>
       </status>
       <status value="3" state="2">
          <labels>
             <label description="Canceled" languagecode="1033" />
          </labels>
       </status>
    </statuses>
    
  4. Tendrá que volver a agregar los estados que faltan (consulte a continuación una lista del estado predeterminado que debe tener).

    Nota:

    Puede agregar nuevos valores en Microsoft Dynamics CRM, pero estos valores predeterminados también deben estar ahí.

    <statuses>
        <status value="1" state="0">
            <labels>
                <label description="Proposed" languagecode="1033" />
            </labels>
        </status>
        <status value="0" state="0">
            <labels>
                <label description="In Progress" languagecode="1033" />
            </labels>
        </status>
        <status value="4" state="0">
            <labels>
                <label description="Pending" languagecode="1033" />
            </labels>
        </status>
        <status value="5" state="0">
            <labels>
                <label description="System Aborted" languagecode="1033" />
            </labels>
        </status>
        <status value="6" state="0">
            <labels>
                <label description="Completed" languagecode="1033" />
            </labels>
        </status>
        <status value="2" state="1">
            <labels>
                <label description="Closed" languagecode="1033" />
            </labels>
        </status>
    
  5. Guarde el customizations.xml modificado. A continuación, seleccione el archivo customization.xml y cualquier otro archivo que se extraiga con la solución para que estén resaltados, haga clic con el botón derecho y elija Enviar a y seleccione Carpeta comprimida (comprimida).

    Nota:

    Los archivos deben estar en la raíz del archivo ZIP y no en una carpeta de directorios.

  6. En Microsoft Dynamics CRM, seleccione Configuración y soluciones. Seleccione Importar y seleccione el nuevo archivo ZIP creado en el paso 5 que contiene el customizations.xml modificado.

  7. Seleccione Publicar todas las personalizaciones una vez completada la importación.

Más información

Al personalizar la entidad Actividad de campaña, si intenta eliminar un valor establecido de opción para el motivo de estado, verá el mensaje siguiente:

Los registros y personalizaciones existentes pueden hacer referencia a este valor de opción. Esas referencias no se actualizarán si se elimina este valor de opción. ¿Desea continuar?

Si continúa y elimina el valor del conjunto de opciones, se encontrará con este problema.