Recibe errores de memoria insuficientes al expandir un buzón o una carpeta pública en Outlook.
Número de KB original: 2968387
Síntomas
Cuando expande un buzón o una carpeta pública (excepto la Bandeja de entrada) en Microsoft Outlook o seleccione Libreta de direcciones en la barra de herramientas, puede recibir uno de los siguientes errores:
No se puede mostrar la carpeta. No hay suficiente memoria libre para ejecutar este programa. Salga de uno o varios programas y vuelva a intentarlo.
No se puede expandir la carpeta. No hay suficiente memoria disponible para realizar la operación.
No se pudo acceder a la lista de direcciones. Necesita más memoria o recursos del sistema. Cierre algunas ventanas e inténtelo de nuevo.
Cuando recibe uno de estos errores, es posible que el correo saliente se bloquee en la carpeta Bandeja de salida y no se envíe hasta que reinicie Outlook.
Causa
Este problema se produce cuando el perfil de mensajería de Outlook incluye una cuenta de Microsoft Exchange configurada para usar el modo de Exchange en caché, la opción Descargar favoritos de carpeta pública está habilitada y tiene muchas carpetas públicas almacenadas en caché. Normalmente, este problema se produce cuando tiene más de 1000 carpetas públicas aproximadamente o cuando las carpetas públicas almacenadas en caché consumen un gigabyte de espacio.
Solución
Para evitar este problema, deshabilite la opción Descargar favoritos de carpeta pública o mantenga el número de favoritos de carpetas públicas almacenadas en caché en menos de 1000. Si el problema continúa teniendo lugar con menos de 1000 favoritos de carpetas públicas, reduzca el número de carpetas hasta que deje de recibir el error o los errores. Normalmente, puede reducir el número de favoritos de carpetas públicas si los elimina mediante el cliente de Outlook. Sin embargo, en algunos casos en los que tiene demasiados favoritos de carpetas públicas, es posible que no pueda eliminar las carpetas mediante el cliente de Outlook porque el error se produce al seleccionar la carpeta Favoritos de la carpeta pública. Si esto ocurre, puede eliminar los favoritos de la carpeta pública mediante MFCMapi en su lugar.
Para resolver este problema, deshabilite la opción Descargar favoritos de carpeta pública, siga estos pasos:
En Outlook, seleccione Archivo, Configuración de la cuenta y Configuración de la cuenta.
Seleccione la cuenta de Microsoft Exchange y, a continuación, seleccione Cambiar.
Seleccione Más ajustes.
En la pestaña Avanzadas , desactive la casilla Descargar favoritos de carpeta pública.
Seleccione Aceptar.
Se le pedirá que reinicie Outlook para que estos cambios surtan efecto. Seleccione Aceptar.
Seleccione Siguiente, Seleccione Finalizar y, después, Cerrar.
Salga de Outlook y, a continuación, reinicie Outlook.
Para eliminar los favoritos de la carpeta pública mediante MFCMapi, siga estos pasos:
Descargue MFCMAPI.
Ejecute MFCMAPI.exe.
En el menú Session, haga clic en Logon.
Seleccione el nombre del perfil de Outlook y, a continuación, seleccione Aceptar.
En el panel superior, localice la línea que corresponde a su buzón y, a continuación, haga doble clic en ella.
En el panel de navegación (panel izquierdo), expanda Raíz - Buzón y, a continuación, seleccione la carpeta Accesos directos.
En el panel de detalles (panel derecho), busque las propiedades de PR_FOLDER_CHILD_COUNT. La columna Valor contiene el número de favoritos de la carpeta pública.
Si desea eliminar todos los favoritos de la carpeta pública, siga estos pasos:
En el panel de navegación. Haga clic con el botón derecho en la carpeta Accesos directos, seleccione Avanzado y, a continuación, seleccione Elementos vacíos y subcarpetas de la carpeta.
Mantenga las opciones predeterminadas y, a continuación, seleccione Aceptar.
Si desea eliminar favoritos de carpetas públicas específicas, siga estos pasos:
En el panel de navegación, expanda la carpeta Accesos directos, haga clic con el botón derecho en el favorito Carpeta pública que desea eliminar y seleccione Eliminar carpeta.
Mantenga las opciones predeterminadas y, a continuación, seleccione Aceptar.