Compartir a través de


Silverlight para Mac no se reconoce o se le pide que instale continuamente.

Nota:

Silverlight se ha retirado y está oficialmente fuera de soporte técnico. Para obtener más información, consulte Finalización del soporte de Silverlight.

Síntomas

Cuando intenta acceder a un sitio web que requiere que Silverlight muestre el contenido, recibirá un mensaje de error que indica que tiene que instalar Silverlight.

Causa

Este comportamiento puede producirse por varias razones:

  • El sistema tiene una versión anterior del complemento y no cumple los requisitos del complemento que usa el sitio.

  • No tiene instalado el complemento.

  • El explorador se establece en "Ejecutar con Rosetta", lo que hará que el equipo se identifique incorrectamente como un Mac basado en PowerPC.

Solución

Antes de determinar cómo solucionar el problema, debe evaluar el entorno actual en el que se ejecuta el software. Para ello, siga estos pasos:

  1. En el menú Apple , seleccione Acerca de este equipo Mac.

  2. Tenga en cuenta el tipo de procesador, la velocidad, la RAM y la información del sistema operativo, ya que algunos sitios web tienen requisitos específicos para ver su contenido.

  3. Cierra la ventana.

  4. Cierre todas las ventanas del explorador abiertas.

  5. Haga doble clic en el icono de disco duro en el escritorio.

  6. Haga doble clic en la carpeta Biblioteca .

  7. Abrir la carpeta Complementos de Internet.

  8. ¿Hay un archivo denominado Silverlight.plugin? Si este archivo existe, se instala el complemento. Para determinar la versión, haga clic para seleccionar el archivo. A continuación, seleccione Obtener información en el menú Archivo . Anote el número de versión que se muestra.

    • Si el número de versión que se muestra es 1.0.xxx y el tipo de procesador es powerPC, tiene instalada la versión correcta del complemento.

    • Si tiene un procesador Intel, se admiten todas las versiones de Silverlight. Pero se recomienda ejecutar la versión más reciente para que pueda acceder a sitios web que usen las características más recientes y aprovechar las mejoras de producto más recientes.

Ahora, podemos abordar las causas y resoluciones individuales.

El sistema tiene una versión anterior del complemento y no cumple los requisitos del sitio web

La causa más común de este problema es que el sitio web usa Silverlight 3 para su contenido. Si un sitio requiere la versión 3, reconoce si el sistema cumple los requisitos. Si el sistema no lo hace, se le pedirá que actualice. Se le dirige al sitio de Silverlight. Si usa powerPC, el sitio reconoce esto y solo se puede instalar la versión 1. (Esta situación tendría que ser abordada por el equipo de soporte técnico del sitio web, ya que la decisión sobre qué versión de Silverlight utilizar es tomada por los diseñadores del sitio web).

No tiene instalado el complemento

Si Silverlight aún no se ha instalado, siga estos pasos para instalar el complemento:

  1. Inicie un explorador web y, a continuación, visite el siguiente sitio web:

    http://silverlight.net/getstarted/

  2. Busque el área "Instalar Silverlight" en la parte inferior derecha de la ventana.

    • Si ejecuta un procesador Intel, haga clic en Tiempo de ejecución de Mac junto a "Silverlight 3".

    • De lo contrario, seleccione Runtime para Mac PowerPC junto a "Silverlight 1.0".

  3. Una vez completada la descarga, la instalación debe iniciarse automáticamente. Siga los pasos del Asistente para la instalación.

  4. Una vez completada la instalación, se le pedirá que salga del explorador. Cierre las ventanas del explorador y reinicie el explorador. El explorador debe reconocer el nuevo complemento.

El explorador se establece en "Ejecutar con Rosetta", lo que hará que el equipo se identifique incorrectamente como un Equipo Mac basado en PowerPC.

Si el explorador está configurado para ejecutarse en el motor de Rosetta, identificará incorrectamente el equipo como un Mac basado en PowerPC o el sitio web no reconocerá que el complemento adecuado está instalado.

Si el complemento adecuado está instalado como se describe en la sección anterior, siga estos pasos:

  1. Haga doble clic en el icono de disco duro en el escritorio.

  2. Elija la carpeta Aplicaciones .

  3. Busque el icono del explorador que está usando. Mantenga presionada la tecla CONTROL mientras hace clic en este icono.

  4. Seleccione Obtener información.

  5. Busque la opción Ejecutar mediante Rosetta y asegúrese de que esta casilla no está activada. Si está seleccionado, haga clic para desactivar la casilla. Cierra la ventana.

  6. En el menú Apple, seleccione Reiniciar.

  7. Una vez reiniciado el equipo, vuelva a intentar acceder al sitio web que generó el mensaje de error.

Nota:

Si la versión adecuada del complemento no está instalada, asegúrese de que la casilla Ejecutar con Rosetta no está seleccionada y, a continuación, siga los pasos de la sección anterior para instalar el complemento.