Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
En este artículo se proporciona una solución a un error que se produce al intentar agregar un nodo a un clúster de conmutación por error basado en Windows Server 2008.
Número de KB original: 2854337
Síntomas
Al intentar agregar un nodo a su clúster de conmutación por error basado en Windows Server 2008 existente mediante el Asistente para agregar nodos, recibirá el siguiente mensaje de error en la parte inferior de la pantalla Asistente para agregar nodos:
Error de carga del proveedor
Causa
El error "Error de carga del proveedor" se devuelve de WMI cuando se realiza una consulta y no puede cargar los proveedores necesarios para satisfacer la consulta. En este caso, el asistente "Agregar nodo" del clúster está realizando consultas para identificar el dominio del servidor y el proveedor no está registrado correctamente en el servidor.
Siga estos pasos para determinar si está experimentando este problema, en el servidor que está intentando agregar al clúster, así como en el nodo que ya forma parte del clúster:
- Abra WMI Tester - wbemtest.exe.
- Seleccione Conectar.
- En el cuadro Espacio de nombres , escriba root\cimv2 y, a continuación, seleccione Conectar.
- Seleccione Consulta y escriba
SELECT Domain FROM Win32_ComputerSystem
.
Si recibe el error "Error de carga del proveedor", está experimentando el problema documentado en este artículo, en este servidor.
Solución
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vea Cómo hacer copia de seguridad y restaurar el registro en Windows.
Para resolver este problema, debe corregir la información de registro del archivo Cimwin32.dll en el Registro mediante estos pasos:
Identifique un equipo con Windows Server 2008 que esté en el mismo nivel de Service Pack y Revisión que el servidor de problemas y pueda ejecutar correctamente la consulta mencionada anteriormente, en Wbemtest.exe.
Nota:
Esto no es necesariamente necesario ser un nodo de clúster.
Para abrir el Editor del Registro, seleccione Iniciar y escriba regedit.
Se requiere el permiso de administrador si se le solicita una contraseña de administrador o confirmación, escriba la contraseña o proporcione confirmación.
Vaya a la siguiente tecla:
HKEY_CLASSES_ROOT\CLSID\{D63A5850-8F16-11CF-9F47-00AA00BF345C}\InprocServer32
Seleccione la clave o la subclave de la que desea realizar una copia de seguridad.
Seleccione el menú Archivo y, a continuación, seleccione Exportar.
En el cuadro Guardar en, seleccione la ubicación donde desea guardar la copia de seguridad y escriba un nombre para el archivo de copia de seguridad en el cuadro Nombre de archivo. Guárdelo como . Reg.
Copie el archivo .REG guardado anteriormente al servidor con el problema.
Acceda al archivo en el servidor de problemas y haga doble clic en el archivo para combinarlo en el Registro.
Reinicia el servidor.