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Pueden producirse varios problemas en un equipo basado en Windows Server 2003 que ejecuta el Servicio de Instantáneas de Volumen.

En este artículo se describen los problemas en los que el identificador de evento 8019, 20, 8193 o 12302 se registra en el registro de aplicación. Recibirá un mensaje de error 0x8004230F o 0x80004002.

Se aplica a: Windows Server 2003
Número de KB original: 940032

Síntomas

En un equipo con Microsoft Windows Server 2003 que utiliza el Servicio de instantáneas de volumen (VSS), experimenta uno de los siguientes síntomas:

  • Al realizar una operación de copia de seguridad mediante la herramienta NTBackup, se registra el siguiente evento en el registro de aplicación:

    Tipo de evento: error
    Origen del evento: NTBackup
    Identificador de evento: 8019
    Descripción: Operación de finalización: se encontraron advertencias o errores. Consulte el informe de copia de seguridad para obtener más detalles.

    Nota:

    Si ve el archivo de registro de copia de seguridad, se muestra la siguiente información:

    Se devolvió un error al crear la instantánea de volumen:0xffffffff

  • Si accede a las propiedades de un volumen y, a continuación, hace clic en Copias de sombra, le aparecerá uno de los siguientes mensajes de error:

    Error 0x8004230F: El proveedor de instantáneas tenía un error inesperado al intentar procesar la operación especificada.

    Error 0x80004002: no se admite este tipo de interfaz

  • Uno de los siguientes eventos se registra en el registro de aplicación:

    Tipo de evento: error
    Origen del evento: VSS
    Identificador de evento: 20
    Descripción: Error del Servicio de Copias de Sombra de Volumen: un componente crítico requerido por el Servicio de Copias de Sombra de Volumen no está registrado. Es posible que esto haya ocurrido si se produjo un error durante la configuración de Windows o durante la instalación de un proveedor de copias de seguridad. El error devuelto por CoCreateInstance en la clase con CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} y nombre VSSEvent es [0x80040154].

    Tipo de evento: error
    Origen del evento: VSS
    Identificador de evento: 20
    Descripción: Error del Servicio de Copias de Sombra de Volumen: un componente crítico requerido por el Servicio de Copias de Sombra de Volumen no está registrado. Es posible que esto haya ocurrido si se produjo un error durante la configuración de Windows o durante la instalación de un proveedor de copias de seguridad. El error devuelto por CoCreateInstance en la clase con CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} y Nombre VSSEvent es [0x80004002].

    Tipo de evento: error
    Origen del evento: VSS
    Identificador de evento: 8193
    Descripción: Error inesperado del servicio de instantáneas de volumen: error inesperado al llamar a la rutina CoCreateInstance. hr = 0x80040154.

    Tipo de evento: error
    Origen del evento: VSS
    Categoría del evento: ninguna
    Identificador de evento: 8193
    Descripción: Error inesperado del servicio de instantáneas de volumen: error inesperado al llamar a la rutina CoCreateInstance. hr = 0x80004002.

    Tipo de evento: error
    Origen del evento: VSS
    Identificador de evento: 12302
    Descripción: Error del Servicio de Copias de Sombra de Volumen: se detectó una inconsistencia interna al intentar contactar a los escritores del servicio de copias de sombra. Asegúrese de que el Servicio de Eventos y el Servicio de Instantáneas de Volumen funcionan correctamente.

Causa

Este problema se produce porque los archivos del sistema VSS no están registrados.

Solución

Nota:

Este artículo no se usa con Windows Vista, con Windows Server 2008 o con sistemas operativos posteriores. A partir de Windows Vista y con Windows Server 2008, la instalación de componentes de Windows se basa en manifiestos. Si intenta registrar manualmente componentes específicos, como los que se describen en esta sección "Resolución", en los sistemas operativos que se mencionan en esta nota, pueden producirse resultados inesperados que pueden requerir reinstalar Windows para resolver.

Para resolver el problema, siga estos pasos:

  1. Haga clic en Inicio y en Ejecutar, escriba cmd y, por último, haga clic en Aceptar.

  2. Escriba los siguientes comandos en el símbolo del sistema. Presione ENTRAR después de escribir cada comando.

    • cd /d %windir%\system32
    • Net stop vss
    • Net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll

    Nota:

    Es posible que el último comando no se ejecute correctamente.

  3. Realice una operación de copia de seguridad para comprobar que se ha resuelto el problema.

Más información

Pasos para reproducir este problema

  1. Escriba el siguiente comando en un símbolo del sistema. Presione ENTRAR después de escribir el comando.

    regsvr32 /u swprv.dll
    
  2. Intente realizar una operación de copia de seguridad.