Importar y exportar la configuración de SQL Server Management Studio (SSMS)

En este tutorial se describe cómo importar la configuración desde otra instalación de SQL Server Management Studio (SSMS) y cómo exportar la configuración desde SSMS. En este artículo, aprenderá a:

  • Importar configuración
  • Configuración de exportación
  • Restablecer toda la configuración

Importar configuración de usuario

La primera vez que abra SSMS después de instalar una versión principal, SSMS le pedirá que importe la configuración del usuario:

Captura de pantalla que muestra el cuadro de diálogo Importar configuración de usuario.

El cuadro de diálogo Importar configuración de usuario solo aparece la primera vez que se inicia una versión recién instalada. Por ejemplo, si tiene SSMS 21.6.x instalado en el equipo e instala SSMS 22.5.x, aparecerá el cuadro de diálogo. Si tiene SSMS 22.4.x instalado e instala SSMS 22.5.x, el cuadro de diálogo de importación no aparece.

Para una nueva instalación de SSMS 22, puede importar la configuración desde SSMS 20 o SSMS 21 o no importar ninguna configuración.

Si elige importar la configuración en este cuadro de diálogo, solo importa la configuración de conexión. Una vez completada la importación, abra el cuadro de diálogo de conexión. En la lista desplegable Nombre del servidor, verá los servidores que existen en la versión de SSMS desde la que importó la configuración. La configuración de conexión de cada servidor, como autenticación y nombre de usuario, también se importan.

Importar la configuración del entorno

  1. Para importar la configuración del entorno desde otra instalación de SSMS, seleccione Herramientas>Importar y exportar configuración....

  2. En el cuadro de diálogo de bienvenida, seleccione Importar configuración de entorno seleccionada y, a continuación, seleccione Siguiente.

  3. Si hay cambios en la configuración del entorno que desea guardar, seleccione Sí, guarde la configuración actual y escriba un nombre de archivo y una ubicación para el archivo de configuración. De lo contrario, seleccione No, simplemente importe nuevas configuraciones, sobrescribiendo mi configuración actual. Seleccione Siguiente.

  4. Elija el archivo de configuración que desea importar y seleccione Siguiente.

  5. Elija la configuración que desea importar y, a continuación, seleccione Finalizar.

Exportar la configuración del entorno

  1. Para exportar la configuración del entorno desde una instalación existente de SSMS, seleccione Tools>Importar y exportar configuración....

  2. En el cuadro de diálogo de bienvenida, seleccione Exportar la configuración del entorno seleccionada y, a continuación, seleccione Siguiente.

  3. Elija la configuración que desea exportar y, a continuación, seleccione Siguiente.

  4. Escriba un nombre de archivo y una ubicación para el archivo de configuración y, a continuación, seleccione Finalizar.

Restablecer la configuración al valor predeterminado

  1. Para restaurar la configuración predeterminada, seleccione Herramientas>Importar y exportar configuración....

  2. En el cuadro de diálogo de bienvenida, seleccione Restablecer toda la configuración y, a continuación, seleccione Siguiente.

  3. Si hay cambios en la configuración del entorno que desea guardar, seleccione Sí, guarde la configuración actual y escriba un nombre de archivo y una ubicación para el archivo de configuración. De lo contrario, seleccione No, simplemente importe nuevas configuraciones, sobrescribiendo mi configuración actual. Seleccione Siguiente.

  4. Elija la colección de opciones de configuración que desea restaurar y, a continuación, seleccione Finalizar.