Ejercicio: Análisis de datos
Ponga en práctica algunos de los principios y técnicas de análisis de datos que ha aprendido. En este laboratorio, usará Excel para la Web para analizar y visualizar datos.
En este laboratorio, analizas las ventas de limonada de Rosie y creas visualizaciones que te ayudarán a obtener conocimientos de los datos.
Antes de empezar
Nota:
Si ha realizado el módulo anterior de esta ruta de aprendizaje, puede omitir la sección Antes de empezar e ir directamente a Ejercicio 1: Análisis de datos con una tabla dinámica.
Si aún no tiene un cuenta Microsoft (por ejemplo, una cuenta de hotmail.com, live.com o outlook.com), regístrese para obtener una en https://signup.live.com.
Cargar el libro en OneDrive
En el explorador web, vaya a https://onedrive.live.com e inicie sesión con las credenciales de su cuenta de Microsoft. Debería ver los archivos y carpetas en OneDrive, de la siguiente manera:
En el menú + Nuevo, seleccione Carpeta para crear una carpeta. Puede darle el nombre que desee, por ejemplo, DAT101. Cuando aparezca la nueva carpeta, haga clic en ella para abrirla.
En la nueva carpeta vacía, en el menú ⤒ Cargar, haga clic en Archivos. Después, cuando el sistema se lo indique, en el cuadro Nombre de archivo, escriba la siguiente dirección en el campo Nombre de archivo (puede copiarla y pegarla desde aquí):
https://github.com/MicrosoftLearning/mslearn-data-concepts/raw/main/labfiles/Lemonade_formatted.xlsxA continuación, haga clic en Abrir para cargar el archivo de Excel que contiene los datos sobre la limonada de Rosie, como se muestra aquí:
Después de unos segundos, el archivo Lemonade_formatted.xlsx debería aparecer en la carpeta de la siguiente manera:
Ejercicio 1: Analizar datos con una tabla dinámica
Las tablas dinámicas son una excelente manera de segmentar y desglosar datos, resumiendo las medidas numéricas por una o varias dimensiones. En este ejercicio, se usa una Tabla dinámica para ver los datos de limonada, agregados de varias maneras.
Crea una tabla dinámica
Si aún no lo ha hecho, en el explorador web, vaya a https://onedrive.live.com e inicie sesión con las credenciales de su cuenta de Microsoft. Si completó el módulo anterior en esta ruta de aprendizaje, abra el libro Lemonade.xlsx; de lo contrario, abra el Lemonade_formatted.xlsx en la carpeta donde lo cargó en la sección Antes de empezar. El libro de trabajo debe tener el siguiente aspecto:
Seleccione cualquier celda de la tabla de datos y, en la pestaña Insertar de la cinta de opciones, haga clic en Tabla dinámica y cree una tabla dinámica a partir de la tabla de datos en una nueva hoja de cálculo. Excel agrega una nueva hoja de cálculo con una tabla dinámica que se parece a esta.
En el panel Campos de tabla dinámica, seleccione Mes. Excel agrega automáticamente Mes al área Filas de la tabla dinámica y muestra los nombres de mes en orden cronológico.
En el panel Campos de tabla dinámica, seleccione Ventas. Excel agrega automáticamente Suma de ventas al área Valores de la tabla dinámica y muestra el número total (suma) de ventas de limonada para cada mes, de la siguiente manera:
Ahora puede ver las ventas agregadas por mes. Por ejemplo, hubo 1056 ventas en junio.
Agregar una segunda dimensión
En el panel Campos de tabla dinámica, seleccione Día. Excel agrega automáticamente Día al área Filas de la tabla dinámica y muestra el número total (suma) de ventas de limonada para cada día de la semana de cada mes, de la siguiente manera:
Ahora puede ver las ventas mensuales agregadas por día de la semana. Por ejemplo, 57 de las ventas de enero tuvieron lugar en sábado. También puede expandir o contraer meses para explorar con menos detalle/explorar en profundidad los niveles de la jerarquía.
En el panel Campos de tabla dinámica, arrastre Día desde el área Filas hasta el área Columnas. Excel ahora muestra las ventas totales de cada mes en filas, desglosadas por día de la semana en columnas; de esta manera:
Todavía puede ver las ventas mensuales desglosadas por día de la semana, pero también puede ver (en la fila inferior) los totales de cada día de la semana de todo el año. Por ejemplo, un total de 1324 ventas tuvieron lugar en lunes.
Cambiar la agregación
En el panel Campos de tabla dinámica, en el área Valores, haga clic en la flecha desplegable situada junto a Suma de ventas y, a continuación, haga clic en Configuración de campo de valor.
En el cuadro de diálogo Configuración de campo de valor, seleccione Promedio, como se muestra aquí:
La tabla de datos muestra ahora el número medio de ventas de cada mes y día de la semana, como se muestra aquí:
Ahora puede ver el número medio de ventas de cada día de la semana por mes. Por ejemplo, el número medio de ventas de los miércoles en febrero es 19,75.
Desafío: Análisis de tabla dinámica
- Modifique los campos de la tabla dinámica para obtener la siguiente información:
- Suma total de ingresos en agosto.
- Temperatura del sábado más caluroso de julio.
- El número más bajo de folletos distribuidos durante un día en noviembre.
Ejercicio 2: Visualización de datos con gráficos
A menudo, puede ser más fácil identificar tendencias y relaciones en los datos mediante la creación de visualizaciones de los datos, como los gráficos.
Ver la tendencia de la ventas del año
Modifique la tabla dinámica que creó en el ejercicio anterior para que muestre Fecha en el área Filas y la suma de Ventas y la suma de Temperatura (en ese orden) en el área Valores, de la siguiente manera:
Antes de continuar, asegúrese de que la tabla tiene un aspecto similar al que se muestra. Tenga en cuenta que la fecha puede tener un formato diferente para su ubicación.
Con las siguientes instrucciones, seleccione solamente las celdas que contienen los valores de fecha, ventas diarias y temperatura, pero no las celdas Fecha, Suma de ventas y Suma de temperatura ni las celdas del pie de página Total general:
- Haga clic en la celda A4, que debe contener el valor de fecha del 1 de enero de 2017.
- A continuación, presione MAYÚS + CTRL + ⇨ (MAYÚS + ⌘ + ⇨ en macOS) para ampliar la selección para incluir los valores de ventas y temperatura.
- A continuación, presione MAYÚS + CTRL + ⇩ (MAYÚS + ⌘ + ⇩ en macOS) para seleccionar las filas debajo de la selección actual.
- Por último, presione MAYÚS + ⇧ para anular la selección de los totales generales.
En la pestaña Inicio de la cinta de opciones, haga clic en el botón Copiar (🗐) para copiar las celdas seleccionadas en el Portapapeles.
En la hoja de cálculo, haga clic en el botón Hoja nueva (+) para agregar una nueva hoja de cálculo al libro.
En la nueva hoja, seleccione la celda A2 y, en la pestaña Inicio, haga clic en el botón Pegar (📋) para pegar las celdas copiadas en la nueva hoja de cálculo. Es posible que tenga que ampliar la columna A para ver las fechas.
En las celdas A1 a C1, agregue los encabezados de columna Fecha, Ventas y Temperatura. La nueva hoja de cálculo debe tener el siguiente aspecto:
Seleccione los datos de Fecha y Ventas, incluidos los encabezados (pero no los datos de temperatura). A continuación, en las pestañas Insertar de la cinta de opciones, en la lista desplegable Líneas, haga clic en el primer formato de gráfico de líneas. Excel inserta un gráfico de líneas como este:
Tenga en cuenta que el gráfico de líneas muestra las fluctuaciones diarias en las ventas, pero la tendencia general parece indicar que las ventas son mayores durante los meses de verano e inferiores al principio y al final del año.
Elimine el gráfico y seleccione todos los datos y encabezados, incluido Temperatura, e inserte un nuevo gráfico de líneas. Se inserta un gráfico como este:
Esta vez, el gráfico incluye series independientes para Ventas y Temperatura. Ambas series muestran un patrón similar; parece que las ventas y la temperatura aumentan durante los meses de verano.
Seleccione el gráfico y haga doble clic en el título del gráfico. A continuación, en el panel Gráfico de la pestaña Formato, expanda Título del gráfico y cambie el título del gráfico a Ventas y temperatura:
Cierre el panel Gráfico.
Ver los ingresos por día de la semana
Vuelva a la hoja de cálculo que contiene la tabla dinámica y modifíquela para mostrar Día en filas con el promedio de Ingresos. El resultado debe tener este aspecto, aunque puede que los días de la semana no estén ordenados:
Copie los valores de día y promedio de ingresos (pero no los encabezados ni el total) en el Portapapeles y, a continuación, agregue una nueva hoja de cálculo, pegue los datos copiados en la celda A2 y agregue los encabezados Día y Promedio de ingresos de la siguiente manera:
Seleccione el encabezado de columna B y, en la pestaña Inicio de la cinta de opciones, use el menú $ para dar formato a los datos de ingresos como $ Inglés (Estados Unidos), de la siguiente manera:
Seleccione todos los datos, incluidos los encabezados Día y Promedio de ingresos y, en la pestaña Insertar de la cinta de opciones, en la lista desplegable Columnas, seleccione el primer formato de gráfico de columnas. Se crea un gráfico similar al siguiente:
A primera vista, este gráfico parece mostrar una variación significativa entre los ingresos medios de diferentes días de la semana, con ingresos mucho más altos los jueves que los domingos. Sin embargo, observe más detenidamente la escala en el eje vertical (Y): la diferencia es inferior a 30 centavos.
Seleccione el gráfico de columnas y, en la pestaña Gráfico de la cinta de opciones, en la lista desplegable Circular, seleccione el formato Gráfico 2D. El gráfico cambia a un gráfico circular como este:
Observe que los sectores del círculo tienen más o menos el mismo tamaño para cada día.
Seleccione el gráfico circular y, en la pestaña Gráfico, en la lista desplegable Etiquetas de datos, seleccione Extremo interno. Esto muestra las cantidades de datos reales en el gráfico, de la siguiente manera:
Ahora se ve más claro que hay poca variación aparente en los ingresos medios de los diferentes días de la semana.
Ver las ventas por folletos
Vuelva a la hoja de cálculo que contiene la tabla dinámica y modifíquela para mostrar Fecha en filas con la suma de Prospectos y la suma de Ventas, de la siguiente manera:
Copie los valores de fecha, prospectos y ventas (pero no los encabezados ni los totales) en una nueva hoja de cálculo y agregue los encabezados Fecha, Prospectos y Ventas de esta manera:
Seleccione los datos y encabezados de Folletos y Ventas (pero no las fechas). A continuación, en la pestaña Insertar, en la lista desplegable Dispersión, seleccione el primer formato de gráfico de dispersión. Esto crea un gráfico de dispersión como este:
Nota:
El gráfico muestra el número de prospectos distribuidos cada día en el eje horizontal (X) y el número de ventas de cada día en el eje vertical (Y). El trazado forma una línea más o menos diagonal (con alguna varianza), lo que indica una tendencia general de que el número de ventas aumente de acuerdo con el número de folletos distribuidos.
Ver las ventas por precipitaciones
Vuelva a la hoja de cálculo que contiene la tabla dinámica y modifíquela para mostrar Fecha en filas con la suma de Precipitaciones y la suma de Ventas como valores, de la siguiente manera:
Copie los valores de fecha, precipitaciones y ventas (pero no los encabezados ni los totales) en una nueva hoja de cálculo y agregue los encabezados Fecha, Precipitaciones y Ventas, así:
Seleccione los encabezados y los datos de Precipitaciones y Ventas (pero no las fechas). A continuación, en la pestaña Insertar, en la lista desplegable Dispersión, seleccione el primer formato de gráfico de dispersión. Esto crea un gráfico de dispersión como este:
Este trazado parece indicar algún tipo de relación entre las precipitaciones y las ventas, que caen a medida que aumentan las precipitaciones. Sin embargo, la línea formada por los trazados es curva. A menudo, esto significa que hay una relación no lineal, posiblemente logarítmica.
Elimine el gráfico para ver las columnas D y E vacías después de los datos de precipitaciones y ventas diarias.
En D1, agregue el encabezado de columna Registro de precipitaciones. Después, seleccione la celda D2 y escriba la siguiente fórmula en el cuadro fx situado encima de la hoja de cálculo para calcular el registro en base 10 del valor de precipitaciones:
=log(B2)Copie la fórmula en las demás celdas de la columna Registro de precipitaciones. La manera más fácil de hacerlo es seleccionar la celda que contiene la fórmula y hacer doble clic en el pequeño "controlador" cuadrado (▪) de la parte inferior derecha de la celda seleccionada.
En E1, agregue el encabezado de columna Registro de ventas. A continuación, seleccione la celda E2 y escriba la fórmula siguiente en el cuadro fx situado encima de la hoja de cálculo para calcular el registro en base 10 del valor de ventas:
=log(C2)Copie la fórmula en las demás celdas de la columna Registro de ventas.
Seleccione los encabezados y los datos de LogRainfall y LogSales. A continuación, en la pestaña Insertar, en la lista desplegable Dispersión, seleccione el primer formato de gráfico de dispersión. Esto crea un gráfico de dispersión como este:
Observe que este trazado muestra una relación lineal entre el registro de precipitaciones y el registro de ventas. Esto resulta potencialmente útil a medida que exploramos las relaciones en los datos, ya que es más fácil calcular una ecuación lineal que relacione las precipitaciones con las ventas que definir una ecuación logarítmica para hacer lo mismo.
Desafío: Visualización de datos
- Cree un gráfico de columnas que muestre la suma de los prospectos distribuidos cada día de la semana y anote los días en los que se distribuyeron los números más alto y más bajo de prospectos.
- Cree un gráfico de dispersión que muestre la temperatura y las precipitaciones diarias, y examine la aparente relación entre estos campos.