AADSTS75005 de error: la solicitud no es un mensaje de protocolo Saml2 válido

En este artículo se describe un problema en el que recibe el mensaje de error "Error AADSTS75005- La solicitud no es un mensaje de protocolo Saml2 válido". Al intentar iniciar sesión en una aplicación que se ha integrado con Microsoft Entra ID.

Síntomas

Recibe un error AADSTS75005 al intentar iniciar sesión en una aplicación que se ha configurado para usar Microsoft Entra ID para la administración de identidades mediante el inicio de sesión único basado en SAML.

Causa

Microsoft Entra ID no admite la solicitud SAML enviada por la aplicación para el inicio de sesión único. Algunos problemas comunes son:

  • Faltan campos obligatorios en la solicitud SAML.
  • Método codificado de solicitud SAML.

Solución

  1. Capture la solicitud SAML. Siga el tutorial Cómo depurar el inicio de sesión único basado en SAML en las aplicaciones de Microsoft Entra ID para obtener información sobre cómo capturar la solicitud SAML.
  2. Póngase en contacto con el proveedor de la aplicación y comparta la siguiente información:

El proveedor de la aplicación debe validar que admite la implementación Microsoft Entra SAML para el inicio de sesión único.

Más información

Para obtener una lista completa de los códigos de error de autenticación y autorización de Active Directory, consulte Microsoft Entra códigos de error de autenticación y autorización.

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.