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Error: "El socket web está cerrado o no se pudo abrir"

En este artículo se describe cómo resolver el mensaje de error "El socket web está cerrado o no se pudo abrir" que impide que Microsoft Azure Container Instances se conecte a una red virtual.

Síntomas

Al intentar conectarse al contenedor desde Azure Portal, recibirá el siguiente mensaje de error:

Se produjo el siguiente error de socket web: error: el socket web está cerrado o no se pudo abrir. Valide la conexión de red y vuelva a intentarlo.

Causa

El firewall o el proxy corporativo bloquean el acceso al puerto 19390. Este puerto es necesario para conectarse a Container Instances desde Azure Portal cuando los grupos de contenedores se implementan en redes virtuales.

Solución

Para resolver este error, permita la entrada al puerto TCP 19390 en el firewall. Como mínimo, asegúrese de que el firewall proporciona acceso a ese puerto para todas las direcciones IP de cliente públicas a las que azure Portal tiene que conectarse.

En algunos escenarios en los que el proxy corporativo bloquea el puerto 19390, permita este puerto para el proxy corporativo y, a continuación, compruebe el tráfico mediante la pestaña Red de las herramientas de desarrollo del explorador.

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