Share via


Solución de problemas de implementación con el reinicio o el cambio de tamaño de una máquina virtual Windows existente en Azure

Al intentar iniciar una máquina virtual de Azure detenida o cambiar el tamaño de una máquina virtual de Azure existente, es común encontrarse un error de asignación. Dicho error se produce cuando el clúster o la región no tienen recursos disponibles o no admiten el tamaño de máquina virtual solicitado.

Si su problema con Azure no se trata en este artículo, visite los foros de Azure en MSDN y Stack Overflow. Puede publicar su problema en ellos o en @AzureSupport en Twitter. También puede enviar una solicitud de soporte de Azure. Para enviar una solicitud de soporte, en la página Soporte técnico de Azure, seleccione Obtener soporte técnico.

Recopilación de registros de actividad

Para iniciar la solución de problemas, recopile los registros de actividad para identificar el error asociado con el problema. Los vínculos siguientes contienen información detallada sobre el proceso:

Ver operaciones de implementación

Ver registros de actividad para administrar recursos de Azure

Problema: Error al iniciar una VM detenida

Intenta iniciar una máquina virtual detenida, pero obtiene un error de asignación.

Causa

La solicitud de iniciar la máquina virtual detenida se debe intentar en el clúster original que hospeda el servicio en la nube. Sin embargo, el clúster no tiene espacio libre disponible para responder a la solicitud.

Solución

  • Detenga todas las máquinas virtuales del conjunto de disponibilidad y reinicie las máquinas virtuales.

    1. Haga clic en Grupos de recursos>su grupo de recursos>Recursos>su conjunto de disponibilidad>Virtual Machines>su máquina virtual>Detener.
    2. Después de detener todas las máquinas virtuales, selecciónelas y haga clic en Iniciar.
  • Vuelva a intentar solicitar el reinicio más tarde.

Problema: Error al reiniciar una VM existente

Intenta cambiar el tamaño de una máquina virtual existente, pero obtiene un error de asignación.

Causa

La solicitud de cambiar el tamaño de la máquina virtual se debe realizar en el clúster original que alberga el servicio en la nube. Sin embargo, el clúster no admite el tamaño de máquina virtual solicitado.

Solución

  • Vuelva a intentar la solicitud con un tamaño de máquina virtual menor.

  • Si no se puede cambiar el tamaño de la máquina virtual solicitada:

    1. Detenga todas las máquinas virtuales en el conjunto de disponibilidad.

      • Haga clic en Grupos de recursos>su grupo de recursos>Recursos>su conjunto de disponibilidad>Virtual Machines>su máquina virtual>Detener.
    2. Después de detener todas las máquinas virtuales, aumente el tamaño de la máquina virtual que quiera.

    3. Seleccione la máquina virtual cuyo tamaño ha cambiado, haga clic en Iniciar e inicie las máquinas virtuales detenidas.

Error al detener, iniciar, reiniciar o volver a implementar una VM existente

Cuando intenta detener, iniciar, reiniciar o volver a implementar una máquina virtual existente, se produce un error en el proceso y recibe un error inesperado al procesar el perfil de red de la máquina virtual. Vuelva a intentarlo más tarde", mensaje de error. Cuando se produce este error, la VM pasa a un estado fallido.

Causa

Este problema ocurre si hay un problema al asignar o actualizar los recursos de red.

Solución

Intente volver a aplicar el estado de máquina virtual. Esta operación vuelve a ejecutar el aprovisionamiento de la VM y ayuda a resolver el error de estado que se produce si su aprovisionamiento de falló cuando se ejecutó una acción anterior de la VM.

  1. Navegue hasta la VM que está atascada en el estado fallido.
  2. En Ayuda, seleccione Volver a implementar + volver a aplicar.
  3. Seleccione la opción Volver a aplicar.

Pasos siguientes

Si surgen problemas al crear una nueva máquina virtual Windows en Azure, consulte Solución de problemas de implementación de Resource Manager con la creación de una máquina virtual de Windows en Azure.

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.