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Se aplica a: ✔️ Máquinas virtuales de Windows
Número de KB original: 4010136
En este artículo se proporciona una solución a un problema por el que la máquina virtual Windows no comienza con el código de error 0xc00000ba.
Síntoma
Windows no se inicia. En su lugar, el sistema genera un error similar al siguiente:
Archivo: \Windows\System32\drivers\<filename>
Estado: 0xc00000ba
Información: No se pudo cargar el sistema operativo porque falta un controlador de sistema crítico o contiene errores.
Causa
Este problema se produce porque los archivos del sistema de Windows están dañados. Esto puede ocurrir si se cumple una de las condiciones siguientes:
- Una instalación sin terminar
- Borrado de archivos sin terminar
- Eliminación incorrecta de la aplicación o el equipo
- El portátil de escritorio está contaminado con un ataque troyano
- Un apagado deficiente del sistema informático
El archivo del sistema dañado causa ausencia, documentos vinculados incorrectamente y archivos esenciales para el funcionamiento correcto del programa.
Solución
Sugerencia
Si tiene una copia de seguridad reciente de la VM, puede intentar restaurar la VM desde la copia de seguridad para corregir el problema de arranque.
Para corregir el problema, siga estos pasos.
Paso 1 Desinstalar el software o servicio instalados recientemente
Si el problema de arranque se produce después de instalar software o servicios, intente deshabilitar el servicio. Si el problema sigue apareciendo, desinstale completamente el software.
Para deshabilitar un servicio, siga estos pasos:
- Elimine la máquina virtual (VM). Asegúrese de seleccionar la opción Mantener los discos cuando lo haga.
- Conecte el disco del SO como un disco de datos a otra VM (VM de solución de problemas). Para más información, consulte Conexión de un disco de datos administrado a una máquina virtual Windows en Azure Portal.
- Conéctese a la máquina virtual de solución de problemas. Abra Administración de equipos>Administración de discos. Asegúrese de que el disco del sistema operativo esté en línea y de que sus particiones tengan letras de unidad asignadas.
- En el disco del sistema operativo que ha conectado, vaya a \windows\system32\config. Copie todos los archivos como copia de seguridad en caso de que se requiera una reversión.
- En la máquina virtual de solución de problemas, abra el Editor del Registro (regedit.exe).
- Haga clic en la clave HKEY_LOCAL_MACHINE y, a continuación, seleccione Carga>de archivos de Hive en el menú.
- Vaya a \windows\system32\config\SYSTEM, escriba un nombre para el subárbol, como ProblemSystem. Después de hacerlo, verá el subárbol del Registro en HKEY_LOCAL_MACHINE.
- Vaya a
HKEY_LOCAL_MACHINE\ProblemSystem\ControlSet001\services\<ServiceNname>
, cambie los datos de valor de Inicio a 4, lo que significa deshabilitar el servicio. - Desasocie el disco reparado de la VM de solución de problemas. A continuación, cree una nueva VM desde el disco del SO.
Para desinstalar completamente el software, debe descargar el disco del sistema operativo en el entorno local y desinstalar el software.
Paso 2 Reparar el sistema de archivos dañado
Elimine la máquina virtual (VM). Asegúrese de seleccionar la opción Mantener los discos cuando lo haga.
Conecte el disco del SO como un disco de datos a otra VM (VM de solución de problemas). Para más información, consulte Conexión de un disco de datos administrado a una máquina virtual Windows en Azure Portal.
Conéctese a la máquina virtual de solución de problemas y, a continuación, abra Administración de discos de administración>de equipos. Asegúrese de que el disco del sistema operativo está en línea y de que sus particiones tienen asignada la letra de unidad.
Tiene dos opciones en este momento, puede usar las imágenes de la consola de recuperación que vienen con cada instalación del sistema operativo e intentar usarla como repositorio o, de lo contrario, puede descargar la iso completa de la versión de Windows de la máquina virtual.
Si desea usar la imagen de la consola de recuperación, tenga en cuenta que es una imagen pequeña y compacta, que puede que no tenga el binario que necesita usar, si es así, SFC podría terminar diciendo que hay daños pero que el binario que necesita no está en esta imagen. Si ese es el caso, debe ir a la segunda opción mediante una imagen ISO completa. Use la imagen de WinRE ubicada en todas las instalaciones de Windows (recuperar imagen de consola) como repositorio para intentar corregir los daños.
Para usar la imagen de la consola de recuperación, ejecute los siguientes comandos en una instancia de CMD con privilegios elevados:
Dism <Drive letter of the broken OSdisk>:\ /cleanup-image /restorehealth /source:wim: <Drive letter of the broken OSdisk>:\recovery\windowsRE\winre.wim:1
En el ejemplo siguiente se supone que G es la letra asignada al disco del sistema operativo:
Dism /image:g:\ /cleanup-image /restorehealth /source:wim:g:\recovery\windowsRE\winre.wim:1
Para descargar una ISO completa para esa versión de Windows, extraiga los archivos de la ISO multimedia y, a continuación, busque el archivo WIM dentro y úselo como repositorio:
Dism /image:<Drive letter of the broken OSdisk>:\ /cleanup-image /restorehealth /source:<Wim file from ISO>:1
Vuelva a crear la máquina virtual.
Si la máquina virtual sigue sin arrancar, vuelva a adjuntar el disco del sistema operativo en una máquina virtual de solución de problemas y ejecute un comando SFC sobre la imagen:
sfc /scannow /offbootdir=<Drive letter of the broken OS>:\ /offwindir=<Drive letter of the broken OS>:\windows
Si SFC indica que se ha corregido el daño, desasocie el disco del sistema operativo de la máquina virtual de solución de problemas y espere hasta que Azure actualice la concesión de disco (3 minutos como máximo).
Vuelva a crear la máquina virtual.
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