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Se aplica a: ✔️ Máquinas virtuales de Windows
En este artículo se describe cómo solucionar problemas del identificador de evento 157, un escenario en el que desapareció un disco de datos, se perdió o se quitó del sistema operativo invitado (SO) de Windows de una máquina virtual (VM) de Microsoft Azure.
Síntomas
Es posible que descubra que se produjo una eliminación de disco si experimenta alguno de los síntomas siguientes:
Los discos parecen estar conectados en Azure Portal aunque el sistema operativo invitado notifique los discos como quitados de la máquina virtual.
Los discos dentro de entornos de clúster de SQL y las máquinas virtuales de Azure se quitan inesperadamente, lo que provoca interrupciones en las cargas de trabajo.
Los datos y los servidores basados en Microsoft SQL Server se ponen en peligro debido a estas eliminaciones inesperadas de discos.
La carga de trabajo excesiva, la configuración del Registro mal configurada y la memoria baja se identifican como posibles desencadenadores para el identificador de evento 157.
Si experimenta estos síntomas, abra la aplicación Visor de eventos en la máquina virtual Windows para investigar. Seleccione el nodo Sistema de registros> de Windows Visor de eventos (local)> en el panel Árbol de consola. En la lista de eventos, seleccione la etiqueta de columna Id. de evento para ordenar por identificador de evento y, a continuación, busque y haga doble clic en la entrada de registro que tiene un valor de Id. de evento de 157. La pestaña General del cuadro de diálogo Propiedades del evento muestra información similar a la tabla siguiente.
Campo de evento | Valor |
---|---|
Nombre del registro | Sistema |
Source | disk |
Registrado (fecha) | <timestamp> |
Id. del evento | 157 |
Categoría de la tarea | Ninguno |
Nivel | Advertencia |
Palabras clave | Clásico |
Usuario | N/D |
Equipo | SERVER-hash-value.domain1.priv<> |
Descripción | Se ha quitado el número> de disco<. |
Causa
La desaparición del disco suele ocurrir cuando algo interrumpe la comunicación entre el sistema y el disco, como un error de tejido de red de área de almacenamiento (SAN) o un problema de bus de interfaz de sistema de equipo pequeño (SCSI). Como alternativa, puede experimentar una desaparición de disco si se produce un error en un disco o se desconecta un disco mientras se ejecuta el sistema operativo.
El identificador de evento 157 se produce dentro del sistema operativo invitado (o mientras se trabaja con un rol de clúster de conmutación por error de Windows). Esto suele ocurrir debido a los siguientes factores subyacentes:
La carga de trabajo de E/S excesiva provoca limitaciones y retrasos de E/S. Estos problemas, a su vez, hacen que el disco alcance el umbral de tiempo de espera de E/S.
La subclave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk registry está mal configurada. En concreto, la entrada del Registro IoTimeoutValue dentro de esa subclave se establece en un valor demasiado pequeño, como 60 segundos.
Nota:
Si el valor de tiempo de espera es demasiado pequeño, aumente este valor, pero no use un valor superior a 179 segundos. Después de un retraso de 180 segundos, el sistema invoca el identificador de evento 17 dentro del nodo host y desencadena el reinicio de la máquina virtual.
Ejecutó una validación de clúster dentro del sistema operativo invitado para comprobar el almacenamiento local en el nodo del clúster. (Es decir, una operación intencionada provocó el identificador de evento 157).
Existe una condición de memoria baja dentro de la máquina virtual.
Solución
Las instrucciones para corregir el problema de desaparición de disco difieren en función de si los discos están en un entorno de clúster o en un entorno que no es de clúster.
Ejecute la herramienta de diagnóstico de autoayuda de PerfInsights .
Si está trabajando en un rol de clústeres de conmutación por error de Windows, recopile los registros del clúster de Windows durante el período de tiempo afectado. Si PerfInsights no ha recopilado estos registros, ejecute el cmdlet Get-ClusterLog en PowerShell.
Obtenga la configuración del Registro para el tiempo de espera del disco inspeccionando el informe de PerfInsights.
Compruebe si hay una configuración del Registro mal configurada en el sistema operativo invitado. Si también hay una limitación excesiva de E/S, este escenario podría explicar por qué se alcanza el umbral de tiempo de espera.
Actualice de HDD estándar (unidad de disco duro) a otro tipo de disco administrado por Azure. Se recomienda no ejecutar un rol de clúster que use hdD de almacenamiento estándar porque pueden provocar problemas como la desaparición del disco.
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