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Se aplica a: ✔️ Máquinas virtuales de Windows
En este artículo se muestra cómo solucionar problemas de una relación de confianza con errores entre la estación de trabajo y el dominio principal en una máquina virtual (VM) Windows de Azure.
Si su problema con Azure no se trata en este artículo, visite los foros de Azure en MSDN y Stack Overflow. Puede publicar su problema en ellos o en @AzureSupport en Twitter. También puede enviar una solicitud de Microsoft Soporte técnico de Azure.
Para enviar una solicitud de soporte técnico, vaya a la página Soporte técnico de Azure y seleccione Obtener soporte técnico.
Síntoma
No puede completar una conexión de protocolo de escritorio remoto (RDP) a la máquina virtual y recibe el error: "Error en la relación de confianza entre esta estación de trabajo y el dominio principal".
Causa
El canal seguro de Active Directory entre esta máquina virtual y el dominio principal se interrumpe. Este error muestra que la máquina no puede establecer una comunicación segura con un controlador de dominio en su dominio, ya que la contraseña secreta no está establecida en el mismo valor en el controlador de dominio.
Solución
Complete los pasos siguientes en la máquina virtual. Si está disponible, intente conectarse a la máquina virtual a través de la conexión a Escritorio remoto (RDC) mediante un usuario local. Si no puede conectarse a la máquina virtual mediante RDC, pruebe una herramienta de solución de problemas remota alternativa para máquinas virtuales de Azure.
Comprobación de la conectividad con el controlador de dominio
Para buscar el controlador de dominio que usa la máquina virtual, escriba el siguiente comando en CMD.exe.
set | find /i "LOGONSERVER"
Compruebe la conectividad de red con el controlador de dominio. Por ejemplo, puede usar el cmdlet Test-Connection para probar la conectividad con el nombre de dominio completo (FQDN) del controlador de dominio identificado en el paso 1.
Si no hay conectividad con el controlador de dominio desde la máquina virtual, solucione los problemas de la ruta de acceso de red. Los diagnósticos de Network Watcher pueden ayudar en esta solución de problemas.
Comprobación del estado del canal seguro
Con PowerShell, ejecute el cmdlet "Test-ComputerSecureChannel" para ver si el canal seguro es correcto.
Ejemplo:
Test-ComputerSecureChannel -verbose
Si el canal seguro es correcto, intente RDP en la máquina virtual mediante el usuario del dominio. Si el canal seguro no es correcto, intente reparar el canal seguro.
Reparación del canal seguro
Si el canal seguro no es correcto, intente corregirlo o vuelva a unir la máquina virtual al dominio.
Con PowerShell, ejecute el cmdlet "Test-ComputerSecureChannel" para reparar el canal seguro.
Test-ComputerSecureChannel -Repair
Si el canal seguro no se repara, restablezca la contraseña del equipo.
Restablecimiento de la contraseña de la máquina
Si no pudo reparar el canal seguro, intente restablecer la contraseña del equipo.
Con PowerShell, ejecute el cmdlet "Reset-ComputerMachinePassword" para restablecer la contraseña del equipo de la máquina virtual.
Ejemplo:
$cred = Get-Credential Invoke-Command -ComputerName "Server01" -ScriptBlock {Reset-ComputerMachinePassword -Credential $using:cred}
Si esto no vuelve a establecer el canal seguro, quite la máquina virtual del dominio y vuelva a unirse al dominio.
Quitar la máquina virtual del dominio y volver a unirse al dominio
Como última opción, quite la máquina virtual del dominio y vuelva a unir el dominio.
Con PowerShell, ejecute el cmdlet "Remove-Computer" para quitar la máquina virtual del dominio.
Ejemplo:
'Remove-Computer -UnjoinDomaincredential Domain01\Admin01 -PassThru -Verbose -Restart'
Con PowerShell, ejecute el cmdlet "Add-Computer" para volver a unir la máquina virtual al dominio.
Ejemplo:
'Add-Computer -ComputerName Server01 -LocalCredential Server01\Admin01 -DomainName Domain02 -Credential Domain02\Admin02 -Restart -Force'
Recursos adicionales
Conceptos detallados: Explicación del canal seguro
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