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La eliminación de acuerdos de nivel de servicio o elementos de acuerdo de nivel de servicio muestra un error en la interfaz unificada durante una actualización de la solución o una eliminación manual

En este artículo se proporciona una solución para el problema por el que la eliminación de acuerdos de nivel de servicio (SLA) o elementos de acuerdo de nivel de servicio muestra un mensaje de error en la interfaz unificada durante una actualización de la solución o la eliminación manual.

Síntomas

Al intentar eliminar acuerdos de nivel de servicio o sla durante una actualización o eliminación manual de la solución, se produce uno de los siguientes mensajes de error:

El objeto que intentó eliminar está asociado a otro objeto y no se puede eliminar.

La operación de eliminación de SLAItem encontró algunos errores. El proceso forma parte de una solución administrada y no se puede eliminar individualmente. Desinstale la solución primaria para quitar el proceso. Consulte registro para obtener más detalles.

Causa

El primer mensaje de error se produce porque, en el acuerdo de nivel de servicio de la interfaz unificada, la relación entre el elemento del ACUERDO de nivel de servicio y las instancias de KPI de SLA se establece en "Restringir a eliminar". El segundo mensaje de error se produce porque los procesos que forman parte de una solución administrada no se pueden eliminar. Si intenta eliminar manualmente un Acuerdo de Nivel de Servicio que forma parte de una solución administrada y tiene flujos configurados, aparece el mensaje de error.

Solución 1

En lugar de eliminar el Acuerdo de Nivel de Servicio, desactive el Acuerdo de Nivel de Servicio en su organización. Si forma parte de una solución administrada, siga estos pasos:

  1. Desactive el Acuerdo de Nivel de Servicio en la instancia de origen y agréguelo a la solución.
  2. Desactive el mismo Acuerdo de Nivel de Servicio en la instancia de destino y, a continuación, aplique la actualización de la solución.

Solución 2

En primer lugar, puede eliminar manualmente todos los registros de entidad relacionados con el ACUERDO de Nivel de Servicio y las instancias de KPI de SLA y, a continuación, quitar el ACUERDO de Nivel de Servicio. Estos son los pasos:

  1. En su organización, vaya a Búsqueda avanzada, busque Instancias de KPI de acuerdo de nivel de servicio y, a continuación, seleccione SLAItem.
  2. Seleccione Resultado. Se mostrarán las instancias de KPI de SLA.
  3. Seleccione las instancias de KPI de SLA necesarias y, a continuación, seleccione Eliminar SLAKPIInstances. Esto también anulará las instancias de KPI de SLA en los registros relacionados.

Incluso después de eliminar los registros de referencia, si el mensaje de error "Operación de eliminación de SLAItem encontró algunos errores. El proceso forma parte de una solución administrada y no se puede eliminar individualmente. Desinstale la solución primaria para quitar el proceso. Consulte registro para obtener más detalles", se muestra y, a continuación, aplique la actualización de la solución con el Acuerdo de Nivel de Servicio eliminado de la solución de actualización.

Resolución 3

Si la resolución anterior no funciona, póngase en contacto con Soporte técnico de Microsoft para solicitar la eliminación de los elementos de SLA o SLA.