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"Existen errores de entrada de datos en el lote RMPMXFR UserID" Mensaje de error al seleccionar "Procesar" en la ventana Crear comprobaciones de reembolso en Microsoft Dynamics GP

En este artículo se proporciona una solución a un error que se produce al seleccionar Procesar en la ventana Crear comprobaciones de reembolso en Microsoft Dynamics GP.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 933027

Importante

Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que puede restaurar si se produce un problema.

Síntomas

Al seleccionar Procesar en la ventana Crear comprobaciones de reembolso y, a continuación, selecciona Transferir, puede experimentar los siguientes problemas.

Escenario 1

Aparece el siguiente mensaje de error:

Existen errores de entrada de datos en el lote RMPMXFR UserID. Use la ventana Recuperación por lotes para procesar este lote.

Nota:

UserID es un marcador de posición para el nombre de inicio de sesión del usuario que está procesando los cheques de reembolso. Este nombre de inicio de sesión forma parte del nombre del lote.

Si la casilla Abrir automáticamente la impresión de cheques por pagar está activada en la ventana de Configuración de cheques de reembolso, este mensaje de error se muestra antes de que se muestre la ventana de Imprimir cheques por pagar.

Seleccione Aceptar después de recibir el mensaje de error. Si sigue imprimiendo el lote de comprobación, recibirá el siguiente mensaje de error:

Se han encontrado errores en este lote de comprobación. Corrija los errores antes de imprimir.

Nota:

Si tiene habilitado el análisis multidimensional (MDA) para cualquiera de las cuentas gl usadas en la comprobación de reembolso y si tiene un grupo de análisis de MDA establecido en Obligatorio, pero no se definen los identificadores de códigos MDA predeterminados, se produce el mismo error y también crea un registro en blanco en la tabla PM20000. Después de esto, el registro dañado debe quitarse manualmente de la tabla PM20000. El problema se puede evitar mediante la designación de un identificador de código de análisis de MDA predeterminado para el grupo de análisis o cuenta de MDA establecido en 100 %, o estableciendo el identificador de grupo de análisis de MDA asignado para la cuenta en Opcional en lugar de Requerido.

Escenario 2

  • Puede ver las transacciones del proveedor en la ventana "Consulta de transacciones por pagar - Proveedor".
  • Usted selecciona la fila del proveedor.
  • Presione la tecla TAB para desplazarse de un campo.

En este escenario, recibirá el siguiente mensaje de error:

El procedimiento almacenado createSQLTmpTable devolvió los siguientes resultados: DBMS 2627, Microsoft Dynamics GP:0.

La ventana "Consulta de transacciones pagaderas - Proveedor" contiene los dos documentos de trabajo siguientes resultantes del procesamiento de la comprobación de reembolso:

  • El pago del cheque para el reembolso
  • Un cargo misceláneo

Nota:

No ve ningún documento duplicado en la ventana "Consulta de transacciones por pagar - Proveedor".

Si desmarca la casilla Trabajo y la casilla Historial y, a continuación, selecciona Reexhibir, aparece otro documento de cargo varios. Este documento tiene el estado Abrir y no se muestra el mensaje de error duplicado. Si analizas detenidamente ese documento abierto, el cargo misceláneo no tiene ningún importe y parece estar dañado. Este documento no aparece si activa las siguientes casillas al mismo tiempo:

  • Trabajo
  • Abierto
  • Historial

Causa

Causa del escenario 1

Este problema se produce si se interrumpe la contabilización del cargo varios en Administración de pagaderos en Microsoft Dynamics GP por uno de los siguientes motivos:

  • La cuenta de pago no está asignada en la ventana Mantenimiento de la cuenta de proveedor y la cuenta de pago no está asignada en la ventana Configuración de cuentas de contabilización.
  • La empresa está registrada para la Seguridad a Nivel de Cuenta. Además, el usuario que está procesando las comprobaciones de reembolso no tiene permiso para usar las cuentas de pago designadas en la ventana Mantenimiento de la cuenta de proveedor o en la ventana Configuración de cuentas de contabilización.
  • El período fiscal en el que se produce el reembolso en Cuentas pagaderas en Microsoft Dynamics GP se cierra.
  • El procesamiento de los cheques de reembolso encontró una interrupción en el procesamiento o una interrupción de la red.

Causa o escenario 2

Este problema se produce si se ha interrumpido la contabilización de un cargo misceláneo que el cheque cubre. El cargo misceláneo se registró parcialmente sin especificar un importe, y la transacción sigue en el lote.

Solución

Resolución del escenario 1

Para resolver este problema, determine la causa de la lista de posibles causas en el escenario 1 de la sección Causa y, a continuación, corrija el problema. Para corregir el problema, siga estos pasos:

  1. Asegúrese de que está configurada una cuenta predeterminada de cuentas por pagar para Compras en Microsoft Dynamics GP, y que la cuenta aparece en la lista Mostrar de la ventana Configuración de cuentas de contabilización.
  2. Asegúrese de que el usuario tenga acceso a la cuenta de cuentas por pagar en la ventana de Asignación Masiva de la Estructura Organizativa. Para abrir la ventana Asignación masiva de estructura organizativa, seleccione Sistema en el menú Tarjetas y, a continuación, seleccione Asignaciones organizativas.
  3. Asegúrese de que el usuario tiene acceso a la ventana Cuentas pagaderas mediante seguridad normal o seguridad avanzada.
  4. Asegúrese de que el período fiscal en el que se publica el documento tiene el estado Abrir en la ventana Configuración de períodos fiscales en Compra. Para abrir la ventana Configuración de períodos fiscales, seleccione Configurar en el menú Herramientas, seleccione Empresa y, a continuación, seleccione Períodos fiscales.
  5. Haga que el lote de comprobación esté disponible y, a continuación, haga que el lote RMPMXFR esté disponible. Para ello, siga los pasos descritos en KB: se mantiene un lote en el estado Contabilización, Recepción, Ocupado, Marcado, Bloqueado o Editado en Microsoft Dynamics GP.
  6. Si experimenta los problemas en el escenario 2, vaya a la resolución del escenario 2.

Resolución del escenario 2

Para solucionar este problema, siga estos pasos:

  1. Si aún no ha puesto a disposición el lote de comprobación, póngalo a disposición. Para ello, siga los pasos descritos en KB: se mantiene un lote en el estado Contabilización, Recepción, Ocupado, Marcado, Bloqueado o Editado en Microsoft Dynamics GP.

  2. Una vez comprobados los documentos, quite el documento duplicado.

    Nota:

    Si el documento que tiene un estado Abierto se publica correctamente, y el documento que tiene un estado Trabajo no se corrige, elimine el grupo para quitar el documento duplicado. Si el documento que tiene un estado de Abierto está dañado, quite el documento que tiene el estado de Abierto y, a continuación, habilite el documento que tiene un estado de Trabajo para que pueda publicarse. (Si no hay cantidades o si la fecha del documento es 00/00/0000, el documento puede estar dañado). Puede quitar este documento mediante el siguiente script de eliminación en el Analizador de consultas SQL o mediante la Consola de administrador de soporte técnico.

    Delete PM20000 where Dex_Row_ID = XX
    

    Nota:

    XX es un marcador de posición para el Identificador de Fila de Dex de la carga adicional.

  3. Si tiene que publicar el documento de cargos varios, publique el documento.

  4. Después de recuperar el lote de cheques, imprime el lote de cheques y, a continuación, publica el lote de cheques. Para obtener más información, consulte KB: se mantiene un lote en el estado Contabilización, Recepción, Ocupado, Marcado, Bloqueado o Editado en Microsoft Dynamics GP.

Más información

Para usar comprobaciones de reembolso, tenga en cuenta los siguientes requisitos:

  • La característica Comprobaciones de reembolso debe estar registrada y debe haber adquirido cuentas por pagar y cuentas por cobrar en Microsoft Dynamics GP.
  • La ventana Configuración de comprobaciones de reembolso debe estar configurada.
  • El registro del proveedor debe crearse para el cliente.
  • La relación entre el cliente y el proveedor debe establecerse en la ventana Relaciones de cliente/proveedor.

Cuando se procesan las comprobaciones de reembolso, Microsoft Dynamics GP asume que el cliente ha pagado por encima de la factura y solicita que la empresa reembolsará el pago en efectivo excesivo. Al procesar el reembolso, se crea una nota de débito. La nota de débito se aplica al pago por exceso de efectivo. A continuación, se crea un cargo misceláneo. El cargo diverso se registra inmediatamente al proveedor. Este documento de cargo varios se selecciona para el pago mediante una comprobación.