Compartir a través de


Error "Documento ya existe" al ingresar un documento en la ventana de Cuentas por Pagar

Este artículo ofrece una solución para el error document already exists que se produce cuando se escribe un documento en la ventana Entrada de transacción de cuentas por pagar en Microsoft Dynamics GP.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 863247

Síntomas

Al intentar escribir un documento en la ventana Entrada de transacciones por pagar en Microsoft Dynamics GP o en Microsoft Business Solutions - Great Plains, recibirá el siguiente mensaje de error:

El documento ya existe.

Este problema se produce si se cumplen las condiciones siguientes:

  • Se le interrumpe cuando intenta agregar un documento en la ventana de entrada de transacciones por pagar.
  • Después de la interrupción, el documento no se muestra en la ventana Consulta de transacciones por pagar.
  • A continuación, intente escribir el mismo número de documento en la ventana Entrada de transacción pagadera.

Causa

Este problema se produce porque se agregó un registro para este documento a la tabla principal de claves pm (PM00400). Pero no se agregó un registro para este documento a la tabla de trabajo de transacciones PM (PM10000).

Solución

Para resolver este problema, quite el registro de la tabla PM00400. Para hacerlo, siga estos pasos.

Nota:

Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que puede restaurar si se produce un problema.

  1. Use el paso adecuado, en función de si usa Microsoft SQL Server o el motor de escritorio de Microsoft SQL Server (también conocido como MSDE 2000):

    • Si usa Microsoft SQL Server 2005, inicie SQL Server Management Studio. Para ello, seleccione Inicio, Todos los programas, Microsoft SQL Server 2005 y SQL Server Management Studio.
    • Si usa Microsoft SQL Server 2000, inicie el Analizador de consultas SQL. Para ello, seleccione Inicio, Programas, Microsoft SQL Server y Analizador de consultas.
    • Si usa MSDE 2000, inicie la consola de administrador de soporte técnico. Para ello, seleccione Inicio, seleccione Programas, seleccione Consola de administrador de Microsoft y luego seleccione Consola de administrador de soporte técnico.
    • Si usa Microsoft SQL Server 2008, inicie el Analizador de consultas sql. Para ello, seleccione Inicio, Programas, Microsoft SQL Server 2008 y SQL Server Management Studio.
    • Si usa Microsoft SQL Server 2008 R2, inicie SQL Server Management Studio. Para ello, seleccione Inicio, Todos los programas, Microsoft SQL Server 2008 R2 y SQL Server Management Studio.
    • Si usa Microsoft SQL Server 2012, inicie SQL Server Management Studio. Para ello, seleccione Inicio, Todos los programas, Microsoft SQL Server 2012 y SQL Server Management Studio.
  2. Ejecute las siguientes instrucciones en la base de datos de empresa para comprobar en qué tabla existe el documento:

    select * from PM00400 where CNTRLNUM = 'XXXX' and VENDORID = 'VVVV'
    select * from PM10000 where VCHRNMBR = 'XXXX' and VENDORID = 'VVVV'
    

    Nota:

    Reemplace el marcador XXXX por el número del vale. Reemplace el marcador de posición VVVV por el identificador del proveedor.

  3. Confirme que los resultados son para la transacción interrumpida. y que la condición existe donde el documento existe en la tabla de Claves PM de PM00400 y no en la tabla de Trabajo de Transacciones de PM10000.

  4. Una vez que haya confirmado que el problema es que el documento existe en la tabla Claves de PM y no en la tabla de trabajo de transacciones de PM, puede ejecutar la siguiente instrucción en la base de datos de la empresa para quitarlo de la tabla Claves de PM:

    delete PM00400 where CNTRLNUM = 'XXXX' and VENDORID = 'VVVV'
    

    Nota:

    Reemplace el marcador de posición XXXX por el número de vale. Reemplace el marcador de posición VVVV por el identificador del proveedor.