Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
En este artículo se proporciona una solución a los errores que se producen al intentar buscar un lote de compras en administración de pagaderos mediante Microsoft Dynamics GP.
Se aplica a: Microsoft Dynamics GP
Número de KB original: 2316165
Síntomas
Cuando vaya a la ventana Entrada por lotes por lotes pagadera e intente buscar un lote, recibirá el siguiente mensaje de error:
Excepción de script no controlada:
El índice 0 de la matriz "VerifyBatchTotals" está fuera de rango en el guion.
'Batch_Lookup_Scrolling_Window SCROLL_FILL', script terminado.
A continuación, desplácese hacia abajo en la ventana para ver el resto del mensaje:
EXCEPCIÓN_CLASE_SCRIPT_FUERA_DE_RANGO
SCRIPT_CMD_INDEX
Al seleccionar Aceptar, recibirá el siguiente mensaje:
Se ha eliminado el registro seleccionado.
Causa
Este mensaje puede deberse a un registro dañado para un lote de cheques en la tabla maestra de las Definiciones de Publicación SY00500. Esta tabla contiene la información sobre los lotes del sistema.
Solución
Para resolver este problema, vuelva a crear la tabla maestra de definiciones de publicación SY00500 mediante una de las dos opciones que se enumeran a continuación. Puede volver a crear esta tabla mediante el mantenimiento de SQL en Microsoft Dynamics GP o mediante el kit de herramientas gratuito en la biblioteca de herramientas de servicios profesionales. Ambas opciones se enumeran a continuación:
Nota:
Antes de continuar, asegúrese de que tiene una copia de seguridad restaurable actual o pruebe estos pasos en un entorno de prueba antes de aplicar los pasos a la base de datos de producción. Restaura inmediatamente desde tu copia de seguridad si obtienes resultados inesperados.
OPCIÓN 1: USO DEL MANTENIMIENTO DE SQL
- Realice una copia de seguridad completa de Microsoft Dynamics GP.
- Seleccione Microsoft Dynamics GP, seleccione Mantenimiento y, a continuación, seleccione SQL.
- Seleccione la base de datos de empresa que recibe el error.
- En la lista de Tabla, seleccione Maestro de Definiciones de Publicación.
- En el lado derecho de la ventana, active todas las casillas y, a continuación, seleccione Procesar.
- Seleccione Sí en el mensaje siguiente:
Ha seleccionado eliminar tablas; esto eliminará los datos de estas. ¿Estás seguro de que quieres continuar?"
Nota:
Este procedimiento vuelve a crear la tabla SY00500 - Maestro de Definiciones de Publicación. Sin embargo, perderá temporalmente todos los lotes sin enviar. Para recuperar estos lotes sin publicar, ejecute el programa de verificación de vínculos en los submódulos. A continuación, concilie los lotes de Microsoft Great Plains General Ledger. Sin embargo, establece los lotes configurados como recurrentes en uso único. Debe volver a cambiar estos lotes a Recurrente si es necesario.
Para recuperar los lotes, siga estos pasos.
Si utilizas la opción multimoneda en la Gestión de Cuentas por Pagar de Microsoft Dynamics GP, ejecuta el programa Verificar Vínculos en los archivos lógicos históricos de pagos antes de ejecutar el programa Verificar Vínculos en el archivo lógico de transacciones de pagos. Si usa Varias monedas, puede omitir este paso y ir al paso 2.
Para ejecutar el programa Comprobar vínculos en los siguientes archivos, seleccione Microsoft Dynamics GP, seleccione Mantenimiento, seleccione Comprobar vínculos, seleccione uno de los siguientes nombres de serie y, a continuación, escriba el nombre de tabla lógica correspondiente. Siga este paso para los siguientes archivos:
Módulo: Administración de pagaderos
Serie/Tabla lógica: Serie de compras - Transacciones de cuentas por pagar lógicasMódulo: Procesamiento de pedidos de compra
Serie/Tabla lógica: Serie de compras- Transacción de compra lógicaMódulo: Administración de recibos
Serie/Tabla lógica: Serie de Ventas - Transacciones Abiertas de Cuentas por CobrarMódulo: facturación
Serie/Tabla Lógica: Series de Ventas - Archivo de Trabajo de FacturaMódulo: Procesamiento de pedidos de ventas
Serie/Tabla lógica: Ventas - Archivo de trabajo de ventasMódulo: Inventario
Serie/Tabla lógica: Inventario: archivo de trabajo de transacciones de inventarioMódulo: Lista de materiales
Serie/Tabla lógica: Inventario - Inventario - Archivo de transacciones de lista de materiales
Si usa Microsoft Dynamics GP Project Series (PS) Time & Expense, también debe ejecutar Check Links en los siguientes archivos. Para ejecutar Comprobar vínculos en los siguientes archivos, seleccione Archivo, Mantenimiento, PS Comprobar vínculos y, a continuación, elija uno de los siguientes nombres de archivo. Siga este paso para los siguientes archivos:
- Lotes de parte de horas: transacciones del parte de horas de PS
- Lotes de registro de activos - Transacciones de registro de activos de PS
- Lotes de registro de gastos - Transacciones del registro de gastos de PS
- Lotes de transferencia de inventario: transacciones de transferencia de inventario de PS
- Lotes de órdenes de compra - Transacciones de órdenes de compra de PS
- Nombre de la serie: Lotes de factura del proveedor: transacciones de factura del proveedor de PS
- Lotes de gastos de empleado: transacciones de gastos de empleado de PS
- Lotes de facturación: tiempo de facturación de PS y transacciones de materiales
Si existen lotes en Microsoft Dynamics GP General Ledger, seleccione Herramientas en el menú Microsoft Dynamics GP, seleccione Utilidades, seleccione Finanzas y, a continuación, seleccione Reconciliar. Seleccione Lotes y, después, seleccione Reconciliar para conciliar los lotes.
Vuelva a probar para comprobar si se ha resuelto el mensaje de error.
OPTION #2: Uso de la biblioteca de herramientas de servicios profesionales (PSTL)
Realice una copia de seguridad completa de Microsoft Dynamics GP.
Haga que todos los usuarios cierren sesión en Microsoft Dynamics GP.
Siga estos pasos para instalar la Biblioteca de herramientas de servicios profesionales (PSTL) y agregarla como acceso directo en Microsoft Dynamics GP. Si ya lo ha hecho, puede omitir este paso.
Pasos para instalar la biblioteca de servicios de herramientas profesionales (PSTL):
Visite este sitio customerSource para descargar PSTL: (Las instrucciones de instalación se incluyen con la descarga).
Después de instalar PSTL, inicie sesión en Microsoft Dynamics GP como administrador del sistema (usuario "sa").
Seleccione Sí cuando se le pida que incluya código nuevo.
Para agregar PSTL a la barra de acceso directo, seleccione Agregar, seleccione Otra ventana, expanda Herramientas de servicio técnico, expanda Proyecto, seleccione Biblioteca de herramientas profesionales, seleccione Agregar y, a continuación, seleccione Listo.
En la barra de acceso directo, seleccione Herramientas de servicio profesional. Espere a que se compilen los objetos SQL. Cuando se le pida que escriba las claves de registro, seleccione Cancelar. No es necesario usar las claves de registro para usar el kit de herramientas gratuito.
Seleccione Kit de herramientas. Seleccione Siguiente.
En Opciones del kit de herramientas, seleccione Volver a crear objetos SQL y, a continuación, seleccione Siguiente.
Junto a Serie, seleccione Compañía.
Junto a Tabla, seleccione SY00500.
En Opciones de mantenimiento, seleccione la opción Volver a crear tabla seleccionada y Volver a crear datos para las tablas seleccionadas.
Importante
Debe activar la casilla Volver a crear datos para las tablas seleccionadas para que se conserven los datos actuales de la tabla. Si olvida marcarlos, perderá todos los datos actuales y tendrá que restaurarlos inmediatamente en la copia de seguridad.
Seleccione Realizar mantenimiento seleccionado.
Cuando reciba los siguientes mensajes, seleccione Aceptar:
La tabla se volverá a crear con datos
La tabla SY00500 se recreará con los datos. Compruebe que se ha realizado una copia de seguridad antes de continuar SY00500 se ha vuelto a crear
Vuelva a probar para ver si se ha resuelto el mensaje de error.
Si sigue recibiendo el mensaje de error, es necesario volver a crear los índices de la SY00800 (actividad por lotes). Para ello, siga los pasos siguientes para resolver el problema: (*Asegúrese de que tiene una copia de seguridad restaurable de la base de datos de la empresa en caso de que se produzca una pérdida de datos no deseada).
Seleccione el vínculo Biblioteca de herramientas de servicios profesionales en la pestaña Accesos directos y, a continuación, elija habilitar Toolkit. Aparecerá la ventana Kit de herramientas.
Seleccione Volver a crear objetos SQL en la ventana Kit de herramientas y, a continuación, seleccione Siguiente.
Seleccione Sistema para la Serie y SY00800 para la tabla.
En Opciones de mantenimiento, seleccione Recompilar índices para la tabla seleccionada.
Nota:
Compruebe que nadie publique o edite un lote cuando se vuelvan a crear los índices para esta tabla. La tabla SY00800 tiene un registro en él cada vez que un usuario está editando o publicando un lote en cualquier módulo.
Seleccione el botón Realizar mantenimiento seleccionado para volver a crear los índices.
Más información
Si tiene algún lote que entra en recuperación de lotes, consulte KB - Se mantiene un lote en el estado Contabilización, Recepción, Ocupado, Marcado, Bloqueado o Editado en Microsoft Dynamics GP para obtener instrucciones sobre cómo volver a poner el lote en estado de 'Disponible'.