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Mensaje de error al intentar abrir la ventana Entrada de pedido de compra en Procesamiento de pedidos de compra en Microsoft Dynamics GP 10.0: "No tiene privilegios de seguridad para abrir esta ventana"

En este artículo se proporciona una solución a un error que se produce al abrir la ventana Entrada de pedido de compra en Procesamiento de pedidos de compra en Microsoft Dynamics GP.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 945957

Síntomas

Al abrir la ventana Entrada de pedido de compra en Procesamiento de pedidos de compra en Microsoft Dynamics GP 10.0, recibirá el siguiente mensaje de error:

No tiene privilegios de seguridad para abrir esta ventana. Póngase en contacto con el administrador del sistema para obtener ayuda.

Si concede acceso al usuario del Agente de compra, se abre la ventana Entrada de pedido de compra .

Causa

Este problema se produce porque un recurso adicional para otro módulo de complemento necesita la seguridad concedida. Por ejemplo, Manufacturing es el recurso más común que se instala y que necesita la seguridad concedida.

Solución

Para resolver el problema, use uno de los siguientes métodos.

Método 1: Conceder acceso a la ventana de ECM_DPOP_Hidden

Nota:

En los pasos siguientes se supone que Manufacturing es el recurso que provoca el problema.

  1. En el menú Microsoft Dynamics GP , seleccione Herramientas, Configuración, Sistema y, a continuación, haga clic en Tareas de seguridad.

  2. En la ventana Configuración de tareas de seguridad , especifique los siguientes campos:

    • Id. de tarea: escriba una tarea asignada al usuario.
    • Producto: Fabricación
    • Tipo: Windows
    • Serie: tercera parte
  3. En la sección Lista de acceso , haga clic para activar la casilla Oculta para conceder acceso a la ventana de ECM_DPOP_Hidden.

Método 2: Deshabilitar aplicaciones de terceros y productos de complemento

  1. En el menú Microsoft Dynamics GP , seleccione Herramientas, Personalizar y, a continuación, haga clic en Estado de personalización.

  2. En la ventana Estado de personalización , seleccione uno de los productos de complemento o una de las aplicaciones de terceros y, a continuación, haga clic en Deshabilitar para deshabilitar temporalmente el producto o la aplicación.

  3. Intente abrir la ventana Entrada de pedido de compra .

  4. Repita el paso 1 al paso 3 para determinar qué producto de complemento o aplicación de terceros causa este problema.

Para obtener más información sobre cómo deshabilitar completamente las aplicaciones y personalizaciones de terceros, haga clic en el siguiente número de artículo para ver el artículo en Microsoft Knowledge Base:

872087 Cómo deshabilitar productos de terceros en el archivo Dynamics.set en Microsoft Dynamics GP

Si tiene que conceder seguridad a un recurso para un producto de terceros, póngase en contacto con la empresa que admita ese producto. Si el producto es un producto de complemento para Microsoft Dynamics GP, abra un incidente de soporte técnico con Microsoft para solucionar el problema.

Si desea abrir un incidente de soporte técnico con el soporte técnico de Microsoft Dynamics GP, recopile un archivo Dexsql.log del error antes de ponerse en contacto con el soporte técnico para ayudarle a solucionar el problema. Para obtener más información sobre cómo recopilar un archivo de Dexsql.log, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:

850996 Cómo crear un archivo de Dexsql.log para Microsoft Dynamics GP

Además, puede intentar acceder a la ventana Entrada de pedido de compra mediante el identificador de usuario administrador del sistema o los identificadores de usuario avanzado designados. Anote los resultados mediante el identificador de usuario del administrador del sistema o un identificador de usuario avanzado. Esta información puede ayudarle a solucionar el problema.