Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
En este artículo se proporciona una solución a un error que se produce al publicar un lote en Microsoft Dynamics GP.
Se aplica a: Microsoft Dynamics GP
Número de KB original: 898996
Síntomas
Al intentar publicar un lote en Microsoft Dynamics GP, recibirá el siguiente mensaje de error:
El procedimiento almacenado glpPostBatch devolvió los siguientes resultados: DBMS: 0, Great Plains: 20286
glpPostBatch. Seleccione en Batch_Headers error.
Causa
Este problema se debe a una de las razones siguientes:
- La tabla maestra de definiciones de publicación (SY00500) está dañada.
- Procedimiento almacenado que falta o está dañado para 'dbo.glpPostBatch'.
- Falta el desencadenador en la tabla SY00500 después de volver a generarlo.
- Registro bloqueado en las tablas de actividad SY00800/SY00801 en la base de datos de Dynamics.
Solución
Nota:
Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que puede restaurar si se produce un problema.
Para resolver este problema, vuelva a crear la tabla Maestra de definiciones de publicación (SY00500). Para ello, puede usar cualquiera de las dos opciones. Los pasos de la opción 1: Usar el mantenimiento de archivos eliminan todos los registros por lotes que se encuentran en la tabla principal de Definiciones de Publicación. Los pasos descritos en opción 2: Use el kit de herramientas gratuito de la Biblioteca de herramientas de servicios profesionales mantienen los registros por lotes existentes mediante la herramienta Biblioteca de herramientas de servicios profesionales (PSTL). Esta herramienta le ayudará a volver a crear la tabla Master de definición de publicación y volver a crear los procedimientos almacenados y los procedimientos automáticos sin perder datos.
Opción 1: Usar el mantenimiento de archivos
Haga que todos los usuarios salgan de Microsoft Dynamics GP.
En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en SQL.
En la lista Base de datos , seleccione la base de datos de la empresa.
En la lista de tablas, haga clic en Maestra de definiciones de publicación. (que es la tabla SY00500)
Haga clic para activar las siguientes casillas:
- Recompilar
- Actualizar estadísticas
- Colocar tabla
- Crear tabla
- Eliminar procedimiento automático
- Crear procedimiento automático
Haga clic en Procesar.
Vuelva a crear los lotes para cada módulo en el que tenga lotes sin publicar. Para ello, siga los pasos de cada módulo.
Contabilidad general
- En el menú De Microsoft Dynamics GP , seleccione Herramientas, Utilidades, Finanzas y, a continuación, haga clic en Reconciliar.
- En el cuadro de diálogo Conciliar información financiera , haga clic para activar la casilla Lotes y, a continuación, haga clic en Reconciliar.
- Cuando se le pida que imprima el informe registro de errores, haga clic en Cancelar.
Administración de pagaderos
En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
En la lista Serie , haga clic en Comprar.
Nota:
Si no usa el módulo Multicurrency, vaya al paso 7.
En la lista Tablas lógicas , seleccione Archivos lógicos del historial de pagaderos y, a continuación, haga clic en Insertar.
Haga clic en Aceptar.
En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Cierre el cuadro de diálogo Informe de errores de mantenimiento de archivos .
En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
En la lista Serie , haga clic en Comprar.
En la lista Tablas lógicas , seleccione Archivo lógico de transacciones pagaderas y, a continuación, haga clic en Insertar.
Haga clic en Aceptar.
En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Procesamiento de pedidos de compra
- En el menú Archivo , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
- En la lista Serie , haga clic en Comprar.
- En la lista Tablas lógicas , seleccione Comprar transacciones y, a continuación, haga clic en Insertar.
- Haga clic en Aceptar.
- En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Administración de cobros
- En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
- En la lista Serie , haga clic en Ventas.
- En la lista Tablas lógicas, seleccione Archivos de Transacciones Abiertas de Cobros y, a continuación, haga clic en Insertar.
- Haga clic en Aceptar.
- En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Facturación
- En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
- En la lista Serie , haga clic en Ventas.
- En la lista Tablas lógicas , seleccione Trabajo de factura y, a continuación, haga clic en Insertar.
- Haga clic en Aceptar.
- En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Procesamiento de pedidos de ventas
- En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
- En la lista Serie , haga clic en Ventas.
- En la lista Tablas lógicas , seleccione Sales Work (Trabajo de ventas) y, a continuación, haga clic en Insertar.
- Haga clic en Aceptar.
- En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Inventario
- En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
- En la lista Serie , haga clic en Inventario.
- En la lista Tablas lógicas , seleccione Trabajo de transacción de inventario y, a continuación, haga clic en Insertar.
- Haga clic en Aceptar.
- En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
- En el menú Transacciones , seleccione Inventario y, a continuación, haga clic en Lotes.
- Haga clic en el botón de registro siguiente para mostrar el primer lote de inventario.
- Haga clic para activar la casilla Publicar en Libro de contabilidad general .
- Repita los pasos 7 y 8 para cada lote.
Lista de materiales
- En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos.
- En la lista Serie , haga clic en Inventario.
- En la lista Tablas lógicas , seleccione Lista de transacciones de materiales y, a continuación, haga clic en Insertar.
- Haga clic en Aceptar.
- En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Contabilidad de proyecto
En el menú Microsoft Dynamics GP , seleccione Mantenimiento y, a continuación, haga clic en Comprobar vínculos de PA.
En la lista Tablas lógicas , haga clic en la primera tabla que aparece y que corresponda a un tipo de transacción contabilidad de proyectos que use. A continuación, haga clic en Insertar.
En la tabla siguiente se enumeran los tipos de transacción y las tablas disponibles en Contabilidad de proyectos.
Tipo de transacción Tabla Parte de horas Transacciones del parte de horas de PA Registro de equipos Transacciones del registro de equipos de PA Registro varios Registro varios de PA Transferencia de inventario Transacciones de transferencia de inventario de PA Transacciones de compra Transacciones de compra de PA Reconocimiento de ingresos Transacciones de recogción de ingresos de PA Gastos de empleado Transacciones de gastos de empleado de PA Lotes de facturación Transacciones de facturación de PA Repita el paso 2 seleccionando la siguiente tabla aplicable que aparece en ese paso. Repita el paso 2 tantas veces como sea necesario para insertar todas las tablas aplicables. A continuación, haga clic en Aceptar.
En el cuadro de diálogo Destino de informe , haga clic para activar la casilla Pantalla y, a continuación, haga clic en Aceptar.
Opción 2: Usar el kit de herramientas gratuito de la Biblioteca de herramientas de servicios profesionales
Obtenga la herramienta Biblioteca de herramientas de servicios profesionales (PSTL) para Microsoft Dynamics GP 2010 o para Microsoft Dynamics GP 10.0.
Para obtener más información sobre la biblioteca de herramientas de servicios profesionales, use una de las siguientes opciones:
Clientes: para obtener más información sobre RTC, póngase en contacto con su asociado de registro. Si no tiene un asociado de registro, visite el siguiente sitio web para identificar a un asociado: Microsoft Pinpoint
Asociados: para obtener más información sobre RTC, visite el siguiente sitio web:
Instale la herramienta PSTL.
Una vez completada la instalación, inicie Microsoft Dynamics GP.
Cuando se le pida que incluya un nuevo código, haga clic en Sí.
Inicie sesión en Microsoft Dynamics GP como administrador del sistema (sa).
Para agregar la herramienta PSTL a la barra de acceso directo, haga clic en Agregar, haga clic en Otra ventana, expanda Herramientas de servicio técnico, expanda Proyecto, haga clic en Biblioteca de herramientas profesionales, haga clic en Agregar y luego haga clic en Listo.
En la barra de acceso directo, haga clic en Herramientas de servicio profesional.
Nota:
Debe esperar a que se compilen los objetos SQL.
Cuando reciba el mensaje para escribir las claves de registro, haga clic en Cancelar.
Nota:
No es necesario tener claves de registro para usar toolkit.
Haga clic en Kit de herramientas. Haga clic en Siguiente.
En Opciones del kit de herramientas, haga clic en Volver a crear objetos SQL y, a continuación, haga clic en Siguiente.
En el campo Serie , haga clic en Compañía.
En el campo Tabla , haga clic en SY00500.
En Opciones de mantenimiento, haga clic para activar la casilla Volver a crear tabla seleccionada y, a continuación, haga clic para activar la casilla Volver a crear datos para las tablas seleccionadas .
Haga clic en Realizar mantenimiento seleccionado.
Haga clic en Aceptar cuando reciba los siguientes mensajes:
La tabla se volverá a crear con datos.
SY00500 tabla se volverá a crear con datos. Compruebe que se ha realizado una copia de seguridad antes de continuar.
SY00500 se ha vuelto a crear.
Además, es posible que tenga que volver a crear un desencadenador recomendado por Toolkit. (consulte la opción 3).
Opción 3
Después de volver a generar la tabla SY00500, compruebe si el archivo "glpBatchHeadersDeletetrigger" existe en la tabla. Si no es así, scriptelo desde una instalación en funcionamiento para volver a crearlo.
sp_helptrigger sy00500
Opción 4: Hacer que todos los usuarios cierren sesión completamente en Dynamics GP y borren las tablas de actividad
Estas tablas deben estar vacías cuando todos los usuarios estén fuera.
SELECT * FROM DYNAMICS..ACTIVITY --shows users currently logged into GP
SELECT * FROM DYNAMICS..SY00800
SELECT * FROM DYNAMICS..SY00801
SELECT * FROM TEMPDB..DEX_LOCK
SELECT * FROM TEMPDB..DEX_SESSION
DELETE DYNAMICS..ACTIVITY
DELETE DYNAMICS..SY00800
DELETE DYNAMICS..SY00801
DELETE TEMPDB..DEX_LOCK
DELETE TEMPDB..DEX_SESSION