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La consulta de saldos de existencias de artículos no es correcta en Microsoft Dynamics GP

En este artículo se proporciona una solución a un problema por el que el campo Balance (Saldo) de la línea superior de la ventana de consulta de existencias de artículos no suma correctamente para igualar el monto de la transacción.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 2647425

Síntomas

En Microsoft Dynamics GP, al revisar las cantidades de un elemento en la ventana Consulta de existencias de artículos, el campo Balance de la primera línea transaccional no es igual a la cantidad de esa transacción. Por ejemplo, la primera transacción mostrada es un ajuste de aumento para una cantidad de 5, pero el campo Balance muestra 3.

Causa

Hay muchas cosas que harán que el campo Balance en la ventana de consulta de existencias de artículos sea incorrecto.

  1. El total de existencias en la parte inferior de la ventana es incorrecto. Consulte resolución 1.

  2. La casilla Mantener historial: transacción no se ha marcado de forma coherente para el elemento en Opciones de mantenimiento de elementos. Consulte resolución 2.

  3. Las transacciones históricas se quitaron para este elemento mediante la ventana Quitar historial de transacciones de inventario. Consulte resolución 2.

  4. Una interrupción durante la contabilización provocó que el IV30300 no se actualizara o se actualizara incorrectamente. Consulte resolución 2.

  5. Se ha cambiado la unidad de medida equivalente para este elemento. Consulte resolución 3.

  6. Es un artículo serializado o numerado por lotes, y las cantidades fueron anuladas para vender mercancías que no estaban disponibles en el inventario. Por ejemplo, vendió 10 de un artículo cuando tenía 0 en stock. Consulte resolución 4.

Resolución 1

Para corregir el total de existencias en la parte inferior de la ventana, ejecute la reconciliación de inventario. Para ejecutar La conciliación del inventario en la ventana microsoft Dynamics GP, seleccione Herramientas, utilidades, inventario y, a continuación, seleccione Reconciliar. Inserte el elemento que está revisando en la ventana Consulta y seleccione Procesar.

Resolución 2

Si las transacciones históricas faltan o están incompletas, la ventana de consulta de existencias de artículos no será confiable para este artículo y es posible que tenga que interrumpir su uso. Si no es deseable, es posible que desee empezar de nuevo con el elemento. Para ello, estos son los pasos recomendados.

  1. Si hay cantidades que no están a mano, escriba y publique las transacciones de transferencia de inventario para moverlas al cubo de cantidad a mano.

  2. Nota:

    La cantidad disponible del inventario para el artículo, para luego registrar y publicar una transacción de disminución del inventario, para llevar esa cantidad a 0.

  3. Use Remove Inventory Transaction History (Quitar historial de transacciones de inventario) para quitar todo el historial transaccional de este elemento.

  4. En este momento, la ventana de consulta stock de artículos tendrá 0 Stock Total y 0 cantidad Balance. Compruebe que la casilla Mantener historial: transacción esté marcada en la ventana Opciones de mantenimiento de elementos para mantener esta información en el futuro.

  5. Registre una transacción de ajuste de inventario para aumentar la cantidad disponible hasta alcanzar el nivel adecuado.

    La ventana Consulta de existencias de artículos ahora será correcta.

    Nota:

    Puede ser posible manipular los datos del back-end mediante SQL para corregir esta ventana.

    Clientes:
    Para obtener más información sobre los servicios de consultoría de manipulación de datos, póngase en contacto con su asociado de registro Si no tiene un asociado de registro, visite Microsoft Pinpoint para identificar a un asociado.

    Asociados:
    Para obtener más información sobre los servicios de consultoría de manipulación de datos, póngase en contacto con Microsoft Advisory Services en 800-MPN-SOLVE.

Resolución 3

Si se han cambiado unidades de medida equivalentes, la ventana Consulta de existencias de artículos no será confiable para este artículo y es posible que tenga que detener su uso. Si no es deseable, es posible que desee empezar de nuevo con el elemento. Consulte los pasos descritos en resolución 2 para conocer los pasos recomendados para hacerlo.

Resolución 4

Teniendo en cuenta que, al anular un artículo serializado o con número de lote, tu cantidad disponible no se vuelve negativa, la venta de esos 10 dejó tu cantidad disponible en 0. Al introducir la cantidad (supongamos que 10), aumenta la cantidad a mano en lugar de consumir la anulación. Ahora la cantidad en existencia está sobrevalorada en 10 que anulaste. Para corregirlo y la ventana de consulta de stock de artículos, siga estos pasos:

  1. Escriba y publique una transacción de disminución para sacar esos 10 de su inventario, de modo que la cantidad disponible ahora sea correcta. Normalmente, la disminución no se publicaría en General Ledger.

  2. Use Remove Transaction History (Quitar historial de transacciones) para quitar la transacción realizada en el paso A del historial de inventario. En la ventana Quitar historial de transacciones de inventario, elija Número de documento en el rango e inserte el número de documento de la transacción del paso A. Luego, procese.

La ventana de consulta de existencias de artículos y la cantidad disponible ahora estarán correctos.

Más información

La columna Saldo de esta ventana se calcula a partir de la cantidad del campo Total de existencias en la parte inferior. Se calcula a partir de los campos de cantidad en la tabla IV00102 (Maestro de Cantidad de Artículos). Por lo tanto, si estas cantidades son incorrectas, el total de existencias también será incorrecto. Esto significa que el saldo calculado probablemente también será incorrecto.

Una vez determinado el número total de existencias, AGREGAMOS las transacciones que reducen la cantidad del artículo y restamos las transacciones que aumentan la cantidad, trabajando desde la parte inferior de la ventana hasta la parte superior, para determinar lo que se muestra en el campo Saldo. Las transacciones que usamos se almacenan en la tabla IV30300 (Historial de cantidades de transacciones de inventario).

Para determinar si faltan transacciones u otras en la tabla IV30300 que están causando discrepancias para el artículo, compare los flujos de entrada en la IV30300 con los recibos de compra en la tabla IV10200 (Trabajo de Recibos de Compra de Inventario). Compare también las transacciones de disminución en el IV30300 con los flujos de salida de la tabla IV10201 (Detalle de recibos de compra de inventario).