Compartir a través de


Se ha producido un error en el script de esta página al iniciar Microsoft Dynamics GP

En este artículo se proporciona una resolución para el problema de que no se puede iniciar Microsoft Dynamics GP debido a que se produjo un error en el script en esta página.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 2702223

Síntomas

Al intentar iniciar Microsoft Dynamics GP, actualice la página principal o acceda a una lista de navegación en la página principal, se muestra un error similar al siguiente:

Se ha producido un error en el script de esta página

Línea: XXX

Carácter: X

Error: El objeto no admite esta propiedad o método

Código: X

Dirección URL: archivo: ///C:/Documents%20and%20Settings/xxxxxxx/Local%Settings/Temp/tmpx.tmp

Causa

Este tipo de error puede deberse a varios motivos, enumerados en Resolución siguiente.

Solución

  1. Se recomienda que todos los usuarios de Microsoft Dynamics GP tengan, como mínimo, permisos de lectura, escritura y modificación; si no, permisos de control total para lo siguiente:

    1. La propia carpeta de código de Microsoft Dynamics GP. De forma predeterminada, será C:\Archivos de programa\Microsoft Dynamics\GP201x.
    2. Cualquier carpeta de red compartida que contenga formularios modificados o archivos de diccionario de informes para Microsoft Dynamics GP.
    3. Directorio TEMP propio del usuario.
  2. Falta la carpeta UserData

    1. En el equipo del usuario, seleccione Iniciar, seleccione Ejecutar, escriba lo siguiente y haga clic en Entrar:

      %appdata%\Microsoft\Internet Explorer

    2. La carpeta UserData es una carpeta del sistema, por lo que es posible que no aparezca. Cómo puede comprobar si existe o no es intentar crear una nueva carpeta UserData, que debe proporcionarle un mensaje que indica que esta carpeta ya existe.

    3. Si la carpeta UserData no existe, créela en esta ubicación.

  3. Usuarios Archivos temporales de Internet

    1. En el equipo que el usuario usa con Microsoft Dynamics GP, seleccione Iniciar, seleccione Panel de control y, a continuación, seleccione Opciones de Internet (también puede acceder a esto en Internet Explorer).
    2. En la ventana de Opciones de Internet, seleccione la pestaña General.
    3. En Historial de exploración, seleccione el botón Eliminar... .
    4. Seleccione las opciones Archivos temporales de Internet, Cookies e Historial, y a continuación, seleccione el botón Eliminar.
    5. También en la sección Historial de exploración, seleccione el botón Configuración y compruebe que la opción Cada vez que visito la página web está seleccionada.
    6. Seleccione Aceptar para cerrar todas las ventanas después de guardar los cambios.
  4. Faltan o están dañados los componentes de Office Web.

    Nota:

    Si ya ha instalado Office Web Components, intente ejecutar una reparación en las instalaciones. Esto resolverá los problemas con las instalaciones.

    Si usa los programas de Office 2007 o 2010, debe instalar Office Web Components para Office 2003.

    Office Web Components para Office 2007 es un Service Pack para Office Web Components para Office 2003. Debe instalar Office Web Components para Office 2003 antes de instalar este Service Pack.

  5. UAC

    1. Si ejecuta Dynamics GP en un sistema operativo más reciente, como Windows 7 o Windows Server 2008, seleccione Panel de control, seleccione Cuentas de usuario.
    2. Seleccione Cambiar configuración de Control de cuentas de usuario.
    3. Si aún no se ha establecido de esta manera, cambie la configuración para que no se notifique nunca y seleccione Aceptar. Esto requerirá un reinicio de la máquina para que se produzcan los cambios.
    4. Una vez reiniciada la máquina, vuelva a iniciar Microsoft Dynamics GP y compruebe si los errores de script permanecen.