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Error "La publicación a nivel de transacción no se ha completado" al usar la ventana de Entrada de transacción de ventas

En este artículo se proporciona una resolución del error que se produce al usar la ventana Entrada de transacción de ventas en Microsoft Dynamics GP.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 853972

Síntomas

Al intentar usar la ventana Entrada de transacción de ventas en Microsoft Dynamics GP, recibirá el siguiente mensaje de error:

La contabilización de nivel de transacción no se ha completado.

La contabilización en el nivel de transacción anterior no ha terminado de procesarse. Espere tiempo para que finalice. Si cree que se ha producido un error, cierre sesión en Microsoft Dynamics GP y vuelva a iniciar sesión para recuperar transacciones.

Este problema se produce para un identificador de usuario específico.

Causa

Este problema puede producirse si existe un registro no válido en la tabla SY00500.

Solución

Para resolver este problema, siga estos pasos;

  1. Haga que el usuario que tenía el problema cerrar sesión en Microsoft Dynamics GP. (Anote el número de documento de la factura del problema).

  2. Abra una ventana de consulta en SQL Server Management Studio mediante el paso adecuado:

    • Si usa Microsoft SQL Server 2005, inicie SQL Server Management Studio. Para ello, seleccione Inicio, Seleccione Programas, Microsoft SQL Server 2005 y, a continuación, seleccione SQL Server Management Studio.
    • Si usa SQL Server 2000, inicie el Analizador de consultas de SQL. Para ello, seleccione Inicio, Seleccione Programas, Microsoft SQL Server y, después, Analizador de consultas.
    • Si usa Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2, inicie SQL Server Management Studio. Para ello, seleccione Inicio, Seleccione Programas, Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2 y, a continuación, seleccione SQL Server Management Studio.
    • Si usa Microsoft SQL Server 2012, inicie SQL Server Management Studio. Para ello, seleccione Inicio, Seleccione Programas, Microsoft SQL Server 2012 y, a continuación, seleccione SQL Server Management Studio.
  3. Ejecute la siguiente instrucción en la base de datos de la empresa y, si encuentra un lote enumerado con el identificador del usuario como el nombre del lote, puede eliminarlo.

    SELECT * from SY00500 whereBACHNUMB = 'xxx'
    Delete SY00500 where BACHNUMB = 'xxx'
    

    donde xxx es el identificador del USUARIO que tenía el problema.

  4. Si el usuario ha cerrado la sesión de Microsoft Dynamics GP, no debe tener ningún registro en las tablas temporales de SY00800 o SY00801. Si lo hacen, quite estos registros bloqueados:

    Select * from DYNAMICS..SY00800 where USERID = 'xxx'
    Select * from DYNAMICS..SY00801 where USERID = 'xxx'
    
    Delete DYNAMICS..SY00800 where USERID = 'xxx'
    Delete DYNAMICS..SY00801 where USERID = 'xxx'
    

    donde xxx es el identificador del USUARIO que tenía el problema.

  5. Ahora haga que el usuario vuelva a iniciar sesión en Microsoft Dynamics GP y revise la transacción o vuelva a escribirla, si es necesario.

Si el problema persiste, consulte "Mensaje de error al intentar abrir la ventana Registro de Transacciones de Ventas en Procesamiento de Pedidos de Ventas en Microsoft Dynamics GP: 'La sesión anterior de publicación a nivel de transacción no ha terminado de procesarse'."