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En este artículo se proporciona una solución a un error que se produce al iniciar Microsoft Dynamics GP.
Se aplica a: Microsoft Dynamics GP
Número de KB original: 916679
Síntomas
Al iniciar Microsoft Dynamics GP, recibirá el siguiente mensaje de error:
Su inicio de sesión ha sido eliminado del archivo de actividad de usuario y no puede acceder al sistema de contabilidad.
Causa
Este problema se produce cuando se publica una actualización automática del cliente. Además, la ruta de acceso del archivo de Microsoft Windows Installer (archivo.msp) es incorrecta o falta el archivo .msp.
Solución
Para resolver el problema, use uno de los siguientes métodos.
Método 1
Si la actualización del cliente ya está instalada en todos los clientes, elimine la actualización de cliente publicada. Para ello, siga estos pasos:
- Inicie sesión en Microsoft Dynamics GP mediante una cuenta de usuario de administrador del sistema (sa).
- Use el paso adecuado:
- En Microsoft Dynamics GP, seleccione Herramientas en el menú Microsoft Dynamics GP, configuración, sistema y, a continuación, seleccione Actualizaciones de cliente.
- En Microsoft Dynamics GP 9.0, sitúe el puntero en Configurar en el menú Herramientas, sitúe el puntero en Sistema y luego seleccione Actualizaciones del cliente.
- En la ventana Administrar actualizaciones automatizadas del cliente, seleccione el icono situado junto al cuadro Nombre de actualización.
- En la ventana Actualizaciones , seleccione la actualización que instaló y, a continuación, seleccione Seleccionar.
- En la ventana Administrar actualizaciones de cliente automatizadas, seleccione Eliminar.
Método 2
Si desea mantener la actualización del cliente, compruebe que el archivo .msp existe y que la ruta de acceso del archivo .msp sea correcta. Para ello, siga estos pasos:
- Inicie sesión en Microsoft Dynamics GP con una cuenta de usuario sa.
- En el menú Herramientas, seleccione Configurar, sistema y, a continuación, seleccione Actualizaciones de cliente.
- En la ventana Administrar actualizaciones de cliente automatizadas, seleccione el icono situado junto al cuadro Nombre de la actualización.
- En la ventana Actualizaciones , compruebe que la ruta de acceso del archivo .msp es correcta. Corrija la ruta de acceso si es incorrecta.
- Compruebe que el archivo .msp está en el directorio al final de la ruta de acceso.
Método 3
Si ningún usuario puede iniciar sesión en el sistema, quite la actualización automática del cliente de la tabla de actualización de cliente automática en la base de datos DYNAMICS. Para ello, siga estos pasos:
Confirme que tiene una copia de seguridad de la base de datos DYNAMICS.
Abra el Analizador de consultas SQL o SQL Server Management Studio.
Para mostrar todas las actualizaciones automáticas de cliente, ejecute la siguiente instrucción SQL.
select * from DYNAMICS..SYUPDATE
Quite la actualización automática del cliente que no tiene un UNCPath válido. Para ello, ejecute el siguiente script.
delete DYNAMICS..SYUPDATE where UPDATENAME = 'XXXX'
Nota:
Reemplace "XXXX" por el nombre de actualización correcto.
Inicie sesión en Microsoft Dynamics GP.
Estado
Microsoft ha confirmado que hay un problema con los productos de Microsoft que aparecen en la sección Se aplica a. Este problema no está programado para corregirse.