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En este artículo se describe cómo resolver el error "El explorador no es compatible o up-to-date" que se produce en una aplicación basada en la Biblioteca de autenticación de Microsoft (MSAL).
Síntomas
Al abrir una aplicación que se integra con MSAL e intenta registrar Microsoft Entra ID Multifactor Authentication (MFA), recibirá el siguiente mensaje de error:
El explorador no es compatible ni actualizado. Intente actualizarlo o descargue e instale la versión más reciente de Microsoft Edge. También puede intentar acceder https://aka.ms/mysecurityinfo desde otro dispositivo.
Causa
Este problema se produce si la aplicación MSAL usa controles de explorador web obsoletos, como WebView1. Estos controles más antiguos no admiten el registro de MFA de Microsoft Entra ID ni el asistente de restablecimiento de contraseña de autoservicio.
Resolución
Para usuarios
Para solucionar este problema, regístrese en Microsoft Entra ID Multifactor Authentication (MFA) mediante un explorador compatible antes de usar la aplicación:
- Abra Mis aplicaciones en Microsoft Edge u otro explorador compatible.
- Complete el proceso de registro de MFA.
- Después del registro correcto, abra la aplicación.
Para desarrolladores
Para resolver este problema, habilite la autenticación de agente mediante el Administrador de cuentas web en la aplicación.
El código de ejemplo siguiente crea un cliente para usar la autenticación de Broker:
var pca = PublicClientApplicationBuilder.Create("client_id").WithBroker(new BrokerOptions(BrokerOptions.OperatingSystems.Windows))
Si el Administrador de cuentas web no está disponible (por ejemplo, en Windows Server 2012), considere la posibilidad de usar el explorador del sistema predeterminado para la autenticación.
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