Configuration Manager clientes reinstalan cada cinco horas y pueden provocar una actualización de cliente involuntaria
En este artículo se describe un problema en system center 2012 Configuration Manager cliente y cliente de System Center 2012 R2 Configuration Manager cliente que podría provocar una actualización de cliente involuntaria en un entorno Configuration Manager rama actual o rama de mantenimiento a largo plazo (LTSB).
Versión original del producto: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Número de KB original: 4018655
Resumen
La instalación de cliente de Configuration Manager (CCMSetup) produce un error inicial y hace que se registre una tarea de reintento de cliente en el Programador de tareas de Windows. Una vez que la instalación del cliente se realiza correctamente, la tarea de reintento no se elimina según lo esperado. Por lo tanto, los clientes continúan reinstalándose cada cinco horas.
En esta situación, si actualiza la infraestructura de Configuration Manager a Configuration Manager rama actual o LTSB y no actualiza los clientes de Configuration Manager, la tarea de reintento programada sigue obligando a reinstalar un cliente cada cinco horas.
La próxima vez que se ejecute CCMSetup, los clientes encontrarán un punto de administración o punto de distribución actualizado y reinstalan el software cliente. Esto actualiza los clientes a Configuration Manager.
Estas actualizaciones continuas se producen fuera del proceso de actualización normal configurado por el administrador. Esto incluye la característica de piloto de cliente.
Síntomas
En un entorno de Microsoft System Center 2012 o System Center 2012 R2, observa los síntomas siguientes:
- Los clientes se reinstalan correctamente cada cinco horas. Esta actividad se registra en los registros de eventos ccmsetup.log y Windows.
- Al ver la carpeta \Microsoft\Microsoft\ConfigurationManager en el Programador de tareas, se encuentra una tarea denominada Configuration Manager tarea de reintento de cliente.
Causa
Este problema se produce porque CCMSetup crea la tarea de reintento de cliente en la carpeta incorrecta del cliente. Esto impide que CCMSetup pueda localizar y quitar la tarea.
La tarea programada se crea en la carpeta \Microsoft\Microsoft\Configuration Manager en lugar de en la carpeta \Microsoft\Configuration Manager.
Solución alternativa 1
Quite manualmente Configuration Manager tarea de reintento de cliente de la carpeta \Microsoft\Microsoft\Configuration Manager mediante el Programador de tareas.
Solución alternativa 2
Implemente un script para quitar Configuration Manager tarea de reintento de cliente de la carpeta \Microsoft\Microsoft\Configuration Manager.
Ejemplo Windows PowerShell comandos para agregar al script:
get-scheduledtask -taskname "Configuration Manager Client Retry Task"
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false
Más información
En Configuration Manager rama actual, versión 1602 y versiones posteriores, y en la versión 1606 de LTSB, Ccmsetup quita correctamente la tarea programada después de actualizar los clientes.