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En este artículo se corrige un problema en el que no se pueden administrar imágenes de arranque en Configuration Manager si el servicio WIMMount está dañado, mal configurado o falta.
Versión original del producto: Configuration Manager (rama actual), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Número de KB original: 4096324
Síntomas
En un entorno con Windows Assessment and Deployment Kit (ADK) instalado y actualizado en el servidor que hospeda el proveedor de SMS, no puede administrar imágenes de arranque mediante Configuration Manager. Esto incluye las acciones siguientes:
- Actualice las imágenes de arranque en los puntos de distribución.
- Importe nuevas imágenes de arranque.
- Cree nuevas imágenes de arranque mediante el asistente de Microsoft Deployment Toolkit (MDT).
- Modifique imágenes de arranque, como para agregar controladores.
En este escenario, se registra el siguiente error en el archivo SMSProv.log en el servidor de proveedor de SMS:
Proveedor de SMS ExecMethodAsync : SMS_BootImagePackage.PackageID="<Boot_Image_Package_ID>"::RefreshPkgSource~
Clase solicitada del proveedor de SMS =SMS_BootImagePackage~
Proveedor de SMS Claves de número solicitadas =1~
Proveedor de SMS IExtClassManager::ValidateAuthenticationLevel...
Proveedor de SMS CExtProviderClassObject::D oExecuteMethod RefreshPkgSource~
Proveedor de SMS Cargado wimgapi.dll versión 10.0.16299.15 desde la ubicación "C:\Archivos de programa (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\wimgapi.dll"
El índice WIM del proveedor de SMS es 1.
Identificador de idioma de la imagen del proveedor de SMS 1033 y en-US~
Proveedor de SMS Cargó la imagen desde \\<Boot_Image_Path>\boot.wim
La ruta temporal del proveedor de SMS para el archivo WIM es C:\Windows\TEMP\BootImages\{<Random_GUID>}\temp.
Proveedor de SMS Cargó el índice de imagen 1.
Error> del proveedor de SMS al montar el archivo wim, err=-1052638943~
Proveedor de SMS ~*~*~.. \sspbootimagepackage.cpp(5198) : no se pudieron insertar archivos binarios de OSD en un archivo WIM montado (a menudo ocurre si los controladores sin firmar se insertan en la imagen de arranque x64)~**~
Proveedor de SMS ~*~*~No se pudieron insertar archivos binarios de OSD en un archivo WIM montado (a menudo sucede si los controladores sin firmar se insertan en la imagen de arranque x64) ~*~*~
Al ejecutar manualmente DISM.exe en el servidor de proveedor de SMS, se registra el siguiente error en el archivo DISM.log:
DISM DISM.EXE: Comandos registrados correctamente para el proveedor: Administrador de compatibilidad.
[10780] [0x8007007b] OpenFilterPort:(408): la sintaxis de nombre de archivo, nombre de directorio o etiqueta de volumen es incorrecta.
[10780] [0x8007007b] FltCommVerifyFilterPresent:(502): la sintaxis de nombre de archivo, nombre de directorio o etiqueta de volumen es incorrecta.
[10780] [0x8007007b] WIMMountImageHandle:(1089): la sintaxis de nombre de archivo, nombre de directorio o etiqueta de volumen es incorrecta.
[10780] [0x80070002] StateStoreRemoveMountedImage:(1030): El sistema no encuentra el archivo especificado.
[10780] [0x80070002] WIMMountImageHandle:(1331): El sistema no encuentra el archivo especificado.Proveedor DE WIM DISM: PID=10780 TID=1096 "No se pudo montar la imagen". - CWimImageInfo::Mount(hr:0x8007007b)
Proveedor DISM DISM WIM: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2684 - CWimManager::InternalOpMount(hr:0x8007007b)
DISM DISM WIM Provider: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:4028 - CWimManager::InternalCmdMount(hr:0x8007007b)
Proveedor DISM DISM WIM: PID=10780 TID=1096 "Error al ejecutar el comando" - CWimManager::InternalExecuteCmd(hr:0x8007007b)
Proveedor DISM DISM WIM: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2201 - CWimManager::ExecuteCmdLine(hr:0x8007007b)
Nota:
El uso del Monitor de procesos al ejecutar MANUALmente DISM no puede identificar qué archivo o directorio no se encuentra.
Causa
Este problema se produce si el servicio WIMMount está dañado, mal configurado o falta en el servidor de proveedor de SMS.
Para comprobarlo, compruebe la siguiente entrada del Registro en el servidor que hospeda el proveedor de SMS:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WIMMount\ImagePath
El valor de esta entrada debe ser la ubicación del archivo Wimmount.sys, que se encuentra en el directorio de instalación de Windows ADK.
Nota:
Es posible que el servidor que hospeda el proveedor de SMS no sea el sitio de administración central o el servidor de sitio primario. Si hay varios servidores que hospedan el proveedor de SMS, asegúrese de comprobar esta entrada del Registro en todos los servidores del proveedor de SMS.
Para buscar los servidores que hospedan el proveedor de SMS en un sitio, siga estos pasos:
- En la consola de Configuration Manager, vaya a Administración>Información general>sitios de configuración>del sitio.
- Haga clic con el botón derecho en el sitio y seleccione Propiedades.
- En la pestaña General , busque los servidores que aparecen en Ubicación del proveedor de SMS.
Solución
Para corregir el problema, siga estos pasos para volver a instalar el servicio WIMMount:
En el servidor que hospeda el proveedor de SMS, vaya a la ubicación donde está instalado Windows ADK. Por ejemplo, la ruta de acceso predeterminada de Windows ADK 10 es
C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64
.Vaya a la carpeta DISM y ejecute el siguiente comando:
WimMountAdkSetupAmd64.exe /Install