Compartir a través de


Sysprep no se ejecutará correctamente en un dispositivo Windows 10 que se haya inscrito mdm

En este artículo se proporcionan sugerencias para solucionar problemas cuando Sysprep no se ejecutará correctamente en un dispositivo Windows 10 inscrito en la administración de dispositivos móviles (MDM).

Síntoma

Se le indica que ejecute la herramienta Preparación del sistema (Sysprep) en un sistema operativo (SO), como una imagen o una máquina virtual (VM), antes de clonarla. Al ejecutar Sysprep, espera que el proceso de generalización quite toda la información única de la máquina original en la que se creó.

Sin embargo, esta eliminación no se produce para varios elementos clave:

  • Certificados de inscripción de MDM (como Intune), identificadores, configuración, etc.

  • Microsoft Entra unirse o Microsoft Entra certificados e identificadores de inscripción de dispositivos.

Este problema provoca problemas importantes para MDM, ya que varios dispositivos reciben los mismos identificadores y no reciben la configuración necesaria del servidor MDM.

Causa

Al ejecutar Sysprep para generalizar un equipo, se permite a todos los componentes de Windows la oportunidad de quitar información del sistema, como claves del Registro, certificados, archivos, carpetas, etc. cualquier cosa que el componente sepa provocará problemas si esa instalación se ha clonado alguna vez.

Pero eso no significa que todos los componentes quiten la información.

Ejemplo: si une una instalación de Windows 10 a Microsoft Entra ID o la inscribe en Intune, el sistema operativo recibirá varios certificados asociados al dispositivo específico. La información adicional de inscripción e identificador de dispositivo se escribirá en una variedad de lugares del registro y, a continuación, se aplicarán tanto la información de directiva como la configuración. Como resultado, el proceso de generalización o sysprep no quitará ninguna de esa información.

Solución

Para poder duplicar o clonar una instalación de Windows (ya sea duplicando físicamente la unidad de disco, o mediante una instantánea basada en máquina virtual o una técnica de disco de diferenciación), el sistema debe generalizarse mediante Sysprep.exe.

Al implementar una instalación de Windows duplicada o con imágenes, es necesario usar Sysprep antes de la captura de la imagen. Microsoft no proporciona compatibilidad con equipos configurados mediante herramientas de duplicación de SID distintas de Sysprep. Vuelva a sellar o generalice una imagen de Windows antes de capturar e implementar la imagen.

Por ejemplo, cuando se usa la herramienta Sysprep para generalizar una imagen, Sysprep quita toda la información específica del sistema y restablece el equipo. Si transfiere una imagen de Windows a otro equipo, debe ejecutar el comando Sysprep junto con la /generalize opción , incluso si el otro equipo tiene la misma configuración de hardware. El comando Sysprep /generalize quita información única de la instalación de Windows para que pueda reutilizar esa imagen en otro equipo.

Además, nunca clone un dispositivo que esté unido a Microsoft Entra ID o inscrito en un servicio MDM como Intune. De lo contrario, todos los dispositivos que usan esa imagen tendrán el mismo aspecto para el usuario y Intune no podrán distinguirlos cuando todos proporcionen el mismo identificador de dispositivo y certificados.

Al crear una imagen, siga un proceso coherente y repetible (por ejemplo, mediante MDT o ConfigMgr OSD), mientras usa una máquina virtual y ejecuta una secuencia de tareas automatizada que puede completar todo el proceso. No la una a Active Directory ni a Microsoft Entra ID y no establezca la imagen en un estado administrado conjuntamente, ya que ya se inscribiría en Intune. Mantenga la imagen en un grupo de trabajo, realice personalizaciones y ejecute sysprep /generalize al final del proceso.

Para omitir muchos de los problemas que se explican aquí, Microsoft recomienda usar Windows Autopilot para automatizar el proceso.