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Este artículo le ayuda a corregir un problema en el que se produce un error en la inscripción automática basada en directivas de grupo de Windows 10 en Intune con el código de error 0x80180002b en Visor de eventos.
Síntomas
Al intentar inscribir automáticamente un dispositivo Windows 10 mediante la directiva de grupo, experimenta los siguientes problemas:
En Visor de eventos, el siguiente evento se registra en
Applications and Services Logs/Microsoft/Windows/DeviceManagement-Enterprise-Diagnostics-Provider/Admin
:Log Name: Microsoft-Windows-DeviceManagement-Enterprise-Diagnostics-Provider/Admin Source: DeviceManagement-Enterprise-Diagnostics-Provider Event ID: 76 Level: Error Description: Auto MDM Enroll: Failed (Unknown Win32 Error code: 0x80180002b)
Al ejecutar el
dsregcmd /status
comando en el dispositivo afectado, el valor deAzureAdPrt
es NO. Esto indica que el usuario no está autenticado en el identificador de Entra de Microsoft al iniciar sesión en el dispositivo.Además, los valores de
TenantId
yAuthCodeUrl
son incorrectos.
Causa
Este problema se produce cuando el dispositivo se ha unido previamente a un inquilino diferente y no se ha unido correctamente al inquilino. En este caso, los valores de la siguiente clave del Registro todavía contienen la información sobre el inquilino anterior:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CloudDomainJoin\TenantInfo\<TenantId>
Los AuthCodeUrl
valores y AccessTokenUrl
de esas claves del Registro se usan para obtener un token de actualización principal (PRT). Dado que los valores son incorrectos, AzureAdPrt
se establece en NO.
Solución
Siga estos pasos para corregir el problema.
En el dispositivo afectado, abra una ventana del símbolo del sistema con privilegios elevados y, a continuación, ejecute el
dsregcmd /leave
comando .Elimine el dispositivo en microsoft Entra ID.
Desencomprima el dispositivo del dominio de Active Directory local. A continuación, elimine el objeto de dispositivo del controlador de dominio.
Vuelva a unir el dispositivo al dominio de Active Directory local. A continuación, inicie manualmente un ciclo de sincronización mediante la ejecución del siguiente cmdlet de PowerShell:
Start-ADSyncSyncCycle -PolicyType Delta
Ejecute el
dsregcmd /status
comando en el dispositivo y compruebe que yAzureAdJoined
DomainJoined
están establecidos en Sí.Cierre sesión en el dispositivo y vuelva a iniciar sesión para obtener un PRT.
Ejecute el
dsregcmd /status
comando en el dispositivo y compruebe queAzureAdPrt
está establecido en Sí y que la información del inquilino es correcta.Ejecute el
gpupdate /force
comando para forzar una actualización de toda la configuración de directiva de grupo. A continuación, compruebe que el dispositivo está inscrito correctamente en Intune.