Compartir a través de


Un programa de Office es lento o puede dejar de responder (bloquear) al abrir un archivo desde una ubicación de red

Síntomas

Cuando intenta abrir un archivo desde una ubicación de red en uno de los programas de Microsoft Office como PowerPoint 2003, Excel 2003, Publisher 2003 o una versión posterior de ellos, el programa de Office puede ejecutarse muy lentamente o puede parecer dejar de responder (bloquear).

Causa

Este comportamiento puede producirse si la conexión a la ubicación de red se pierde durante el tiempo en que el programa de Office está abriendo el archivo.

Solución

Importante

Esta sección, método o tarea contiene pasos que indican cómo modificar el registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrate de seguir estos pasos cuidadosamente. Para mayor protección, realice una copia de seguridad del registro antes de modificarlo. Luego, puedes restaurar el registro si ocurre un problema. Para obtener más información sobre cómo hacer una copia de seguridad y restaurar el registro, consulta Cómo hacer una copia de seguridad y restaurar el registro en Windows.

Para solucionar este comportamiento, agregue el valor EnableShellDataCaching al Registro de Microsoft Windows. Para hacer esto, sigue estos pasos:

  1. Cierre los programas de Office.

  2. Haga clic en Inicio y luego en Ejecutar.

  3. En el cuadro Abrir, escriba regedit y luego haga clic en Aceptar.

  4. Busque y haga clic para seleccionar una de las siguientes claves del Registro en consecuencia:

    • Aplicaciones de Microsoft 365, Office LTSC 2021, Office 2019 y Office 2016:

      HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Open Find

    • Office 2013:

      HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Open Find

    • Office 2010:

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find

    • Office 2007:

      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find

    • Office 2003:

      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

  5. Después de seleccionar la clave especificada en el paso 4, seleccione Nuevo en el menú Editar y, a continuación, haga clic en Valor DWORD.

  6. Escriba EnableShellDataCaching y presione ENTRAR.

  7. Haga clic con el botón derecho en EnableShellDataCaching y, a continuación, haga clic en Modificar.

  8. En el cuadro Datos de valor , escriba 1 y, a continuación, haga clic en Aceptar.

    Nota:

    Cualquier número distinto de cero en el cuadro Datos de valor activará el almacenamiento en caché. Un número cero o en blanco (valor predeterminado) desactivará el almacenamiento en caché.

  9. En el menú Archivo , haga clic en Salir para salir del Editor del Registro.

¿Esta información le ha ayudado a solucionar el problema?

Compruebe si el problema se ha corregido. Si se ha corregido el problema, ha terminado con esta sección. Si el problema no se soluciona, puede ponerse en contacto con el soporte técnico.

Información adicional

Esta situación puede producirse después de hacer clic en Abrir en el cuadro de diálogo Abrir (en el menú Archivo , haga clic en Abrir) para abrir un archivo desde una ubicación de red (por ejemplo, un servidor de red). Durante el proceso de apertura del archivo, pierdes la conexión de red o la ubicación de red que contiene el archivo que intentas abrir se cae. Durante el proceso de abrir el archivo, el programa de Office intenta agregar el nombre de archivo y la información de ruta de acceso del archivo que está intentando abrir en la lista de archivos recientes de Windows. Dado que la ubicación de red (ruta de acceso) ya no existe, el programa de Office puede ejecutarse lentamente y puede parecer dejar de responder (bloquear).

Nota:

Esta situación también puede producirse si la conexión a la red es lenta porque el programa de Office tiene que realizar varias consultas en la red para obtener la información de archivo correcta.