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Error "Se ha producido un error durante el inicio de sesión" al acceder a la aplicación Dynamics 365 para Outlook

Se aplica a: Aplicación de Dynamics 365 para Outlook
Número de KB original: 3064194, 4035750

En este artículo se proporcionan soluciones a los siguientes errores de inicio de sesión que pueden producirse al acceder a La aplicación de Microsoft Dynamics 365 para Outlook.

Error 1

Al intentar abrir la aplicación dynamics 365 para Outlook mientras usa Outlook en el escritorio, la web o el dispositivo móvil, es posible que reciba el siguiente mensaje de error:

Algo salió mal durante el inicio de sesión. Vuelve a intentarlo de nuevo. Si el problema continúa, póngase en contacto con el administrador del sistema.

Causa 1

La aplicación Dynamics 365 para Outlook no se puede conectar al servicio de autorización para asegurarse de que está autorizado para usar esta aplicación.

Solución

Para resolver este problema, primero puede intentar cerrar y volver a abrir la aplicación. Si el problema persiste, intente cerrar y volver a abrir el explorador de Internet. Si el problema continúa, pruebe las siguientes opciones para asegurarse de que las direcciones URL usadas por Dynamics 365 y las direcciones URL de autenticación usan el mismo nivel de integridad.

Opción 1: Agregar cada una de las direcciones URL de Dynamics 365 y las direcciones URL de autenticación a la misma zona de seguridad en Internet Explorer
  1. En Internet Explorer, seleccione Herramientas>Opciones de Internet.

  2. Seleccione la pestaña Seguridad , seleccione la zona Sitios de confianza y, a continuación, seleccione Sitios.

  3. En Agregar este sitio web a la zona, escriba las siguientes direcciones URL una a la vez:

    *.dynamics.com
    *.microsoftonline.com
    https://login.windows.net

    Importante

    Si usa la autenticación federada para acceder a Dynamics 365 mediante sus credenciales corporativas, también debe agregar las direcciones URL de autenticación usadas por la empresa. Por ejemplo, si la empresa usa Servicios de federación de Active Directory (AD FS) (AD FS) con una dirección URL de autenticación de https://adfs.contoso.com/..., agregue esta dirección URL a la misma zona o asegúrese de que ambas zonas tengan la misma configuración modo protegido.

  4. Seleccione Agregar y, a continuación, seleccione Aceptar para guardar los sitios.

Opción 2: Habilitar el modo protegido en cada zona de seguridad de Internet Explorer

Al habilitar el modo protegido en cada zona de seguridad de Internet Explorer, cada dirección URL se carga en el mismo nivel de integridad.

  1. En Internet Explorer, seleccione Herramientas>Opciones de Internet.
  2. Seleccione la pestaña Seguridad.
  3. Seleccione cada una de las zonas (Internet, Intranet local y Sitios de confianza).
  4. Al seleccionar cada zona, compruebe que la casilla Habilitar modo protegido está activada.
  5. Seleccione Aceptar para cerrar el cuadro de diálogo Opciones de Internet.

Nota:

Cuando el modo protegido está habilitado para una zona de seguridad, las direcciones URL se cargan en el nivel de integridad bajo (más seguro). Cuando el modo protegido está deshabilitado para una zona de seguridad, las direcciones URL se cargan en el nivel de integridad medio. Si una URL no se agrega a las zonas de Sitios de confianza o Intranet local, predeterminadamente se carga en la zona de Internet, que tiene habilitado el modo protegido.

Causa 2

Este problema puede producirse si se cambia la dirección URL de Dynamics 365 (en línea) después de instalar la aplicación Dynamics 365 para Outlook. Por ejemplo, si la dirección URL de Dynamics 365 es https://contosocorp.crm.dynamics.com cuando implementa la aplicación, pero cambia la dirección URL a https://contoso.crm.dynamics.com más adelante.

Para comprobar si esta es la causa del problema, haga clic con el botón derecho en el vínculo Ayuda para resolver este problema en el mensaje de error y compruebe la dirección URL. Si la dirección URL es la dirección URL anterior en lugar de la dirección URL actual de Dynamics 365, podría ser el motivo del error.

Solución

Si cambia la dirección URL de Dynamics 365 (en línea) después de instalar la aplicación Dynamics 365 para Outlook, debe volver a implementar la aplicación:

  1. Un usuario con el rol Administrador del sistema puede volver a implementar la aplicación a los usuarios abriendo la aplicación web de Dynamics 365 y navegando al área de Dynamics 365 App for Outlook en Configuración.

  2. Seleccione los usuarios que deben volver a implementar la aplicación y use uno de los botones Agregar aplicación para volver a implementar la aplicación.

  3. Después de que el estado cambie a Agregado a Outlook, puede comprobar si se ha resuelto el problema. Si ya tiene la aplicación abierta, cierre y vuelva a abrirla.

Error 2

Al intentar abrir la aplicación Dynamics 365 para Outlook mientras usa Outlook en el escritorio, es posible que reciba el siguiente mensaje de error:

¿Tiene problemas para iniciar sesión?
Algo salió mal durante el inicio de sesión. Intente agregar las siguientes direcciones URL a los sitios de confianza:
https://*.dynamics.com
https://login.microsoftonline.com
Si el problema continúa, póngase en contacto con el administrador del sistema.

Causa

Algunas de las direcciones URL necesarias para usar la aplicación dynamics 365 para Outlook están en diferentes zonas de seguridad de Internet Explorer (por ejemplo, zona de intranet local, zona de sitios de confianza o zona de Internet).

Al usar la aplicación dynamics 365 para Outlook en Outlook en el escritorio, Internet Explorer se usa para mostrar el contenido y también redirigirle para autenticarse según sea necesario. Las distintas zonas de seguridad pueden usar diferentes niveles de integridad, en función de si el modo protegido está habilitado para la zona. Si las distintas direcciones URL se cargan con distintos niveles de integridad, impide que la autenticación se pase correctamente de las direcciones URL de autenticación a Dynamics 365.

Solución

Para resolver este problema, use una de las siguientes opciones para asegurarse de que las direcciones URL usadas por Dynamics 365 y las direcciones URL de autenticación usan el mismo nivel de integridad: