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En este artículo se proporcionan las causas y soluciones de los errores que recibe al crear una conexión de flujo de escritorio mediante una credencial de CyberArk en Power Automate para escritorio.
Síntomas
Al crear una conexión de flujo de escritorio mediante una credencial de CyberArk en Power Automate para escritorio, recibirá el siguiente mensaje de error:
Detalles: Error de conexión: [Id.> de máquina de máquina<]. Error de conexión: no se pudo leer el certificado de aplicación. Intente eliminar y volver a crear la aplicación. Id. de correlación: <Id. de> correlación.
Causa
El mensaje de error se produce porque la credencial usada en la conexión no se puede autenticar en la máquina de destino seleccionada.
Solución
Si usa Power Automate para escritorio versión del instalador anterior a la 2.50, puede actualizar a la versión 2.50 o posterior. Después de la actualización, al crear una conexión de flujo de escritorio mediante una credencial de CyberArk, es posible que vea un mensaje de error con detalles específicos sobre lo que salió mal. Los detalles le proporcionarán suficiente información para resolver el problema.
Compruebe las secciones siguientes para ver algunos mensajes de error específicos y sus resoluciones:
"La configuración de la tienda cyberArk es incorrecta. Valide toda la información de conexión".
Este error se produce porque el almacén de CyberArk está mal configurado y no se puede realizar una solicitud válida para CyberArk.
Para resolver este problema, asegúrese de que las opciones de configuración de Power Automate coincidan con las de CyberArk, incluida la dirección del servidor y el identificador de la aplicación. Por ejemplo, el nombre de host del servidor CyberArk debe seguir el https://hostname.com
formato o https://hostname.com:443
. Para obtener más información, consulte Creación de una credencial de CyberArk.
"No se pudo contactar con el almacén de CyberArk. Compruebe la conectividad con el servidor y valide toda la información de conexión".
Este error se produce debido a problemas con la conectividad de red entre la máquina y el servidor CyberArk.
Para resolver este problema:
- Confirme que la máquina puede comunicarse con el servidor CyberArk.
- Asegúrese de que el certificado de servidor sea de confianza instalándolo en el almacén de certificados de entidades de certificación raíz de confianza.
- Asegúrese de que la configuración del proxy o del firewall no impide que los usuarios del servicio Power Automate se conecten al servidor. Para obtener más información, consulte Configuración de Power Automate para escritorio proxy.
"No se encontró el objeto CyberArk o la aplicación usada no tiene permiso para recuperarlo".
Este error se produce porque el nombre del objeto no coincide con un secreto de CyberArk que la aplicación configurada puede recuperar.
Para resolver este problema,
- Use la API Obtener cuentas para obtener una lista de todas las cuentas del almacén.
- Si ningún nombre de cuenta coincide con el nombre del objeto, actualice el nombre del objeto con una cuenta existente o confirme con el equipo de CyberArk que la aplicación tiene acceso a la caja fuerte de CyberArk que contiene el objeto.
"El servidor CyberArk no pudo comprobar el certificado, confirme que el servidor CyberArk está configurado correctamente para la autenticación SSL".
Este problema se produce porque es posible que el proveedor de credenciales de CyberArk Central (CCP) no esté configurado o configurado correctamente.
Para resolver este problema, consulte Error de CCP APPAP330E Error al comprobar los datos de autenticación de la aplicación: No se pudieron obtener los detalles del certificado de cliente.
"No se pudo leer el certificado de aplicación. Intente eliminar y volver a crear la aplicación".
Este mensaje de error significa que el certificado CyberArk no se puede procesar correctamente. Es posible que el certificado de aplicación falte, esté dañado o esté instalado incorrectamente.
Este mensaje suele aparecer incorrectamente para la mayoría de los errores con Power Automate para escritorio versiones anteriores a la versión 2.50. Si usa una versión anterior a la 2.50, pruebe una actualización.
De lo contrario, elimine y vuelva a crear la aplicación en CyberArk como se sugiere en el mensaje de error. Asegúrese de escribir correctamente los detalles de Id. de aplicación, Seguro, Carpeta y Objeto al configurar la conexión.
Otros pasos para solucionar problemas
Si sigue sin tener suficiente información para mitigar el problema, estos son algunos pasos que puede seguir para solucionar el problema:
Intente usar una acción dedicada para obtener un secreto de CyberArk en Power Automate para escritorio con una ejecución local para validar la configuración.
Pruebe a usar un explorador para obtener el secreto de la máquina de destino con uno de los métodos siguientes:
Instale el certificado de cliente necesario para la aplicación en la máquina del almacén de usuarios.
Use el siguiente URI en el explorador y seleccione el certificado adecuado para autenticarse:
https://<hostname>/AIMWebService/api/Accounts?AppId=<appid>&Query=Safe=<safe>;Object=<object>
Si recibe un mensaje de advertencia que indica que el certificado de servidor no es de confianza con uno de los métodos del paso 2, asegúrese de instalar el certificado de servidor en el almacén de certificados de entidades de certificación raíz de confianza.
Intente cambiar el usuario del servicio de Power Automate para escritorio a un usuario que haya recuperado correctamente el secreto con uno de los métodos del paso 2.
Más información
- Creación de una credencial de CyberArk
- Configuración de Power Automate para escritorio proxy
- Configuración de la dirección IP de Power Automate
- Cambio de la cuenta de servicio local
- <Elemento Bypasslist> (configuración de red)
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