Compartir a través de


Error del flujo de escritorio con el código de error SessionCreationTimeout

En este artículo se proporciona una solución a un problema que provoca un error en las ejecuciones desatendidas del flujo de escritorio y recibe el código de error SessionCreationTimeout en Microsoft Power Automate para escritorio.

Se aplica a: Power Automate
Número de KB original: 5016026

Síntomas

Se produce un error en las ejecuciones desatendidas del flujo de escritorio con el código de error SessionCreationTimeout (consulte la captura de pantalla siguiente).

Detalles del código de error SessionCreationTimeout.

Causa

Al crear una sesión de Windows para ejecuciones desatendidas, Power Automate para escritorio tiene un tiempo de espera predeterminado de 3 minutos. Por lo tanto, si una conexión de Escritorio remoto a la máquina tarda más de 3 minutos, se producirá un error en las ejecuciones desatendidas.

Solución

Lo primero que debe hacer es asegurarse de que tiene la versión más reciente de Power Automate para escritorio. Si sigue teniendo el problema, es posible que tenga que aumentar la duración del tiempo de espera de la creación de la sesión de Windows. Tenga en cuenta que estos pasos solo se admiten en las versiones 2.21 o posteriores. Para ello, siga estos pasos:

  1. Abra el Editor del Registro. Para abrirlo, puede abrir el menú Inicio y escribir Ejecutar para obtener la aplicación Ejecutar. Escriba regedit en el campo de texto y seleccione Aceptar.

    Pasos para abrir el Editor del Registro.

  2. En la ruta de acceso Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Power Automate Desktop\Service, cree una nueva DWORD y asígnele el nombre SessionCreationTimeoutSeconds. El valor que debe asignar a él es la duración máxima en segundos permitida para la creación de la sesión. En la captura de pantalla siguiente se muestra un nuevo valor de tiempo de espera de cinco minutos.

    Pasos para crear una nueva sesión DWORD SessionCreationTimeoutSeconds con un valor de tiempo de espera.

  3. Reinicie el servicio Power Automate. Para ello, abra La aplicación Servicios, haga clic con el botón derecho en Servicio Power Automate y seleccione Reiniciar.

    Pasos para reiniciar el servicio Power Automate.