Compartir a través de


Error de perfil temporal durante el registro de la máquina

En este artículo se proporciona una resolución de un error que se produce al intentar registrar una máquina mediante la aplicación de tiempo de ejecución de la máquina de Power Automate.

Se aplica a: Power Automate
Número de KB original: 5007391

Síntomas

Al intentar registrar una máquina mediante la aplicación de tiempo de ejecución de la máquina de Power Automate, recibirá el siguiente mensaje de error:

Error al registrar la máquina. Es posible que Power Automate no se haya instalado correctamente. Siga los pasos descritos en las secciones más información.

Causa

Este problema se produce porque la aplicación Power Automate para escritorio no está instalada correctamente debido a una instalación o desinstalación anterior que coloca el perfil de usuario "NT Service\UIFlowService" en un estado roto.

Solución

Para resolver este problema,

  1. Desinstale Power Automate para escritorio de la máquina y asegúrese de que los archivos relacionados, ubicados en C:\Archivos de programa (x86)\Power Automate Desktop, se eliminan.

  2. Restablezca manualmente el perfil de usuario.

    1. Compruebe la configuración del perfil "UIFlowService":

      Abra el Editor del Registro y vaya a la carpeta de claves:

      Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-80-3017052307-2994996872-1615411526-3164924635-3391446484

      Si existe una segunda clave con la .bak extensión, puede eliminarla.

    2. Vaya a la ubicación de ProfileImagePath.

    3. Compruebe que la carpeta UIFlowService está presente en ese directorio. De forma predeterminada, se encuentra en %SystemRoot%\ServiceProfiles.

    4. Modifique el ProfileImagePath valor para que apunte a la carpeta UIFlowService existente. De forma predeterminada, debe ser %SystemRoot%\ServiceProfiles\UIFlowService.

  3. Reinicie el equipo.

  4. Vuelva a instalar Power Automate para escritorio.