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Solución de problemas de errores de cola de ejecución de flujo de escritorio

En este artículo se proporcionan soluciones en segundo plano y posibles para los errores basados en cola detectados durante las ejecuciones del flujo de escritorio.

Se aplica a: Power Automate
Número de KB original: 5004537

Síntomas

Es posible que el flujo de escritorio no se ejecute con el código NoCandidateMachine de error o con los detalles de error "No se encontró ninguna máquina capaz de ejecutar el flujo de escritorio".

También puede recibir uno de estos códigos de sub-error comunes:

Causa

Cuando no hay máquinas disponibles, Power Automate crea una cola para contener los flujos de escritorio a la espera de ejecutarse. Una vez que una máquina está disponible, se seleccionará la siguiente ejecución de flujo de escritorio para ejecutarse en función de la prioridad y el tiempo de solicitud. Si no hay ninguna máquina disponible después de seis horas desde el momento en que se solicitó, el flujo de escritorio agotará el tiempo de espera y producirá un error con un NoCandidateMachine código de error.

Como se mencionó en el mensaje de error, este error significa que el orquestador no puede encontrar una máquina disponible para ejecutar el flujo de escritorio. Este error se produce antes de que se inicie la ejecución del flujo de escritorio.

Importante

Power Automate escala automáticamente el número de ejecuciones de flujo de escritorio simultáneas al valor máximo admitido. La cola de ejecución de la máquina sigue un enfoque primero en entrar y primero en salir, lo que significa que la primera ejecución recibida es la siguiente que se va a ejecutar. Si todas las máquinas disponibles han alcanzado el máximo de sesiones simultáneas y no pueden ejecutar la siguiente ejecución en la cola, la cola se bloquea hasta que una máquina esté disponible para ejecutar la siguiente ejecución en la cola.

SessionExistsForTheUserWhenUnattended

Este error se produce al intentar ejecutar un flujo de escritorio desatendido en una máquina de destino donde el usuario usado en la conexión de flujo de escritorio ha iniciado sesión.

Solución

Para resolver el problema, cierre la sesión (una sesión bloqueada provocará este error) y confirme que no ha iniciado sesión con el mismo usuario en el equipo.

NoUnlockedActiveSessionForAttended

Este error suele producirse al intentar ejecutar un flujo de escritorio asistido en un equipo de destino que está bloqueado o no tiene ningún usuario que haya iniciado sesión. También puede obtener este error cuando el usuario de Windows en el que ha iniciado sesión actualmente en la máquina de destino no coincide con el usuario que especificó en la conexión. Los flujos de escritorio asistidos solo se pueden ejecutar si la máquina está desbloqueada en una sesión donde el usuario actual coincide con el de la conexión de flujo de escritorio.

Solución

Para resolver el problema:

  • Compruebe las credenciales usadas en la conexión y asegúrese de que son las que se usan en la sesión desbloqueada. Puede comprobar su identidad escribiendo whoami en cualquier símbolo del sistema.
  • Compruebe que tiene como destino la máquina correcta. Para ello, abra la aplicación en tiempo de ejecución de la máquina y seleccione Ver máquina en el portal para comprobar que le lleva a la máquina de destino en la ejecución.
  • Compruebe que la cuenta que ejecuta el servicio Power Automate (UIFlowService) tiene permisos de Escritorio remoto en el equipo. De forma predeterminada, el servicio Power Automate se ejecuta como NT SERVICE\UIFlowService. Si no ha cambiado esto, compruebe que NT SERVICE\UIFlowService se encuentra en el grupo Usuarios de Escritorio remoto . Para ello, vaya a Iniciar>ejecución, escriba usrmgr.msc, seleccione Grupos, haga doble clic en el grupo Usuarios de Escritorio remoto y compruebe que la cuenta está incluida. Si no está incluido, insclúyelo (esto requiere permisos de administrador) y reinicie la máquina.

AttendedUserSessionNotActive

Este error se produce cuando el usuario especificado en la conexión inicia sesión en la máquina de destino, pero la sesión de destino está en un estado bloqueado o desconectado.

Solución

Intente conectarse a la sesión de destino y volver a ejecutar el flujo asistido.

AttendedUserNotLoggedIn

Este error se produce cuando el usuario especificado en la conexión no ha iniciado sesión en la máquina de destino.

Solución

Inicie sesión en la máquina de destino como el usuario especificado en la conexión, deje la sesión activa e intente volver a ejecutar el flujo asistido.

UIFlowAlreadyRunning

Cuando un flujo de escritorio ya se está ejecutando en el equipo, este error puede producirse en una de las situaciones siguientes:

  • Ejecuta un flujo de escritorio desatendido o desatendido y el número de sesiones activas en la máquina ha alcanzado su límite.
  • Intenta abrir una sesión para un usuario que ya ha iniciado sesión.

Solución

Para resolver el problema, espere a que los flujos que ya se están ejecutando se completen o cancele la ejecución del flujo de nube principal.

Otros códigos de error

Para obtener información sobre otros códigos de error que pueden producirse al ejecutar flujos de escritorio y pasos para mitigarlos, consulte Código de error al ejecutar un flujo de escritorio desatendido o desatendido.

Más información

Si no se proporciona el código de sub-error, compruebe si:

  • La máquina o todas las máquinas del grupo de máquinas están sin conexión.

    Inicie la máquina y asegúrese de que Power Automate Desktop esté instalado correctamente y pueda comunicarse con Internet.

  • El grupo de máquinas está vacío.

    Asegúrese de que el grupo de máquinas contiene al menos una máquina antes de asignarle una ejecución de flujo de escritorio.

  • La máquina o todas las máquinas del grupo de máquinas están ocupadas continuamente.

    Si las máquinas no recogen el flujo de escritorio a tiempo, es probable que se deba a que los recursos de máquina asignados no se escalan lo suficiente para satisfacer la demanda de flujo de trabajo. Agregar más máquinas podría ayudar a distribuir la carga de trabajo.

  • No se puede acceder a la máquina debido a problemas de red (incluidos proxy o firewall).

    Trabaje con el administrador de TI para asegurarse de que las máquinas son accesibles.

  • El problema es transitorio.

    Intente cambiar la directiva de reintentos en la configuración de las acciones.

  • La máquina o todas las máquinas del grupo de máquinas no pueden conectarse con el flujo de escritorio.

    Asegúrese de que se cumple uno de los siguientes requisitos:

    • No está intentando ejecutar un flujo desatendido en un grupo en el que todas las máquinas han iniciado sesión.
    • No está intentando ejecutar un flujo asistido en un grupo en el que todas las máquinas están firmadas.
  • La máquina ya no se puede usar.

    Agregue una nueva máquina y actualice las conexiones de flujo de escritorio en los flujos de nube para usar la nueva máquina.

Si tiene una copia de seguridad de los flujos de escritorio en la cola de ejecución debido a uno de los motivos anteriores, puede cancelar de forma masiva las ejecuciones de flujo de escritorio cancelando la ejecución del flujo de nube principal mediante la acción Cancelar ejecución de flujo primario en la página Ejecuciones de flujo de escritorio. Una vez resuelto el problema de la máquina, puede reiniciar esos flujos de nube.