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En este artículo se proporcionan pasos para resolver un problema por el que las interacciones de elementos de la interfaz de usuario no funcionan al ejecutar acciones en Citrix Virtual Apps, aunque los elementos de la interfaz de usuario estén resaltados y capturados correctamente.
Síntomas
Al usar el selector de elementos de la interfaz de usuario para interactuar con Citrix Virtual Apps, puede resaltar y capturar elementos correctamente. Sin embargo, cuando estos elementos capturados se usan en una acción (por ejemplo, Click Element in Window), la interacción no se ejecuta y no se muestra ningún mensaje de error. La funcionalidad Selector de pruebas funciona según lo previsto.
Causa
La configuración de Citrix Workspace de alta resolución PPP (HIDPI) podría interferir con Power Automate para la interacción en el escritorio. Este problema se observa normalmente en las configuraciones que implican varios monitores.
Resolución
Para resolver este problema, siga estos pasos:
Deshabilite la opción HIDPI de Citrix Workspace:
- En la bandeja del sistema, haga clic con el botón derecho en el icono de la aplicación Citrix Workspace.
- Seleccione Preferencias avanzadas>Alta resolución PPP.
- En la configuración de Alta DPI, seleccione la opción Dejar que el sistema operativo ajuste la resolución.
- Seleccione Guardar y cierre las ventanas de preferencias de Citrix Workspace.
Cierre las instancias activas de Citrix Desktop o Virtual Apps.
Reinicie los escritorios Citrix o las aplicaciones virtuales.
(Opcional) Ajuste el escalado de escritorio de la máquina que ejecuta Power Automate para escritorio a 100%. Para las máquinas desatendidas, consulte Establecer la resolución de pantalla en modo desatendido.
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