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Errores que se producen al deshabilitar Salesforce con flujo de servidor a servidor

Este artículo le ayuda a solucionar los errores que pueden producirse al intentar deshabilitar Salesforce con un flujo de servidor a servidor en Microsoft Copilot for Sales.

¿Quién está afectado?

Tipo de requisito Descripción
Aplicación cliente Equipos de Microsoft
Plataforma Clientes web y de escritorio
Sistema operativo Windows y Mac
Implementación Administrado por el usuario y administrado por el administrador
CRM Salesforce
Usuarios Administradores

No se pudieron obtener los detalles de la aplicación conectada para la organización de Salesforce.

Síntomas

Al intentar deshabilitar Salesforce con un flujo de servidor a servidor, puede producirse el siguiente mensaje de error:

No se pudieron obtener detalles sobre la aplicación conectada de la organización Salesforce.

Causa

Cuando se recibe una solicitud de deshabilitación, el servidor intenta eliminar los recursos implementados, como la aplicación conectada y el conjunto de permisos. El error se produce cuando el servidor no puede recuperar la información de la aplicación conectada durante el proceso de eliminación.

Resolución

Para resolver este problema, intente deshabilitar Salesforce de nuevo. Si el problema persiste, recopile los detalles del error y póngase en contacto con el soporte técnico de Microsoft.

No se pudo quitar la aplicación conectada

Síntomas

Al intentar deshabilitar Salesforce con un flujo de servidor a servidor, puede producirse el siguiente mensaje de error:

No se pudo quitar la aplicación conectada. Puede estar configurado como de solo lectura, ausente o restringido.

Causa

Cuando se recibe una solicitud de deshabilitación, el servidor intenta eliminar los recursos implementados, como la aplicación conectada y el conjunto de permisos. El error se produce cuando el usuario actual no tiene permiso para eliminar la aplicación conectada o la aplicación ya se ha eliminado.

Resolución

Para resolver este problema, confirme que existe la aplicación conectada.

  1. Inicie sesión en Salesforce CRM como administrador.

  2. Vaya a Configuración>Aplicaciones>Aplicaciones Conectadas>Administrar Aplicaciones Conectadas.

  3. Confirme que existe la aplicación conectada Copilot for Sales Connected App .

Si este problema persiste, póngase en contacto con el soporte técnico de Microsoft para obtener más ayuda.

No se pudo quitar el conjunto de permisos

Síntomas

Al intentar deshabilitar Salesforce con un flujo de servidor a servidor, puede producirse el siguiente mensaje de error:

No se pudo quitar el conjunto de permisos. Puede ser de solo lectura, faltar o estar restringido.

Causa

Cuando se recibe una solicitud de deshabilitación, el servidor intenta eliminar los recursos implementados, como la aplicación conectada y el conjunto de permisos. El error se produce cuando el usuario actual no tiene permiso para eliminar el conjunto de permisos o el conjunto de permisos ya se ha eliminado.

Resolución

Para resolver este problema, confirme que el conjunto de permisos existe.

  1. Abra la consola para desarrolladores de Salesforce.

  2. Ejecute la consulta siguiente para confirmar que existe el conjunto de permisos:

    SELECT Id, Name, Label, Description FROM PermissionSet WHERE Name = 'CopilotForSalesPermissionSet'
    

Si este problema persiste, póngase en contacto con el soporte técnico de Microsoft para obtener más ayuda.

Error cuando no se puede quitar un recurso

Síntomas

Al intentar deshabilitar Salesforce con un flujo de servidor a servidor, puede producirse uno de los siguientes mensajes de error:

  • No se pudo quitar la asignación del conjunto de permisos debido a una clave de referencia no válida.

  • El identificador de usuario de conexión no se encuentra o ya se ha quitado.

  • No se pudo eliminar la asignación de permisos. Otra cosa depende de ella.

  • No se pudo quitar la asignación de permisos porque el identificador de asignación no existe.

  • No se pudo encontrar la aplicación conectada. Es posible que se haya eliminado anteriormente.

  • No se encontró el conjunto de permisos. Es posible que se haya eliminado anteriormente.

  • No se encontró el usuario de conexión. Es posible que se haya eliminado anteriormente.

Causa

Cuando se recibe una solicitud de deshabilitación, el servidor intenta eliminar los recursos implementados, como la aplicación conectada y el conjunto de permisos. El error se produce cuando ya no existe un recurso o no se puede eliminar debido a dependencias de otros componentes.

Resolución

Para resolver este problema, intente deshabilitar la conexión de nuevo. Si el problema persiste, recopile los detalles del error y póngase en contacto con el soporte técnico de Microsoft.

Información adicional

Si el problema sigue sin resolverse, vaya a Copilot for Sales - Microsoft Community Hub para interactuar con nuestros expertos.

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